Agregar archivos a control de código fuente (Comando, entorno de desarrollo)

Vea también

Copia un archivo o un grupo de archivos de un proyecto del entorno de desarrollo a un proyecto de VSS.

Para utilizar el comando Agregar archivos a control de código fuente

  • Una vez agregado un proyecto del entorno de desarrollo a un control de código fuente, en el menú Herramientas de SourceSafe, haga clic en el comando Agregar archivos a control de código fuente.

Comentario

Puede utilizar el cuadro de diálogo Agregar al control de código fuente para llevar un archivo del entorno de desarrollo a la base de datos del control de código fuente. Sólo puede utilizar este comando con los archivos que ya formen parte del proyecto del entorno de desarrollo. Si desea agregar un archivo que no forma parte de ningún proyecto, primero deberá agregarlo al proyecto del entorno de desarrollo.

Nota Los archivos del entorno de desarrollo ya agregados al proyecto de control de código fuente actual no aparecen bajo Archivos para agregar.

Opciones del cuadro de diálogo

Archivos para agregar

Archivos disponibles para agregarlos a la base de datos de control de código fuente. Haga clic en la casilla de verificación correspondiente a los archivos que desee agregar.

Comentario

Escriba un comentario opcional para todos los archivos seleccionados.

Aceptar

Agrega los archivos al control de código fuente.

Cancelar

Cancela el comando Agregar archivos al control de código fuente.

Seleccionar todo

Selecciona todos los archivos de la lista.


Agregar proyecto al control de código fuente (Comando, entorno de desarrollo)

Vea también

Agrega el proyecto actual del entorno de desarrollo a la base de datos de control de código fuente.

Para utilizar el comando Agregar proyecto al control de código fuente

  • En el menú Herramientas de SourceSafe, haga clic en Agregar proyecto al control de código fuente.

Nota Si especifica el nombre del proveedor de control de código fuente, aparecerá en lugar de "control de código fuente".

Comentario

El comando Agregar proyecto al control de código fuente toma los archivos seleccionados en la ventana del proyecto del entorno de desarrollo y crea con ellos un nuevo proyecto de control de código fuente. Este comando sólo está disponible al seleccionar un proyecto que no se encuentre ya bajo el control de código fuente. En este caso cada archivo seleccionado se agrega automáticamente.


Agregar proyecto a SourceSafe (Cuadro de diálogo, Visual SourceSafe)

Proyecto

Escriba el nombre del proyecto de VSS que desee o bien haga clic en la lista de proyectos para elegir uno de ellos. Puede especificar una ruta de acceso completa (como $/CODIGO/RECURSOS) o simplemente un nombre de proyecto para crear uno nuevo bajo el proyecto actual.

Aceptar

Agrega a VSS el proyecto actual del entorno de desarrollo.

Cancelar

Cancela el comando Agregar proyecto a SourceSafe.

Crear

Crea un nuevo proyecto de VSS. Escriba un nombre bajo Proyecto y haga clic en Crear.


Proteger (Comando, entorno de desarrollo)

Protege las modificaciones realizadas en la carpeta de trabajo del entorno de desarrollo en la base de datos de control de código fuente.

Para usar el comando Proteger

  • En el menú Herramientas de SourceSafe en Visual Basic, haga clic en Proteger.

Opciones del cuadro de diálogo

Archivos para proteger

Presenta una lista con los archivos que pueden ser protegidos. Haga clic en los archivos que quiere proteger o en Seleccionar todo para seleccionar todos los archivos que aparecen en la lista

Comentario

Escriba un comentario opcional.

Mantener desprotegido

Actualiza con los cambios la base de datos de control de código fuente, pero mantiene el archivo desprotegido.

Aceptar

Protege los archivos seleccionados.

Cancelar

Cancela el comando Proteger.


Opciones avanzadas de Desproteger (Cuadro de diálogo)

Establece las opciones predeterminadas del comando Desproteger.

Para mostrar las opciones avanzadas de Desproteger:

  • Haga clic en el botón Avanzadas en el cuadro de diálogo Desproteger.

Opciones del cuadro de diálogo

Reemplazar modificable

Determina el comportamiento de VSS cuando intenta desproteger un archivo marcado como modificable en su directorio de trabajo. Seleccione una de las posibilidades siguientes en el cuadro de lista:

  • Preguntar: Le pregunta lo que debe hacer con cada archivo.

  • Reemplazar: Reemplaza el archivo por una versión de sólo lectura.

  • Saltar: Salta la operación de desprotección.

  • Combinar: combina los cambios entre el archivo desprotegido y el que está obteniendo o desprotegiendo.

  • Predeterminado: Utiliza los valores predeterminados establecidos en la ficha Archivos locales del cuadro de diálogo Opciones de SourceSafe (en el menú Herramientas).

Establecer hora de archivo

Cambia la fecha asociada a la operación de desprotección. Seleccione una de las posibilidades siguientes en el cuadro de lista: Actual, Modificación, Protección o la fecha predeterminada (establecida en la ficha Archivos locales).

No obtener copia local

Indica a VSS que no debe copiar el archivo a su directorio de trabajo. VSS registra la desprotección del archivo pero no le proporciona una copia nueva del mismo.


Desproteger (Comando, entorno de desarrollo)

Vea también

Desprotege una copia del archivo o los archivos seleccionados del proveedor de control de código fuente y la coloca como editable en la carpeta de trabajo correspondiente del entorno de desarrollo.

Para utilizar el comando Desproteger

  • En el menú Herramientas de SourceSafe en Visual Basic, haga clic en Desproteger.

Opciones del cuadro de diálogo

Archivos para desproteger

Muestra los archivos disponibles para su desprotección. Haga clic en los que desee desproteger o en Seleccionar todo para seleccionar todos ellos.

Comentario

Escriba una breve descripción del motivo de la desprotección.

Aceptar

Confirma la desprotección.

Cancelar

Cancela el comando Desproteger.

Seleccionar todo

Selecciona todos los archivos de la lista.


Crear un proyecto local de SourceSafe (Cuadro de diálogo)

Permite al usuario crear un nuevo proyecto de desarrollo a partir un proyecto de VSS existente.

Para usar el comando Descargar proyecto de SourceSafe:

  1. En el menú Archivo haga clic en Abrir espacio de trabajo.

  2. Seleccione el botón Control de código fuente en la esquina inferior derecha del cuadro de diálogo.

Opciones del cuadro de diálogo

Crear un proyecto nuevo en esta carpeta

La carpeta de trabajo correspondiente al proyecto seleccionado. Haga clic en Examinar para crear o cambiar la carpeta de trabajo.

Proyecto de SourceSafe para descargar

lista de proyecto de VSS. Haga clic en el proyecto que desea abrir.

Aceptar

VSS obtiene los archivos, los coloca en el su carpeta de trabajo y abre el proyecto en su entorno de desarrollo con el fin de que pueda modificarlos.

Cancelar

Cancela el comando Descargar proyecto de SourceSafe.


Crear proyecto de SourceSafe (Comando, entorno de desarrollo)

Copia un proyecto al disco duro cuando se encuentra en el control de código fuente, pero no en el disco.

Para utilizar el comando Descargar proyecto de SourceSafe

  • En el menú Herramientas de SourceSafe, haga clic en Descargar proyecto de SourceSafe.

Nota Cuando haya ubicado el proyecto que desee, este comando lo abrirá en el entorno de desarrollo y obtendrá automáticamente todos sus archivos de la base de datos de VSS.


Conectarse a VSS (Cuadro de diálogo)

Permite al usuario seleccionar la ubicación de la base de datos a la que desea conectarse.

Para mostrar el cuadro de diálogo Conectarse a VSS:

  • En el menú Complementos haga clic en SourceSafe y a continuación en Abrir nuevo proyecto de SourceSafe.

Opciones del cuadro de diálogo

Ruta de la base de datos de SourceSafe

Escriba la ruta completa y el nombre de la base de datos de VSS con la que desea conectar. Utilice el botón Examinar para determinar el nombre completo.

Ruta de datos (opcional)

Escriba el identificador deseado para el proyecto de datos. Consulte su administrador de VSS para obtener ayuda acerca del uso de este identificador. (Su administrador de VSS debe establecer este identificador mediante la variable Data_Path).

Aceptar

Conecta con la base de datos especificada, si está disponible.

Cancelar

Cancela la conexión a la base de datos.


Diferencias de archivo (Cuadro de diálogo, Visual SourceSafe)

De forma predeterminada, VSS utiliza la opción de presentación Visual, ajustando el ancho de la línea al ancho de la pantalla y sin líneas de contexto. Si especifica una presentación UNIX, VSS aplicará las opciones Pasar por alto MAY/min e Ignorar espacios en blanco. En la presentación Visual se muestran todas las líneas (contexto infinito).

Visual

Muestra todo el archivo, con anotaciones de los cambios.

SourceSafe

Muestra una lista con las líneas agregadas, eliminadas y modificadas optimizada para su legibilidad.

Unix

Muestra las diferencias con el formato del programa Diff de UNIX.

Pasar por alto MAY/min

Muestra las diferencias sin tener en cuenta la distinción entre mayúsculas y minúsculas.

Ignorar espacios en blanco

Muestra las diferencias sin tener en cuenta los caracteres espaciadores, como los tabuladores.

Informe

Envía un informe al, a un archivo de texto o a una impresora.

Proyecto

Muestra el cuadro de diálogo Diferencias de proyecto.

Opciones avanzadas

Ignorar diferencias del SO

Indica a VSS que debe pasar por alto las diferencias en los caracteres de terminación de línea del sistema operativo. Esta opción es útil al comparar archivos en una red en la que, por ejemplo, un equipo funciona en una plataforma UNIX y otro funciona con Microsoft Windows NT.

Mostrar contexto

Incluye el número de líneas especificado en la presentación de las diferencias. Las líneas de contexto son las que rodean a las que VSS identifica como diferentes. Por ejemplo, si especifica 3 en Mostrar contexto, aparecerán tres líneas por encima y otras tres por debajo de la que contiene la diferencia.

Guardar configuración

Guarda la configuración seleccionada para su uso en el futuro.


Opciones de historial de archivo (Cuadro de diálogo, Visual SourceSafe)

Sólo etiquetas

Sólo incluye las etiquetas en el historial del archivo o el proyecto.

Desde

Indique una hora, una fecha, una versión o una etiqueta. Utilice el prefijo D para indicar una fecha o una hora y el prefijo L para indicar una etiqueta. Por ejemplo, "D29/02/95;12:15" o "LBeta1".

Hasta

Indique una hora, una fecha, una versión o una etiqueta. Utilice el prefijo D para indicar una fecha o una hora y el prefijo L para indicar una etiqueta. Por ejemplo, "D29/02/95;12:15" o "LBeta1".

Usuario

Indique un nombre de usuario para mostrar un historial de los archivos con los que ha trabajado el usuario especificado.

Aceptar

Muestra el cuadro de diálogo Historial de archivo.

Cancelar

Cancela el comando Mostrar historial.

Proyecto

Muestra el cuadro de diálogo Opciones de historial de proyecto. Este cuadro de diálogo contiene las mismas opciones que Opciones de historial de archivo, junto con otras dos: Incluir archivos, que incluye la información de los archivos en la presentación del historial del proyecto, y Recursivo, que incluye los subproyectos con todos sus archivos. Haga clic en Aceptar para mostrar el cuadro de diálogo Historial del proyecto.


Buscar archivo de proyecto (Cuadro de diálogo)

Le permite encontrar un archivo de proyecto de forma que pueda abrirlo bajo control de código fuente.

Una vez encontrado el archivo de proyecto (make file), haga clic en Aceptar para abrirlo bajo control de código fuente o haga clic en Cancelar para cancelar la operación.


Buscar archivo de proyecto (Cuadro de diálogo, entorno de desarrollo)

Identifica el archivo de proyecto del entorno de desarrollo para que el proveedor de control de código fuente pueda realizar sus operaciones correctamente. Sólo aparece al realizar operaciones con proyectos que contienen más de un archivo de proyecto en la misma carpeta.

Opciones del cuadro de diálogo

Seleccionar el archivo de proyecto de Visual Basic

Seleccione el archivo del proyecto del entorno de desarrollo con el que desee trabajar.

Aceptar

Abre el archivo de proyecto seleccionado.

Cancelar

Cancela el comando.


Opciones avanzadas de obtención (Cuadro de diálogo)

Establece las opciones predeterminadas del comando Desproteger.

Para mostrar el cuadro de diálogo Opciones avanzadas de obtención :

  • En el menú Herramientas haga clic en Obtener y a continuación en el botón Avanzadas.

Opciones del cuadro de diálogo

Reemplazar modificable

Determina el comportamiento de VSS cuando intenta obtener un archivo ya marcado como modificable en su directorio de trabajo. Seleccione una de las posibilidades siguientes en el cuadro de lista:

  • Preguntar: Le pregunta lo que debe hacer en cada caso.

  • Reemplazar: VSS reemplaza el archivo por una versión de sólo lectura.

  • Saltar: Salta la operación Obtener.

  • Combinar: combina los cambios entre el archivo desprotegido y el que está obteniendo o desprotegiendo.

Predeterminado: Utiliza los valores predeterminados establecidos en la ficha Archivos locales, mediante el comando Herramientas, Opciones.

Establecer hora de archivo

Cambia la fecha asociada a la operación de obtención. Seleccione una de las posibilidades siguientes en el cuadro de lista: Actual, Modificación, Protección o la fecha predeterminada (establecida en la ficha Archivos locales).

Permitir escribir

Recupera el archivo y permite escribir en él. Esta operación no equivale a una operación Desproteger porque el comando Obtener no es exclusivo, es decir, que más personas pueden ejecutar el comando Obtener sobre el mismo archivo. No puede proteger los cambios después de una operación Obtener con esta opción establecida.


Obtener la última versión (Comando, entorno de desarrollo)

Vea también

Obtiene los archivos seleccionados del proveedor de control de código fuente y coloca un archivo de sólo lectura en el proyecto del entorno de desarrollo.

Para utilizar el comando Obtener la última versión

  • En el menú Herramientas de SourceSafe en Visual Basic, haga clic en Obtener la última versión.

Opciones del cuadro de diálogo

Archivos para obtener/proteger

Selecciona el archivo o los archivos que se desea obtener o proteger.

Aceptar

Confirma las selecciones.

Cancelar

Cancela las selecciones.

Seleccionar todo

Selecciona todos los archivos de la lista.


Opciones de integración (Ficha)

Muestra información acerca de la integración entre su proyecto de Visual Basic y el proyecto de VSS correspondiente.

Para mostrar la ficha Opciones de Integración:

  • En el menú Complementos haga clic en SourceSafe, después en Opciones y a continuación en el botón Avanzadas. En este cuadro de diálogo, seleccione la ficha Integración.

Derechos de acceso

Debe disponer del derecho de acceso de Leer para poder utilizar este cuadro de diálogo.

Comentarios

La principal utilidad de la ficha Opciones de Integración es mostrar cómo están conectados sus proyectos de VSS y de Visual Basic. Sin embargo, puede establecer también un par de opciones en esta ficha: una que especifica si deben mostrarse los cuadros de diálogo intermedios para los comandos Historial y Mostrar diferencias, y otra que especifica si VSS debe preguntar por la base de datos que usará al abrir un proyecto nuevo.

Opciones de la ficha

Proyecto de SourceSafe

Muestra el nombre completo del proyecto de VSS asociado con este proyecto de Visual Basic.

Nombre de la base de datos

Muestra el nombre (en su caso) de la base de datos de VSS en la que está almacenado el proyecto.

Ruta de la base de datos

Muestra la ruta de la base de datos de VSS en la que está almacenado el proyecto.

Especificador de datos

Muestra el directorio de datos correspondiente a un proyecto específico. (Su administrador de VSS puede establecer directorios de datos diferentes para proyectos diferentes mediante la variable Data_Path.)

Mostrar cuadro de diálogo

Active la casilla correspondiente al comando si desea mostrar un cuadro de diálogo de opciones cuando lo selecciona.

Elegir base de datos de SourceSafe

Establezca su valor a Utilizar predeterminada para buscar siempre la información de su proyecto en la base de datos predeterminada de VSS. Establezca la opción Preguntar para mostrar un cuadro de diálogo donde puede especificar el nombre de la base de datos, su ruta y su especificador de datos cada vez que abre un proyecto.

Aceptar

Establece las opciones tal y como se especifican en la ficha.

Cancelar

Cierra la ficha Opciones de Integración.


Opciones (Comando, entorno de desarrollo)

Personaliza el entorno del proveedor de control de código fuente.

Para utilizar el comando Opciones

  • Una vez agregado un proyecto del entorno de desarrollo al proveedor de control de código fuente, haga clic en Opciones en el menú Herramientas de SourceSafe.

Comentario

El comando Opciones muestra el cuadro de diálogo Opciones de control de código fuente.

Opciones del cuadro de diálogo

Para cada opción puede especificar Sí, No o Preguntar.

  • ¿Desea obtener la versión protegida de los archivos al abrir un proyecto? (El valor predeterminado es No).

  • ¿Desea proteger los archivos al cerrar el proyecto? (El valor predeterminado es Preguntar).

  • ¿Desea agregar los archivos al control fuente cuando se agreguen a Visual Basic? (El valor predeterminado es Sí).

  • ¿Desea quitar los archivos del control fuente cuando se eliminen de Visual Basic? (El valor predeterminado es Preguntar).

Avanzadas

Muestra las opciones avanzadas.

Aceptar

Confirma las selecciones.

Cancelar

Cancela las selecciones.


Propiedades (Comando, menú Archivo)

Muestra el cuadro de diálogo Propiedades, que contiene información básica acerca de un archivo o un proyecto de VSS, incluyendo el tamaño, nombre y tipo.

Derechos de acceso

Debe disponer del derecho de acceso Leer para ver el cuadro de diálogo Propiedades.

Debe disponer del derecho de acceso Agregar para cambiar el tipo de un archivo.

Debe disponer del derecho de acceso Destruir para cambiar el estado de Almacenar sólo la última versión de un archivo.

Comentario

Haga clic en la ficha que contiene la información que desea. El contenido de la ficha varía dependiendo si un archivo o un proyecto está seleccionado actualmente en el Explorador de VSS.

Nota Haga clic en el botón Informe de cualquiera de las fichas para crear un informe para enviarlo al Portapapeles, a un archivo de texto o a una impresora.

Fichas del cuadro de diálogo Propiedades de archivo

General

Muestra el nombre de archivo, su tipo, tamaño, el número de la versión más reciente, la fecha de la última modificación, el comentario, además de indicar si todo el historial del archivo (o sólo la última versión) está almacenado en la base de datos de SourceSafe. Puede cambiar el comentario y establecer que se almacene sólo la última versión del archivo para ahorrar espacio de disco. Aquí también puede modificar el tipo de archivo.

Estado de desprotección

Muestra el nombre del archivo, quién lo ha desprotegido (si está desprotegido), si se ha desprotegido de forma exclusiva, cuándo se desprotegió, la versión actual, la ruta de acceso de desprotección (con el nombre del equipo), el proyecto al que pertenece el archivo y el comentario de desprotección. Puede modificar el comentario de desprotección.

Vínculos

Muestra los vínculos compartidos actuales que tiene un archivo con otros proyectos.

Rutas de acceso

Muestra los proyectos que han bifurcado versiones de este archivo anteriormente.


Actualizar estado del archivo (Entorno de desarrollo)

Actualiza la presentación del estado de los archivos en la ventana de proyecto de Visual Basic.

Para utilizar el comando Actualizar estado del archivo

  • En el menú Herramientas de SourceSafe en Visual Basic, haga clic en Actualizar estado del archivo.

Comentario

Utilice este comando cuando haya protegido o desprotegido un archivo o cuando desee comprobar el estado del proyecto en un entorno con múltiples programadores, donde otros usuarios del control de código fuente hayan podido modificarlo.


Ejecutar (Comando, entorno de desarrollo)

Inicia el proveedor de control de código fuente.

Para utilizar el comando Ejecutar

  • En el menú Herramientas de SourceSafe, haga clic en Ejecutar. En algunos casos, puede que necesite escribir su nombre de usuario y (si es necesario) su contraseña y, después, hacer clic en Aceptar.

Comentario

Nota Al utilizar el comando Ejecutar VSS tendrá acceso, a través del Explorador de VSS, a todas las características y comandos de VSS. Los comandos de VSS disponibles en el menú Herramientas son un subconjunto del conjunto completo de comandos de VSS.


Compartir archivos (Comando, entorno de desarrollo)

Convierte el archivo seleccionado en un miembro del proyecto actual o crea un nuevo proyecto bifurcado.

Para utilizar el comando Compartir archivos

Una vez agregado un proyecto del entorno de desarrollo al proveedor de control de código fuente, haga clic en Compartir archivos en el menú Herramientas de SourceSafe.

Comentario

Nota Para compartir un archivo, cree un vínculo compartido entre proyectos. El archivo existe simultáneamente en dos (o más) proyectos. Al protegerlo en uno de ellos, los cambios se protegen automáticamente en todos los demás.

Si crea una bifurcación, los cambios realizados en el archivo bifurcado no se propagarán al proyecto original y viceversa.

Al compartir un proyecto crea bajo un nuevo proyecto bajo el proyecto actual que es un duplicado exacto del proyecto especificado. Todos los archivos del nuevo proyecto se comparten con los correspondientes archivos del proyecto original y los cambios en ellos se reflejan en el proyecto original al protegerlos.

Nota Cuando comparta un proyecto con archivos de formulario de Visual Basic (.FRM), asegúrese de compartir el archivo .FRX asociado por Visual Basic. Si no lo hace, el proyecto compartido no tendrá todos los archivos necesarios y no funcionará correctamente.


Mostrar diferencias (Comando, entorno de desarrollo)

Compara un archivo seleccionado del proyecto del entorno de desarrollo con la versión actual almacenada en la base de datos del proveedor de control de código fuente y muestra las diferencias, si existen.

Para utilizar el comando Mostrar diferencias

  • Una vez agregado un proyecto al proveedor de control de código fuente, en el menú Herramientas de SourceSafe, haga clic en Mostrar diferencias.

Comentario

Normalmente, el comando Mostrar diferencias se utiliza inmediatamente antes de proteger un archivo con el fin de comparar la copia modificada con la copia maestra. De este modo se obtiene una lista con los cambios realizados, lo que puede resultar útil para crear un comentario.

Al utilizar el comando Mostrar diferencias con un archivo de texto ASCII, el proveedor de control de código fuente muestra una lista con códigos de colores que indica las diferencias entre la versión del archivo almacenada en la base de datos y la copia local.

En el caso de archivos binarios, el proveedor de control de código fuente indica si la copia local del archivo es distinta de la copia maestra, pero no puede mostrar las diferencias.


Mostrar historial (Comando, entorno de desarrollo)

Vea también

Muestra el historial de un archivo o un proyecto bajo el control de código fuente.

Para utilizar el comando Mostrar historial

  • Una vez agregado un proyecto de entorno de desarrollo al proveedor de control de código fuente, haga clic en Mostrar historial del menú Herramientas de SourceSafe.

Comentario

Cada vez que protege en el proveedor de control de código fuente un archivo o un proyecto, éste recibirá un nuevo número de versión. Puede utilizar el comando Mostrar historial para obtener una lista de las versiones anteriores del archivo o el proyecto.

Nota De forma predeterminada, el comando Mostrar historial muestra el cuadro de diálogo Opciones de historial de archivo. Haga clic en Proyectos para mostrar el cuadro de diálogo Opciones de historial de proyecto.

Las versiones que aparecen comienzan por la más reciente y llegan hasta la creación del archivo o el proyecto. VSS proporciona información acerca del número de versión, que puede utilizarse con otros comandos (como Obtener la última versión) para indicar una versión determinada.

De forma predeterminada, el historial de un proyecto incluye los historiales de todos sus archivos, pero no es recursivo y no incluye los subproyectos.


Resultados del control del código fuente (Ventana, entorno de desarrollo)

Muestra el resultado del último comando de control de código fuente.

Opciones del cuadro de diálogo

Cerrar

Cierra la ventana Resultados del control del código fuente.


Estado de comandos de SourceSafe (Cuadro de diálogo)

Este cuadro de diálogo aparece brevemente mientras obtiene o desprotege un archivo.

Opciones del cuadro de diálogo

Cancelar

Este botón cancelará la operación de obtención del archivo.


Deshacer desprotección (Comando, entorno de desarrollo)

Sobrescribe las modificaciones realizadas en un archivo y copia la última versión protegida del mismo a la carpeta de trabajo del entorno de desarrollo.

Para utilizar el comando Deshacer desprotección

  • En el menú Herramientas de SourceSafe en Visual Basic, haga clic en Deshacer desprotección.

Opciones del cuadro de diálogo

Deshacer protección de archivos

Muestra los archivos desprotegidos. Haga clic en aquéllos cuya desprotección desee deshacer o en Seleccionar todo para seleccionar todos los archivos de la lista.

Aceptar

Confirma la selección.

Cancelar

Cancela la selección.

Seleccionar todo

Selecciona todos los archivos de la lista.


Visual SourceSafe

Visual SourceSafe (VSS) es la principal herramienta de control de código para código y programadores de Web. Puede almacenar cualquier tipo de archivo. Si desea más información, abra el archivo de Ayuda en su sistema (si ha instalado VSS).


Ya existe una base de datos con este nombre en el proyecto <proyecto> de control de código fuente. ¿Desea volver a conectarse a esta base de datos?

Este mensaje tiene la siguiente causa y solución:

  • Intentó agregar un proyecto, pero ya existe otro proyecto con ese nombre en el control de código fuente.

Haga clic en Sí para volver a conectarse al proyecto existente o haga clic en No si el proyecto del control de código fuente es un proyecto distinto pero con el mismo nombre. Después, elija otro nombre para el nuevo proyecto.


En el proyecto de control de código de fuente <proyecto> ya existe un proyecto con este nombre

Este mensaje tiene la siguiente causa y solución:

  • Intentó agregar una base de datos al control de código fuente en un proyecto existente.

Elija Sí para volverse a conectar al proyecto existente o elija No para cancelar esta operación.


Ya existe un proyecto de VB con este nombre en el proyecto <proyecto> de control de código fuente. ¿Desea volver a conectar este proyecto de VB con el proyecto de control de código fuente existente?

Este error tiene la siguiente causa y solución:

  • Intentó agregar un proyecto, pero ya existe otro proyecto con ese nombre en el control de código fuente.

Haga clic en Sí para volver a conectarse al proyecto existente o haga clic en No si el proyecto del control de código fuente es un proyecto distinto pero con el mismo nombre. Después, elija otro nombre para el nuevo proyecto.


Error al agregar. Los archivos no se agregaron al control de código fuente

Este error tiene la solución siguiente:

  • Abra la aplicación del proveedor de control de código fuente y agregue los archivos al proyecto manualmente.


¿Desea agregar este proyecto a <proyecto>?

Este mensaje tiene la siguiente causa y solución:

  • Creó un nuevo proyecto o abrió un proyecto que no estaba bajo el control de código fuente.

Elija Sí para agregar el proyecto o elija No para cancelar la operación.


¿Desea agregar este proyecto al control de código fuente?

En la mayoría de los casos, haga clic en Sí para mantener sincronizados los proyectos de Visual Basic y del control de código fuente. Puede hacer clic en No si está probando un archivo que desea agregar más tarde o un archivo que no desea agregar.

Haga clic en Sí para agregar el archivo al control de código fuente.

Haga clic en No para agregar el archivo al proyecto de Visual Basic sin agregarlo al proyecto de control de código fuente.


Ya se han agregado todos los archivos disponibles al control de código fuente

Este error tiene la siguiente causa y solución:

  • Todos los archivos del proyecto de desarrollo actual ya se han agregado al control de código fuente.

    Si desea proteger un archivo que no está todavía en el proyecto de desarrollo, agregue primero el archivo al proyecto de desarrollo. VSS le pedirá que lo agregue al control de código fuente.


Ya se han desprotegido todos los archivos disponibles

Intentó desproteger un archivo, pero todos los archivos ya se habían desprotegido.


Todos los archivos disponibles se han agregado al proyecto de control de código fuente

Se ha agregado todos los archivos del proyecto de Visual Basic al proveedor de control de código fuente.


Error al leer el archivo <archivo> para comprobar los cambios

Este mensaje tiene la siguiente causa y solución:

  • Se encontró con un error interno de control de código fuente.

Salga y vuelva a iniciar VSS. Si esto no resuelve el problema, vuelva a instalar VSS y reinicie su equipo. Si esto no resuelve el problema, compruebe que tiene memoria y espacio en disco suficientes, compruebe el espacio en disco del servidor y compruebe la conexión de red con su equipo.


Error al intentar la conexión con el proyecto <proyecto>

Este mensaje tiene la siguiente causa y solución:

  • El proveedor de control de código fuente no pudo inicializar el proyecto de control de código fuente.

Salga del entorno de desarrollo y vuelva a iniciarlo. Si esto no elimina el error, vuelva a ejecutar el programa de instalación del proveedor de control de código fuente. Compruebe los recursos del sistema, especialmente la memoria y el espacio en disco.


Otro usuario (<usuario>) ha situado esta base de datos bajo control de código fuente y es la única persona que debería trabajar con él

Este mensaje tiene la siguiente causa y solución:

  • Está intentando abrir una base de datos propiedad de otro usuario.

Usted no fue el último usuario en utilizar este archivo. Si continúa, sobrescribirá sus cambios y el estado de desprotección. Termine la sesión de VSS y obtenga su propia copia del archivo mediante el comando Crear <objeto> desde SourceSafe.


Otro usuario (<usuario>) ha situado este proyecto bajo control de código fuente y es la única persona que debería trabajar con él

Este mensaje tiene la siguiente causa y solución:

  • Otro usuario tiene esta base de datos bajo control de código fuente y usted la abrió. Sobreescribirá todos los cambios del otro usuario a menos que salga inmediatamente. Si el otro usuario tenía algo desprotegido, sus cambios se perderán la próxima vez que use el comando Obtener.

Salga de inmediato o sacrifique los cambios del otro usuario.


Como no ha iniciado sesión en <proveedor>, las características de control de código fuente no están habilitadas para este proyecto

Este error tiene la siguiente causa y solución:

  • Canceló su conexión al proveedor de control de código fuente; no están disponibles las características del proveedor de código fuente.

    Abra un proyecto diferente y vuelva a este proyecto e inicie una sesión.


No se puede agregar el archivo .FRX al control de código fuente

Este error tiene la siguiente causa y solución:

  • Se generó automáticamente un archivo .FRX para contener los recursos del archivo .FRM, pero no se pudo agregar el archivo .FRX al control de código fuente.

    Agregue manualmente el archivo.


No se pudo volver a cargar el archivo <archivo> en el proyecto de Visual Basic

Este error tiene la siguiente causa y solución:

  • No se pudo volver a cargar el archivo en el proyecto de Visual Basic.

    Asegúrese de que el proyecto de Visual Basic está desprotegido. Compruebe el nombre de archivo y, si es correcto, puede volver a cargar el archivo en el proyecto de Visual Basic. Puede que tenga que obtener una nueva copia del archivo del proveedor de control de código fuente y colocarla en la carpeta de trabajo, o puede que tenga que reiniciar Visual Basic.


Error del comando Proteger. Los archivos no se han protegido

Este error tiene la solución siguiente:

  • Abra la aplicación de control de código fuente y proteja los archivos manualmente.

    Compruebe la ventana Resultados para obtener otras condiciones de error. Si las encuentra, corríjalas y vuelva a intentar la operación.


Fallo del comando Desproteger. Los archivos no se han desprotegido

Este error tiene la solución siguiente:

  • Abra la aplicación de control de código fuente y desproteja los archivos manualmente.

    Compruebe la ventana Resultados para obtener otras condiciones de error. Si las encuentra, corríjalas y vuelva a intentar la operación.


Error al intentar conectar el proyecto del control de código fuente con el proyecto actual de Visual Basic

Este error tiene la siguiente causa y solución:

  • El proveedor de control de código fuente no pudo asociar el proyecto actual de Visual Basic con un proyecto del proveedor de control de código fuente.

    Ejecute VSS y obtenga el proyecto (si está todavía en VSS).

    Intente realizar la misma operación con otro proyecto. Si funciona, cambie el nombre del proyecto original y vuelva a realizar la operación. Si no funciona, llame al Servicio de soporte técnico de Microsoft.


No se pudo crear un nombre válido de archivo para <archivo>

Este mensaje tiene la siguiente causa y solución:

  • Sólo puede agregar módulos a VSS si el nombre del módulo es un nombre de archivo válido. El nombre de archivo que ha elegido no es válido.

Cambie el nombre de su objeto a un nombre de archivo válido.

Si escribe mal el nombre de archivo, inténtelo de nuevo con un nombre de archivo válido. Si cree que el nombre de archivo es válido y está trabajando en un entorno de sistemas operativos mixtos, el problema puede estar en que el nombre de archivo que ha elegido no se traduce correctamente a uno de los demás entornos de sistemas operativos conectados a su base de datos de VSS. En este caso, pruebe con otro nombre de archivo.


No se pudo crear una carpeta de trabajo para este proyecto

Este mensaje tiene la siguiente causa y solución:

  • La carpeta de trabajo que ha especificado no se pudo crear.

Debe tener permisos para crear una carpeta en el equipo que especifique, la unidad de disco puede estar llena o el nombre que he elegido puede estar ya en uso. Inténtelo de nuevo especificando otro nombre.


No se pueden mostrar las diferencias

Este mensaje tiene la siguiente causa y solución:

  • Se encontró con un error interno mientras intentaba comprobar diferencias entre objetos.

Salga y vuelva a iniciar Microsoft Access y VSS, si se está ejecutando.


Error al cargar el archivo <archivo>

Este error tiene la siguiente causa y solución:

  • Se han encontrado errores al cargar el archivo.

Es posible que Visual Basic no haya cargado el archivo correctamente. Intente abrir el archivo de nuevo o asegúrese de que no está dañado.


No se pudieron agregar archivos a <proyecto>

Este mensaje tiene la siguiente causa y solución:

  • VSS no pudo guardar los archivos que desea agregar y contienen cambios sin guardar.

La operación de VSS puede haber fallado, puede no tener derechos para este proyecto o puede que no haya memoria disponible. Guarde los archivos manualmente e inténtelo de nuevo. Si esto falla, compruebe su conexión con VSS e inténtelo de nuevo.


Fallo al agregar el archivo<archivo> al control de código fuente

Este mensaje tiene la siguiente causa y solución:

  • Ya existe un archivo con el nombre seleccionado en el proyecto de control de código fuente.

Puede guardar su archivo nuevo con otro nombre o aceptar el archivo que ya existe en el control de código fuente (sobreescribiendo cualquier cambio).


No se pudo crear un nuevo proyecto basado en el proyecto <proveedor de control de código fuente>

Este mensaje tiene la siguiente causa y solución:

  • Se encontró con un error interno mientras intentaba crear una carpeta nueva.

Salga y vuelva a iniciar Microsoft Access y VSS, si se está ejecutando.


No se pudo inicializar el proyecto actual. Salga y vuelva a cargar este proyecto

Este mensaje tiene la siguiente causa y solución:

  • Normalmente está provocado por un error interno de VSS.

Salga y vuelva a cargar el proyecto. Si esto no resuelve el problema, salga y vuelva a cargar su entorno de aplicación. Si el problema persiste, reinicie su equipo.


No se ha podido inicializar el proveedor de control de código fuente

Este mensaje tiene la siguiente causa y solución:

  • El proveedor de control de código fuente no puede conectarse correctamente con el host del entorno de desarrollo.

Ejecute de nuevo el programa de instalación para elegir su proveedor de código fuente.


Error al volver a cargar el proyecto

Este mensaje tiene la siguiente causa y solución:

  • Se produjo un error interno en la aplicación.

Cierre este proyecto desde el menú Archivo y vuelva a abrirlo para obtener la versión correcta de todos los archivos cargados en memoria.


No se pudo actualizar la información de ubicación del proyecto en la aplicación principal

Este mensaje tiene la siguiente causa y solución:

  • Otra aplicación está usando el archivo .mdb.

Asegúrese de que ninguna otra aplicación está usando la base de datos (asegúrese de comprobar el uso a través de programación mediante DAO).


No se puede asignar el archivo <archivo> al proyecto <proyecto> de Visual SourceSafe

Este error tiene la siguiente causa y solución:

  • Debe tener el archivo en VSS antes de continuar con la operación.

    Haga clic en Sí para copiar el archivo al proyecto especificado y continuar.

    Haga clic en No para cancelar la operación.


<archivo> no tiene un nombre de archivo válido. Debe tener un nombre de archivo válido para poder agregarlo al control de código fuente

Este mensaje tiene la siguiente causa y solución:

  • Aunque el nombre de este objeto es válido para la aplicación principal, no es un nombre válido para el sistema de archivos (contiene caracteres no permitidos).

Cambie el nombre del objeto y agréguelo al control de código fuente.


El archivo <nombre de archivo> no ha cambiado. ¿Desea crear una versión nueva del archivo en SourceSafe?

Este mensaje tiene la siguiente causa y solución:

  • Está intentando proteger un archivo desprotegido que no ha modificado.

    Haga clic en Sí, y VSS protegerá el archivo. (Si hace clic en Sí a todo protegerá todos los archivos seleccionados.) Una protección crea una nueva versión del archivo, con un comentario opcional.

    Haga clic en No, y VSS deshará la desprotección del archivo. (Haga clic en No, y VSS deshará la desprotección del archivo.) En este caso no se creará una versión nueva del archivo.

Nota Para omitir este mensaje en el futuro, deshabilite esta notificación en la ficha General a la que se accede seleccionando Opciones en el menú Herramientas.


El archivo <archivo> ya está desprotegido

Este error tiene la siguiente causa y solución:

  • Los archivos .FRM sólo los puede desproteger un usuario a la vez.

    Si es necesario, ejecute su proveedor de control de código fuente para saber quién ha desprotegido el archivo.


No se puede encontrar el archivo <nombre de archivo> (archivo <nombre de archivo> en SourceSafe)

Este mensaje tiene la siguiente causa y solución:

  • VSS no ha podido localizar el archivo especificado.

    Ejecute la utilidad Analyze para asegurarse de que no hay errores en su base de datos VSS. Si el problema no se arregla ejecutando Analyze con el argumento–F, póngase en contacto con el Soporte de productos.

Nota Cuando use la utilidad Analyze, hágalo primero sin argumentos para localizar cualquier error en la base de datos y luego con el argumento –F para que se ejecute en modo de reparación automática.


No se puede asignar el archivo <nombre de archivo> al proyecto <nombre de proyecto> de SourceSafe. Copie el archivo en <nombre de proyecto>

Este mensaje tiene la siguiente causa y solución:

  • Ha agregado un archivo de una carpeta distinta a su carpeta de proyecto (o uno de sus subdirectorios) y VSS no puede determinar qué proyecto corresponde a la carpeta de inicio del archivo nuevo.

    VSS debe asignar la copia local a una ruta de acceso de un proyecto VSS para que funcione esta operación. Copie el archivo a una subcarpeta de o debajo de su proyecto IDE. Si el archivo ya está en VSS en un proyecto diferente, comparta el archivo en su proyecto actual e intente de nuevo la operación.

    Continuará para obtener este mensaje conforme el archivo tenga un nombre tan largo que no se pueda asignar. Si ocurre esto, deberá quitar el archivo de su archivo de proyecto, copiarlo o compartirlo, y después volver a agregarlo.


No se ha podido asignar el archivo <nombre de archivo> al proyecto <nombre de proyecto> de SourceSafe

Este mensaje tiene la siguiente causa y solución:

  • Debe tener el archivo en VSS antes de continuar la operación.

    Haga clic en Sí para copiar el archivo al proyecto especificado y continuar.

    Haga clic en No para cancelar la operación.


El archivo <nombre de archivo> sobrepasa el tamaño de nombre de archivo máximo de SourceSafe

Este mensaje tiene la siguiente causa y solución:

  • Ha excedido el número máximo de nombre de archivo de la base de datos de VSS.

    Póngase en contacto con el Soporte de productos.


Fallo del comando Obtener. Los archivos no se han descargado del control de código fuente

Este error tiene la solución siguiente:

  • Abra la aplicación del proveedor de control de código fuente y obtenga los archivos manualmente.

    Compruebe la ventana Resultados para obtener otras condiciones de error. Si las encuentra, corríjalas y vuelva a intentar la operación.


Error interno: salga y vuelva a iniciar Visual Basic

Este error tiene la siguiente causa y solución:

  • Ha ocurrido un error interno en Visual Basic o en VSS.

Guarde su trabajo, salga de Visual Basic y de VSS, y reinicie ambos programas si todavía necesita usarlos.


No hay ninguna Ayuda adicional disponible sobre este elemento

  • No hay más información disponible acerca de este cuadro de diálogo. Si la causa del problema no está clara en el mensaje, llame al Servicio de soporte técnico para obtener asistencia.


No hay ningún archivo de proyecto de Visual Basic que corresponda a este proyecto de control de código fuente

Este error tiene la siguiente causa y solución:

  • El proveedor de control de código fuente no puede encontrar el archivo de proyecto de Visual Basic (archivo .VBP o .MAK). Se requiere un archivo de proyecto porque guarda la lista de archivos incluidos en el proyecto y el proveedor de control de código fuente utiliza la lista para hacer un seguimiento del estado del archivo.


No hay archivos disponibles para desproteger desde el control de código fuente

Este error tiene la siguiente causa y solución:

  • No hay ningún archivo desprotegido en el proyecto actual de VSS.

    Para desproteger un archivo que todavía no se ha agregado al control de código fuente, utilice el comando Agregar archivo para agregar archivos. Si el archivo ya está en el proyecto, asegúrese de que no esté desprotegido.

    Este error se produce a veces si alguien elimina el archivo con el que desea trabajar (o elimina todo el proyecto); asegúrese de que el proyecto sigue existiendo.


No hay archivos disponibles para obtener desde el control de código fuente

Este mensaje tiene la siguiente causa y solución:

  • Eligió el comando Obtener, pero después de una cuidadosa comprobación, no había ningún archivo para la operación.

Este error se produce a veces si alguien elimina el archivo con el que desea trabajar (o elimina todo el proyecto); asegúrese de que el proyecto sigue existiendo. A continuación, asegúrese de que tiene algún archivo desprotegido.


En este proyecto no hay archivos disponibles para obtener

Este error tiene la siguiente causa y solución:

  • No hay archivos en el proyecto actual de VSS.

    Para agregar archivos, utilice el comando Agregar archivos.


No se han podido establecer todas las opciones correctamente

Este mensaje tiene la siguiente causa y solución:

  • Se encontró con un error al escribir en el Registro del sistema.

Asegúrese de que tiene suficiente espacio en su unidad para poder guardar los cambios en el Registro del sistema.


No se pudo agregar al proyecto de control de versiones todos los archivos solicitados

Este error tiene la causa siguiente:

  • Mientras se agregaba archivos al proveedor de control de código fuente, no se reemplazaron correctamente todos los archivos.

    Compruebe la ventana Resultados para obtener otras condiciones de error. Si las encuentra, corríjalas y vuelva a intentar la operación.


<objeto> ya está desprotegido en algún lugar; no puede cambiar el nombre ahora

Este mensaje tiene la siguiente causa y solución:

  • Está intentando cambiar el nombre de un archivo que actualmente está desprotegido.

Puede esperar a que el otro usuario proteja el archivo o ponerse en contacto con su administrador de VSS para deshacer la desprotección del usuario (lo que sobreescribirá los cambios del otro usuario).


Sólo puede haber un proyecto bajo el control de código fuente a la vez con este proveedor de control de código fuente

Este mensaje tiene la siguiente causa y solución:

  • Algunos proveedores de control de código fuente sólo pueden tratar un proyecto a la vez.

Póngase en contacto con el fabricante para obtener una versión actualizada del proveedor de control de código fuente. Seleccione un proveedor de código fuente más avanzado o no utilice múltiples proyectos.


Sólo se puede ejecutar una copia del proveedor de control de código fuente a la vez

Este error tiene la causa siguiente:

  • Aunque se pueden ejecutar varias sesiones de Visual Basic a la vez, sólo se puede ejecutar a la vez un proveedor de control de código fuente; esta sesión de Visual Basic tiene desactivado el control de código fuente.


No hay suficiente memoria

No tiene suficiente memoria en su PC para realizar esta operación. Este mensaje tiene la siguiente causa y solución:

  • Tiene abiertas demasiadas aplicaciones, documentos o archivos de origen.

    Cierre las aplicaciones, documentos o archivos de origen abiertos que no sean necesarios.

  • Tiene cargados demasiados controladores de dispositivos.

    Elimine los controladores de dispositivos innecesarios.


Memoria insuficiente; no se puede terminar la operación

Este mensaje tiene la siguiente causa y solución:

  • Su equipo no tiene suficiente memoria.

Cierre las aplicaciones que no esté utilizando. Si el problema persiste, reinicie su equipo.


Guarde y proteja su archivo de proyecto de Visual Basic

Este error tiene la siguiente causa y solución:

  • Ha realizado cambios que modifican su archivo de proyecto de Visual Basic.

Necesita guardar y proteger su archivo de proyecto. De lo contrario, el proyecto contendrá referencias a copias de archivos con sus anteriores ubicaciones en lugar de las ubicaciones actuales.


Se ha eliminado el proyecto <proyecto> y antes de abrirlo debe recuperarlo

Vea también

Este mensaje tiene la siguiente causa y solución:

  • Está intentado actuar sobre un proyecto que ha sido eliminado. Este error ocurrirá en la integración debido a que no puede conectar con el proyecto de VSS (el proyecto se ha eliminado desde VSS).

    Antes de poder hacer algo con el proyecto debe recuperarlo mediante el comando Recuperar de VSS.

    Utilice los siguientes pasos en el Explorador de VSS:

    • Seleccione el proyecto primario que contenía el proyecto eliminado.

    • En el menú Archivo, haga clic en Propiedades.

    • Haga clic en la ficha Elementos eliminados.

    • Seleccione el proyecto eliminado, después haga clic en Recuperar.


No se encontró el proyecto <proyecto>

Este error tiene la siguiente causa y solución:

  • Se cambió el nombre del proyecto, o se movió o eliminó.

    Haga clic en Examinar si desea buscar el proyecto en la base de datos del proveedor de control de código fuente.


No se encontró el proyecto <nombre de proyecto>. ¿Desea buscar el proyecto?

VSS ha intentado abrir un proyecto que no se ha podido encontrar en la base de datos de VSS. Este mensaje tiene la siguiente causa y solución:

  • Se ha movido o cambiado de nombre el proyecto VSS en el Explorador de VSS, y después se ha abierto el proyecto en Visual Basic o Visual C++ que hace referencia al nombre de proyecto antiguo de VSS.

    Haga clic en Sí para explorar el proyecto si sabe el nombre del proyecto nuevo.

    Haga clic en No si no quiere que el proyecto esté bajo el control de código fuente. Si hace clic en No, debe volver a agregar manualmente el proyecto a VSS para poder usar las características de control de código fuente en el futuro.


No se pueden mostrar las propiedades

Este mensaje tiene la siguiente causa y solución:

  • Se encontró con un error interno mientras intentaba ver las propiedades.

Salga y vuelva a iniciar Microsoft Access y VSS, si se está ejecutando.


No se pueden agregar los archivos de soporte necesarios al control de código fuente; la operación de protección ha fallado

Este mensaje tiene la siguiente causa y solución:

  • Intentó una operación Agregar pero falló cuando VSS intentó agregar archivos de proyecto de soporte (por ejemplo, el archivo de formulario .frx).

Agregue cada archivo por separado al control de código fuente.


Como no ha iniciado sesión en <proveedor de control de código fuente>, las características de control de código fuente no están habilitadas para este proyecto

Este mensaje tiene la siguiente causa y solución:

  • No inició la sesión en el proveedor de control de código fuente.

Vuelva a abrir su proyecto e inicie su sesión en el proveedor de control de código fuente para usar las características de control de código fuente.


No se pudo guardar algunos archivos. El proyecto no se agregó a <proveedor>

Este mensaje tiene la siguiente causa y solución:

  • Está agregando un proyecto al control de código fuente sin guardar los cambios.

SourceSafe no pudo guardar alguno de sus cambios. Quizá no tenga permiso de escritura en algunos archivos o puede que haya un error de red.


Algunos archivos no se han podido proteger

Este error tiene la siguiente causa y solución:

  • Se produjo un error durante el comando Proteger.

    Compruebe el espacio libre del disco o reinicie Windows.

    Compruebe la ventana Resultados para obtener otras condiciones de error. Si las encuentra, corríjalas y vuelva a intentar la operación.


Algunos archivos no se han podido desproteger

Este error tiene la siguiente causa y solución:

  • Se produjo un error durante el comando Desproteger.

    Compruebe el espacio libre del disco o reinicie Windows.

    Compruebe la ventana Resultados para obtener otras condiciones de error. Si las encuentra, corríjalas y vuelva a intentar la operación.


No se pudo deshacer el estado de desprotección de algunos archivos

Este error tiene la siguiente causa y solución:

  • Se produjo un error durante el comando Deshacer desprotección.

    Compruebe el espacio libre del disco o reinicie Windows.

    Compruebe la ventana Resultados para obtener otras condiciones de error. Si las encuentra, corríjalas y vuelva a intentar la operación.


Algunos archivos no tienen nombres todavía

Este error tiene la siguiente causa y solución:

  • No ha asignado nombre a todos sus archivos.

Asigne nombre a sus archivos mediante el comando Guardar archivo de Visual Basic antes de continuar con la operación.


Algunos resultados antiguos se han eliminado para hacer espacio para los resultados más recientes

Este mensaje le informa de que se han eliminado los resultados antiguos; no es necesaria ninguna acción.


El control de código fuente no pudo actualizar algunos archivos

Este error tiene la siguiente causa y solución:

  • Se produjo un error durante el comando Obtener la última versión.

    Compruebe el espacio libre del disco o reinicie Windows.

    Compruebe la ventana Resultados para obtener otras condiciones de error. Si las encuentra, corríjalas y vuelva a intentar la operación.


<proveedor de control de código fuente> no es compatible con esta operación

Este mensaje tiene la siguiente causa y solución:

  • Su proveedor de control de código fuente no es compatible con el elemento de menú que eligió.

Póngase en contacto con su proveedor de control de código fuente o compre Microsoft Visual SourceSafe.


<proveedor de control de código fuente> no se desconectó correctamente

Este mensaje tiene la siguiente causa y solución:

  • El proveedor de control de código fuente no se desconectó de su proyecto.

Salga y vuelva a iniciar Microsoft Access para eliminar este error.


Resultados de control de código fuente (Cuadro de diálogo)

Coloca los resultados de un comando en una ventana.

Para mostrar el cuadro de diálogo Resultados de comando:

  1. Establezca la variable Results_Window con el valor Sí en el archivo SRCSAFE.INI.

  2. Obtenga o desproteja un archivo.

Cuando lleva a cabo un comando que genera un mensaje de estado o de error, VSS muestra el resultado del comando en la ventana Resultados. Esta ventana permanece en pantalla hasta que presiona la tecla INTRO, hace clic en Cancelar (o en Cerrar) o bien hace clic en la ventana del explorador de VSS.

Si lo prefiere, puede indicar a VSS que no muestre la ventana Resultados. Desactive la casilla Mostrar panel de resultados en la ficha Ver del cuadro de diálogo Opciones de SourceSafe (en el menú Herramientas). Así se establece automáticamente la variable de inicialización Results_Windows con el valor No en su archivo SS.INI. Sin embargo, los mensajes de error siguen apareciendo


El archivo srcsafe.ini no está en la carpeta <carpeta>

Este error tiene la siguiente causa y solución:

  • Eligió una ruta de acceso en el cuadro de diálogo Conectarse a VSS que no contiene un archivo SRCSAFE.INI.

Necesita elegir la carpeta en la que exista la información de su base de datos. Normalmente suele estar en el servidor donde está instalado SourceSafe.


<cadena> contiene un carácter no válido

Este error tiene la siguiente causa y solución:

  • El valor de la ruta de datos en el cuadro de diálogo Conectarse a VSS contiene un carácter no válido.

Los nombres de ruta de datos no deben contener los caracteres ( )[ ] ni caracteres en blanco.


Ese proyecto de control de código fuente no contiene el archivo de proyecto de Visual Basic cargado. ¿Desea intentarlo de nuevo?

Este error tiene la siguiente causa y solución:

  • Seleccionó un proyecto de control de código fuente que no contenía el archivo de proyecto de Visual Basic apropiado.

    Haga clic en Sí para seguir examinando la base de datos del control de código fuente en busca del proyecto actual.

    Haga clic en No para cancelar la operación.


Puede que <archivo> haya cambiado. ¿Desea deshacer la desprotección y perder los cambios?

Este mensaje tiene la siguiente causa y solución:

  • El mensaje de confirmación le pregunta si desea continuar con el comando Deshacer desprotección aunque pueda perder los cambios que haya realizado en su archivo local.

Haga clic en Sí para deshacer las desprotección o en No para cancelar la operación.


El proyecto <proyecto> que ha seleccionado no contiene este proyecto IDE

Este mensaje tiene la siguiente causa y solución:

  • Esta advertencia le informa de que mientras intentaba explorar un proyecto eliminado eligió el proyecto erróneo.

Vuelva a intentar la operación de exploración.


El cambio que ha hecho ha cambiado el archivo de proyecto de Visual Basic, pero todavía no ha desprotegido el archivo de proyecto de Visual Basic

Este error tiene la siguiente causa y solución:

  • Modificó el archivo de proyecto de Visual Basic, pero no desprotegió el archivo antes en el proveedor de control de código fuente.

    Haga clic en Sí para desproteger el archivo de proyecto y poder guardar las modificaciones.

    Haga clic en No para mantener protegido el archivo de proyecto. No podrá guardar los cambios en el proveedor de control de código fuente.


La operación proteger ha fallado

Este mensaje tiene la siguiente causa y solución:

  • No guardó los objetos que se podrían perder si realiza esta operación.

Guarde todos los objetos de su proyecto en un archivo e inténtelo otra vez.


La operación desproteger ha fallado

Este mensaje tiene la siguiente causa y solución:

  • No guardó los objetos que se podrían perder si realiza esta operación.

Guarde todos los objetos de su proyecto en un archivo e inténtelo otra vez.


La copia del archivo de proyecto de Visual Basic que está en la base de datos de control de versiones ha cambiado; ya no podrá guardar sus cambios actuales. Debe desproteger el archivo de proyecto y volver a realizar los cambios

Este mensaje tiene la siguiente causa y solución:

  • Es una advertencia que le avisa que otro usuario ha cambiado el archivo de proyecto mientras usted estaba trabajando.

Desproteja la nueva versión del archivo de proyecto y vuelva a realizar sus cambios.


El archivo <archivo> ya existe en el proyecto de control de código fuente, pero su copia local es diferente

Usted (u otro usuario) agregó el proyecto al proveedor de control de código fuente. Sin embargo, cuando intentó agregar archivos al proyecto, había en el proyecto un archivo diferente con el mismo nombre. Debe utilizar el comando de diferencias del proveedor de control de código fuente para averiguar las diferencias y proteger la versión adecuada.

En vez de utilizar el comando Agregar proyecto, debe obtener el proyecto entero en su unidad local y desproteger los archivos que necesite. Con este método podría volver a tener sincronizado el proyecto, pero perdería las modificaciones locales que hubiera realizado en los archivos del proyecto.


El archivo <archivo> ya existe en el proyecto de control de código fuente, pero su copia local es diferente

Este mensaje tiene la siguiente causa y solución:

  • Intentó agregar un archivo a su proyecto cuando ya existe un archivo con ese nombre en su proyecto. El archivo no se agregó y su copia local no se cambió.

Elija otro nombre diferente para el archivo que desea agregar.


El archivo <archivo> ya no está conectado a este proyecto de control de código fuente

Este error tiene la siguiente causa y solución:

  • Ha seleccionado un archivo que ya no está incluido en el control de código fuente de este proyecto.

Posiblemente el archivo se ha eliminado del proveedor de control de código fuente o se ha movido a otro proyecto. Use el comando Agregar archivos para agregarlo al control de código fuente de su proyecto o busque en la base de datos del control de código fuente para ver si el archivo forma parte de otro proyecto.


El archivo <archivo> ya no está bajo control de código fuente; falló la operación

Este mensaje tiene la siguiente causa y solución:

  • Algún usuario eliminó un archivo de la base de datos de VSS durante la sesión y usted intentó utilizar un menú contextual para obtenerlo.

Vuelva a agregar el archivo al control de código fuente, compruebe quién lo eliminó y por qué, etc.


El archivo <archivo> no es un tipo de archivo normal para agregarlo a un proyecto de Visual Basic

Este error tiene la siguiente causa y solución:

  • El archivo que está agregando al proveedor de control de código fuente es de un tipo que no reconoce Visual Basic.

    Haga clic en Sí para continuar agregando el archivo al proveedor de control de código fuente.

    Haga clic en No para cancelar la operación de agregar.


El archivo <archivo> no está bajo control de código fuente

Este error tiene la siguiente causa y solución:

  • Ha seleccionado un archivo que no está incluido en el control de código fuente.

Use al comando Agregar archivos para agregar el archivo al proveedor del control de código fuente antes de intentar desprotegerlo o utilizar las funciones que ofrece el control de código fuente.


No se pudo agregar el archivo <archivo> al proyecto de Visual Basic

Este error tiene la siguiente causa y solución:

  • No se pudo agregar el archivo a Visual Basic.

    Inténtelo con otro archivo.


No se pudo asignar el archivo <archivo> al proyecto <proyecto> del proveedor de control de código fuente

Este error tiene la siguiente causa y solución:

  • El proveedor de control de código fuente no sabe en qué proyecto del proveedor de control de código fuente debe colocar el archivo o del que debe obtener el archivo.

    El proveedor de control de código fuente determina esto basándose en la carpeta en la que está el archivo. Aunque el proveedor de control de código fuente puede asignar proyectos a carpetas dentro de una subcarpeta de un proyecto o carpeta, los archivos en subcarpetas o en otras unidades crean problemas, a menos que haya una asociación entre la carpeta de la que procede el archivo y el proyecto del proveedor de control de código fuente.

    Agregue el archivo especificado a una carpeta que esté al mismo nivel o por debajo del proyecto especificado. Si el archivo ya está en el proveedor de control de código fuente, comparta el archivo con el proyecto actual.


No se pudo cambiar automáticamente el nombre del archivo en el proveedor de control de código fuente

Este error tiene la solución siguiente:

  • Abra la aplicación del proveedor de control de código fuente y cambie el nombre del archivo manualmente.


No se puede volver a cargar el archivo en el IDE principal

Este mensaje tiene la siguiente causa y solución:

  • Normalmente está provocado por un error interno de SourceSafe.

Cierre el proyecto y vuelva a abrirlo.


Se ha quitado el archivo del proyecto de Visual Basic. ¿Desea quitar también el archivo del control de código fuente?

Haga clic en Sí para quitar el archivo del proyecto de control de código fuente. (Se pueden recuperar después los archivos eliminados si es necesario.)

Haga clic en No para quitar el archivo de su proyecto de Visual Basic, pero manteniéndolo en el proyecto de control de código fuente.


La operación cambiar el nombre del archivo se ha detenido, no se han guardado todos los archivos

Este error tiene la siguiente causa y solución:

  • Eligió no permitir al proveedor de control de código fuente desproteger el archivo de proyecto al que está cambiando el nombre.

Si elige no permitir al proveedor de control de código fuente desproteger el archivo de proyecto mientras cambia el nombre de un archivo, la operación no podrá continuar hasta que no se cambie el nombre del archivo en el proveedor de control de código fuente.


Un archivo de etiqueta que se cambió de nombre no puede cambiarse de nombre automáticamente en el control de código fuente

Este mensaje tiene la siguiente causa y solución:

  • Normalmente está provocado por un error interno de VSS.

Cambie manualmente el nombre del archivo de etiqueta.


El nombre de archivo <archivo> contiene caracteres no válidos. Se pasará por alto el archivo

Este mensaje tiene la siguiente causa y solución:

  • El nombre de archivo especificado contiene uno o más caracteres no válidos.

    Al agregar archivos a VSS, deben cumplir los requisitos siguientes.

    • Longitud de 255 caracteres o menos.

    • La ruta de acceso completa no puede pasar de 259 caracteres, incluyendo los separadores.

    • No pueden comenzar o acabar con un espacio.

    • No pueden comenzar con un $.

    • Pueden contener una o más extensiones de archivo (p.e., MiArchivo.Ext1.Ext2.Ext3.Txt).

    • Son caracteres válidos los caracteres del 32 al 255 en ASCII, pero no: ?”/\<>*|:


La operación obtener ha fallado

Este mensaje tiene la siguiente causa y solución:

  • No guardó los objetos que se podrían perder si realiza esta operación.

Guarde todos los objetos de su proyecto en un archivo e inténtelo otra vez.


La operación de historial ha fallado

Este mensaje tiene la siguiente causa y solución:

  • No guardó los objetos que se podrían perder si realiza esta operación.

Guarde todos los objetos de su proyecto en un archivo e inténtelo otra vez.


No se ha quitado el elemento del proyecto <proveedor>

Este mensaje tiene la siguiente causa y solución:

  • Normalmente está provocado por un error interno de VSS.

Quite cada archivo por separado del control de código fuente.


No se ha cambiado el nombre al elemento en el proyecto <proveedor>

Este mensaje tiene la siguiente causa y solución:

  • Normalmente está provocado por un error interno de VSS.

Cambie el nombre de cada archivo por separado del control de código fuente.


No se puede usar el nuevo nombre porque ya existe un objeto con ese nombre en <proveedor>

Este mensaje tiene la siguiente causa y solución:

  • Está intentando cambiar el nombre de un archivo o un objeto y el nuevo nombre es el nombre de un objeto o un archivo que ya existe en el control de código fuente.

Elija otro nombre diferente para el archivo o el objeto, o cambie el nombre o elimine el objeto existente que tiene el nombre deseado.


No se puede usar el nuevo nombre ya que no es un nombre de archivo válido

Este mensaje tiene la siguiente causa y solución:

  • Está intentando cambiar el nombre de un archivo o un objeto y el nuevo nombre no es un nombre de archivo válido (normalmente porque contiene caracteres no válidos).

Elija otro nombre diferente para el archivo o el objeto.


Falló el comando Abrir proyecto del proveedor del control de código fuente

Este error tiene la solución siguiente:

  • Abra la aplicación del proveedor de control de código fuente y obtenga el proyecto manualmente. Abra después el proyecto en Visual Basic.


La operación falló porque algunos archivos no se guardaron. Guarde su proyecto y vuelva a intentarlo

Este mensaje tiene la siguiente causa y solución:

  • No se pudo guardar en disco algunos archivos.

Asegúrese de que tiene permiso y espacio para guardar los archivos en el disco de destino Intente guardar los archivos manualmente y vuelva a intentar la operación.


No se pudo cerrar correctamente el proyecto cargado anteriormente

Este error tiene la siguiente causa y solución:

  • Mientras intentaba abrir un proyecto nuevo, el proveedor de control de código fuente no pudo cerrar correctamente el anterior.

    Salga de Visual Basic y reinícielo.


No se pudo cerrar correctamente el proyecto en <proveedor de control de código fuente>

Este mensaje tiene la siguiente causa y solución:

  • El proveedor de control de código fuente no pudo cerrar el proyecto de control de código fuente.

Normalmente, si sale y vuelve a iniciar Microsoft Access eliminará este error.


El proyecto <proyecto> ya no existe bajo <proveedor>

Este error tiene la siguiente causa y solución:

  • Se eliminó (o cambió de lugar) el proyecto especificado. Debe recuperar (o seleccionar)el proyecto especificado antes de que se le puedan aplicar comandos de control de código fuente.

    Si se cambió de lugar el proyecto, obtendrá un cuadro de diálogo para ayudarle a buscar el nuevo proyecto. Si se eliminó el proyecto, deberá ejecutar el proveedor de control de código fuente para volver a instalar el proyecto.


El proyecto <proyecto> ya no está bajo control de código fuente. Debe recuperar o volver a crear el proyecto antes de que pueda usar este proyecto con control de código fuente

Este mensaje tiene la siguiente causa y solución:

  • Otro usuario eliminó (o movió) su proyecto.

Haga clic Aceptar si desea intentar encontrar el proyecto. Si el proyecto se eliminó, haga clic en Cancelar. Al hacer clic en Cancelar, la base de datos se dará de baja del control de código fuente y podrá volver a agregar el proyecto al control de código fuente (pero perderá cualquier información histórica acerca de este proyecto).

Si puede averiguar quién eliminó o movió su proyecto, es posible que pueda recuperar el proyecto y su historial (por ejemplo, si su administrador de control de código fuente ha archivado su proyecto en una copia de seguridad en cinta).


No se puede agregar el proyecto al control de código fuente porque la ruta es demasiado larga

Este error tiene la siguiente causa y solución:

  • La ruta de acceso para este proyecto es demasiado larga.

Utilice otra ruta de acceso más corta y pruebe otra vez.


La ventana Resultados está llena; se eliminarán las entradas anteriores de la ventana Resultados

Cuando se realiza una operación con varios archivos, la ventana Resultados puede llenarse rápidamente con mensajes de estado. Este mensaje de advertencia tiene la causa siguiente:

  • La ventana Resultados está llena. No podrá ver algunas de las entradas anteriores.


La operación de uso compartido ha fallado

Este mensaje tiene la siguiente causa y solución:

  • Intentó compartir un archivo que tiene la misma propiedad de nombre que otro del proyecto de destino.

Existen varias causas posibles que producen este mensaje. Una causa es que si no ha asignado la propiedad de nombre en uno de sus archivo podrían producirse conflictos con un archivo del proyecto de destino (donde la propiedad de nombre tampoco está asignada o es la misma). En este caso, asigne la propiedad de nombre del archivo a su proyecto actual y después inténtelo de nuevo.

Otras posibilidades son que el archivo de proyecto está desprotegido por alguien o que no es capaz de desproteger el archivo de proyecto. Compruebe el estado de desprotección del archivo para determinar si es éste el caso. Si no, podría haber ocurrido un error interno de VSS.


La operación de uso compartido ha finalizado, pero no se pueden agregar los archivos al proyecto actual

Este mensaje tiene la siguiente causa y solución:

  • La operación de compartir se ha realizado con éxito, pero ha fallado al intentar agregar el archivo al proyecto.

Compruebe que la propiedad de nombre del archivo no causa conflicto con la propiedad de nombre de un formulario, módulo, módulo de clase u otro archivo de Visual Basic existente.


El complemento de control de código fuente no se desconectó de Visual Basic

Este error tiene la solución siguiente:

  • Cierre Visual Basic y vuélvalo a abrir; lo más probable es que sea un error interno temporal.


El proyecto de control de código fuente ya tiene un archivo de proyecto con el mismo nombre que el que está agregando. ¿Es el mismo archivo?

Este mensaje tiene la siguiente causa y solución:

  • Está intentando agregar un archivo de proyecto con el mismo nombre que un archivo del proyecto del proveedor de control de código fuente.

    Compruebe el nombre del archivo y cambie su nombre si es necesario.

    Haga clic en Sí para agregar el archivo seleccionado actualmente, sobrescribiendo el antiguo con el mismo nombre.

    Haga clic en No para cancelar la operación.


El proveedor de control de código fuente no se inicializó correctamente

Este error tiene la solución siguiente:

  • Su sistema tiene poca memoria o recursos del sistema.

    Cierre algunas aplicaciones y vuélvalo a intentar.

    Si esto no es suficiente, vuelva a instalar el proveedor de código fuente.


El proveedor de control de código fuente no se pudo conectar

Falló un método de automatización OLE de Visual Basic. Este error tiene la siguiente causa y solución:

  • Se ha producido un error interno de OLE, Visual Basic o del proveedor de control de código fuente.

    Vuelva a instalar el proveedor de control de código fuente.


El proveedor de control de código fuente no pudo instalar correctamente los menús

Este error tiene la siguiente causa y solución:

  • Se ha producido un error interno de OLE.

    Primero vuelva a instalar Visual Basic y luego el proveedor de control de código fuente (si es necesario); después, vuelva a instalar OLE (si es necesario).


El proveedor de control de código fuente no pudo conectarse con Visual Basic

Este error tiene las siguientes causas y soluciones:

  • Se produjo un error interno con OLE y Visual Basic.

  • Está utilizando una versión incorrecta de Visual Basic.

    Vuelva a instalar Visual Basic y el proveedor de control de código fuente.


La operación deshacer desprotección ha fallado

Este mensaje tiene la siguiente causa y solución:

  • No guardó los objetos que se podrían perder si realiza esta operación.

Guarde todos los objetos de su proyecto en un archivo e inténtelo otra vez.


La operación de diferencia visual ha fallado

Este error tiene la solución siguiente:

  • Abra la aplicación del proveedor de control de código fuente y utilice el comando Diferencias manualmente.


No hay un archivo de proyecto asociado con este proyecto; no se puede crear un proyecto de Visual Basic desde el proyecto <proyecto>

Este mensaje tiene la siguiente causa y solución:

  • Intentó crear un proyecto de Visual Basic desde el control de código pero especificó un proyecto no válido.

Compruebe el nombre del proyecto e inténtelo de nuevo.


Esto es un proyecto de integración. No está permitido desproteger archivos desde el explorador de VSS

Este mensaje tiene la siguiente causa y solución:

  • Está intentando Desproteger un objeto de Microsoft Access en el explorador de Microsoft VSS, o se ha agregado manualmente la entrada Disable_UI al archivo SRCSAFE.INI.

    El Componente de integración de Microsoft Access de VSS agrega un valor al archivo SRCSAFE.INI cuando agrega una base de datos de Microsoft Access a la base de datos del servidor de VSS. Esta entrada marca los archivos de la base de datos de VSS conforme van perteneciendo a un proyecto de integración de base de datos de Microsoft Access, y tiene un aspecto similar a éste:

      [$/Northwind]
      Disable_UI = Yes

Esta entrada del archivo .INI impide que se use el Explorador de VSS para desproteger los archivos de base de datos de Microsoft Access. Ocurre así por diseño debido a que los archivos son representaciones de tipo texto de los objetos de Microsoft Access que sólo se debería manipular en el contexto de un proyecto de Microsoft Access.

En algunos casos, puede que sea necesario realizar operaciones sobre objetos de Microsoft Access u otros archivos dentro del Explorador de VSS. Si es así, cierre el Explorador de VSS, quite o marque como comentario la línea Disable_UI del archivo SRCSAFE.INI, y después vuelva a abrir el Explorador de VSS. Después podrá realizar la operación deseada desde el Explorador de VSS.

Tenga en cuenta que cuando vuelva a abrir la base de datos de Microsoft Access, el Componente de integración de VSS (ACCSCC) vuelve a agregar la línea Disable_UI = Yes al archivo SRCSAFE.INI. También puede volver a agregar la línea al archivo por su propia cuenta.


El proveedor de control de código fuente no admite esta operación

Algunos proveedores de código fuente no admiten todos los comandos de control de código fuente. Este error tiene la siguiente causa y solución:

  • Intentó ejecutar una operación no admitida.

    Salga de Windows y reinícielo e informe del error al Servicio de soporte técnico de Microsoft.


Esta operación necesita desproteger primero el archivo de proyecto de Visual Basic

Muchas operaciones, como agregar un archivo nuevo, quitar un archivo, cambiar el nombre de un archivo, etc. requieren que se desproteja primero el archivo de proyecto de Visual Basic.

  • Realizó una operación sin desproteger primero el archivo de proyecto de Visual Basic.

    Desproteja el archivo de proyecto de Visual Basic antes de continuar y vuelva a intentar realizar el comando.


El proyecto no está bajo el control de código fuente

Este error tiene la siguiente causa y solución:

  • VSS determinó que el proyecto actual no está almacenado en la base de datos de VSS.

    Si desea agregar ahora este proyecto al control de código fuente, guarde el proyecto y haga clic en Agregar proyecto en el menú del proveedor de control de código fuente.


El proyecto se llamó <nombre> pero se ha movido, copiado o cambiado de nombre

Este mensaje tiene la siguiente causa y solución:

  • Una vez que ha situado una base de datos de Access bajo el control de código fuente, no está permitido cambiar su nombre, moverla a otra carpeta o trabajar con copias de ellas. Cuando abra una base de datos que esté bajo el control de código fuente y se haya movido, cambiado de nombre o copiado, se presentará este mensaje y se deshabilitarán todas las funciones del control de código fuente para esta base de datos.

No trabaje con una copia de la base de datos de Access que esté bajo el control de código fuente. Utilice el comando Crear base de datos del SCC para crear una nueva base de datos en la ubicación que desee.

Si la base de datos se ha movido, devuélvala a su ubicación original y vuelva a abrirla. Las funciones de control de código fuente volverán a funcionar. De la misma forma, si la base de datos se cambió de nombre, restaure su nombre original.


No se puede tener acceso al archivo <archivo>

Este mensaje tiene la siguiente causa y solución:

  • El proveedor de control de código fuente no pudo crear un archivo temporal en el que se pueda escribir.

Compruebe los permisos de escritura y lectura de sus archivos y directorios, compruebe el espacio de su disco y asegúrese de que la base de datos está en una unidad en la que tiene permiso de escritura.


No se puede agregar el proyecto nuevo al control de código fuente

Este error tiene la siguiente causa y solución:

  • No tiene suficientes derechos de acceso al proveedor de control de código fuente.

    Pida al administrador del control de código fuente que incremente sus derechos de acceso y vuélvalo a intentar o intente agregar el proyecto en otra parte del árbol de proyectos.

    Conéctese de nuevo a VSS con la contraseña apropiada.

    (Si ha obtenido otros errores procedentes de éste, revise sus causas para obtener más causas posibles.)


No se pudo eliminar automáticamente el archivo del proveedor de control de código fuente

Este error tiene la solución siguiente:

  • Abra la aplicación de control de código fuente y elimine manualmente el archivo.


No se pudo desproteger el archivo <archivo> porque ya está desprotegido

Este mensaje tiene la siguiente causa y solución:

  • El archivo que eligió ya está desprotegido.

Los archivos almacenados en formato binario no los puede desproteger más de una persona a la vez, porque VSS no podría combinar los cambios realizados por múltiples usuarios.


No se pudo conectar Visual Basic con el control de código fuente. Compruebe la instalación del complemento del control de código fuente

Este mensaje tiene la siguiente causa y solución:

  • VSS no pudo conectarse correctamente con su host de desarrollo.

Vuelva a ejecutar el programa de instalación de VSS.


No se pueden determinar las propiedades de este elemento

Este error tiene la siguiente causa y solución:

  • Visual Basic no pudo encontrar las propiedades de este elemento.

    Ejecute el proveedor de control de código fuente y obtenga desde allí las propiedades.


El complemento de control de código fuente no se puede conectar con Visual Basic

Este mensaje tiene la siguiente causa y solución:

  • El complemento de control de código fuente no se puede conectar con Visual Basic.

    Póngase en contacto con el Soporte de productos.


No se puede inicializar la aplicación principal de control de código fuente

Este mensaje tiene la siguiente causa y solución:

  • El proveedor de control de código fuente no puede conectarse correctamente con el host del entorno de desarrollo.

Ejecute de nuevo el programa de instalación para elegir su host de entorno de desarrollo y el proveedor de control de código fuente.


No se puede cargar el proveedor de control de código fuente

Este error tiene las siguientes causas y soluciones:

  • Las cadenas de registro utilizadas para encontrar la biblioteca de vínculos dinámicos del proveedor de control de código fuente (por ejemplo, SSSCC.DLL) no son correctas, tiene la versión errónea de Visual Basic o falta el archivo SSSCC.DLL.

  • Cambió de lugar la carpeta del control de código fuente después de instalar sin actualizar el registro.

  • Falló el programa de instalación.

    Compruebe las instrucciones de instalación de su proveedor de código fuente.

    Vuelva a ejecutar el programa de instalación de VSS.


No se puede cargar el proveedor de control de código fuente; necesita una versión más reciente

Este mensaje tiene la siguiente causa y solución:

  • Está usando una versión del proveedor de control de código fuente anterior a la versión admitida.

Vuelva la última versión del proveedor de control de código fuente.


No se puede obtener el historial para este elemento

Este error tiene la siguiente causa y solución:

  • Visual Basic no pudo obtener el historial de este archivo o proyecto del proveedor del control de código fuente.

    Ejecute el proveedor de código fuente y obtenga allí el historial.


No se pueden configurar correctamente los menús del control de código fuente para este proyecto

Este error tiene la siguiente causa y solución:

  • Se ha producido un error interno mientras se configuraba el sistema de menús de control de código fuente.

    Salga de Visual Basic y reinícielo o salga de Windows y reinícielo.


No se puede iniciar el proveedor de control de código fuente

Este error tiene la siguiente causa y solución:

  • Visual Basic no pudo iniciar un componente del proveedor de control de código fuente.

    Ejecute el proveedor de control de código fuente desde su icono, el Explorador de Windows 95 o el Administrador de archivos.


No se puede compartir un archivo desde el proveedor de control de código fuente

Este error tiene la solución siguiente:

  • Ejecute el proveedor de control de código fuente y comparta desde allí los archivos.


No se puede usar el proyecto de control de código fuente seleccionado

Este mensaje tiene la siguiente causa y solución:

  • Al agregar un proyecto principal al control de código fuente, debe seleccionar un proyecto de control de código fuente en el que colocará los archivos. El proveedor de control de código fuente comprueba el proyecto de control de código fuente para asegurarse de que se puede llevar a cabo la operación. Si se encuentra un problema, se produce este error.

Siga las reglas impuestas por el proveedor de control de código fuente acerca de proyectos compatibles con el comando Agregar.


Error del comando Deshacer desprotección. Revise los archivos para comprobar el estado de sus versiones

Este error tiene la solución siguiente:

  • Abra la aplicación de control de código fuente y deshaga la protección de los archivos manualmente.

    Compruebe la ventana Resultados para obtener otras condiciones de error. Si las encuentra, corríjalas y vuelva a intentar la operación.


No se puede ejecutar el Explorador de VSS

No se puede ejecutar el Explorador de VSS.

Es posible que haya un apuntador incorrecto a la ubicación del programa de VSS. Póngase en contacto con el Soporte de productos.


¿Desea agregar el archivo <archivo> al proyecto actual de control de código fuente?

En la mayoría de los casos, haga clic en Sí para mantener sincronizados los proyectos de Visual Basic y del control de código fuente. Puede hacer clic en No si está probando un archivo que desea agregar más tarde o un archivo que no desea agregar.

Haga clic en Sí para agregar el archivo al control de código fuente.

Haga clic en No para agregar el archivo al proyecto de Visual Basic sin agregarlo al proyecto de control de código fuente.


¿Desea agregar los nuevos archivos al proyecto actual de control de código fuente?

Este mensaje tiene la siguiente causa y solución:

  • Está agregando, directa o indirectamente mediante un asistente u otra herramienta, varios archivos al control de código fuente.

Haga clic en Sí para agregar los archivos o en No para cancelar la operación.


¿Desea proteger todos los archivos que han cambiado?

Haga clic en Sí para proteger todos los archivos.

Haga clic en No para dejar la protección para otro momento.


¿Desea proteger todos los archivos que ha desprotegido en el proyecto <proyecto>?

Este mensaje tiene la siguiente causa y solución:

  • Está cerrando el entorno de programación dejando archivos desprotegidos.

Al cerrar su entorno de programación, VSS le recuerda que tiene archivos del proyecto desprotegidos y le pregunta si desea protegerlos. No es necesario protegerlos, pero si los deja desprotegidos otros usuarios no podrán desprotegerlos.


¿Desea desproteger el archivo <archivo>?

Este error tiene la siguiente causa y solución:

  • Intentó modificar al archivo de Visual Basic <archivo>, sin haberlo desprotegido.

Haga clic en Sí para desproteger el archivo o en No para cancelar esta operación.


¿Desea obtener la última copia protegida de los archivos en este proyecto?

Haga clic en Sí para obtener la última versión de los archivos.

Haga clic en No para conservar las versiones que tiene de los archivos.


¿Desea obtener la última versión de todos los archivos del proyecto <proyecto>?

Este mensaje tiene la siguiente causa y solución:

  • Esta consulta le pregunta si desea obtener las últimas versiones de todos los archivos que están en la carpeta de trabajo de su proyecto.

Elija Sí para obtener las últimas versiones de todos los archivos del proyecto. Elija No para cancelar. Puede utilizar el comando Opciones para desactivar este mensaje de consulta.


¿Desea quitar el archivo <archivo> del control de código fuente?

Este mensaje tiene la siguiente causa y solución:

  • Quitó un objeto del proyecto de desarrollo.

Haga clic en Sí para quitar también el objeto del control de código fuente o haga clic en No para dejar el objeto en el proyecto de control de código fuente.


¿Desea guardar sus archivos antes de continuar con esta operación <proveedor>?

Este error tiene la siguiente causa y solución:

  • No guardó los archivos antes de realizar una operación del proveedor de control de código fuente.

    Haga clic en Sí para guardar los archivos.

    Haga clic en No para permitir a VSS sobreescribir los cambios hechos en la última operación de guardar.


Puede compartir otro archivo de proyecto en este proyecto de control de código fuente, pero el archivo de proyecto no se ha agregado al proyecto de VB

Este error tiene la siguiente causa y solución:

  • Intentó compartir un archivo de proyecto de otro proyecto en el actual, pero no agregó el archivo de proyecto en VSS.

Agregue primero el archivo de proyecto al propio proyecto.


No tiene archivos desprotegidos desde el control de código fuente

Este mensaje tiene la siguiente causa y solución:

  • Eligió el comando Agregar, Desproteger, Proteger o Deshacer desprotección, pero después de una cuidadosa comprobación, no había ningún archivo disponible para la operación.

Este error se produce a veces si alguien elimina el archivo con el que desea trabajar (o elimina todo el proyecto); asegúrese de que el proyecto sigue existiendo. A continuación, asegúrese de que tiene algún archivo desprotegido.


No tiene ningún archivo para proteger

Este error tiene la siguiente causa y solución:

  • Intentó proteger archivos, pero no hay ninguno desprotegido.

Si ha realizado cambios en un archivo que desea proteger, ejecute el Explorador de VSS, seleccione el archivo y, en el menú SourceSafe, haga clic en Desproteger. Asegúrese de hacer clic en la opción No obtener copia local del cuadro de diálogo Desproteger o, de lo contrario, perderá los cambios.


No tiene un programa de control de código fuente (como Microsoft Visual SourceSafe) instalado en su equipo

Este mensaje tiene la siguiente causa y solución:

  • No agregó ningún programa de control de código fuente a su equipo.

Por tanto, los comandos de control de código fuente no están disponibles. Haga clic en Sí para mostrar esta advertencia la próxima vez que intente utilizar comandos de control de código fuente o haga clic en No para desactivar este mensaje de advertencia.

Para los usuarios de VSS, ejecute NETSETUP.EXE desde la carpeta de SourceSafe para obtener capacidades de control de código fuente. Para otros proveedores de control de código fuente, vuelva a ejecutar el programa de instalación de su proveedor.


Ha elegido no desproteger el archivo de proyecto de Visual Basic; se perderán todos los cambios realizados durante esta sesión

Este mensaje tiene la siguiente causa y solución:

  • Es una advertencia que le avisa que si no desprotege el archivo de proyecto, cualquier cambio realizado durante esta sesión no se guardará en el control de código fuente.

Desproteja el archivo de proyecto si quiere que se guarden sus cambios.


Ha creado un nuevo proyecto con un nombre diferente. El nuevo proyecto ya no está asociado al control de código fuente

Este mensaje tiene la siguiente causa y solución:

  • Cambió el nombre de un proyecto y éste ya no está disponible en el control de código fuente.

Agregue el nuevo proyecto al control de código fuente, si lo desea.


Ha creado un nuevo proyecto

Este error tiene la siguiente causa y solución:

  • Ha elegido guardar el proyecto en otra carpeta diferente, pero el proveedor de control de código fuente no puede asignar directamente el nombre de la nueva carpeta.

El proyecto antiguo está aún bajo el control de código fuente, pero el nuevo no. Utilice el comando Agregar proyecto para agregar manualmente el nuevo nombre del proyecto al control de código fuente.


No ha agregado suficientes archivos al control de código fuente para tener un proyecto completo

Este mensaje tiene la siguiente causa y solución:

  • Intentó agregar algunos archivos al control de código fuente, pero no hay suficientes para definir completamente un proyecto. Este proyecto no se ha conectado con el control de código fuente.

VSS necesita mantener todos los archivos del proyecto. Agregue el grupo completo al proyecto de VSS.


No ha agregado el archivo .acb al control de código fuente para tener una base de datos completa

Este mensaje tiene la siguiente causa y solución:

  • Agregó un proyecto Access pero no eligió agregar un archivo .ACB.

Vuelva a agregar el proyecto al control de código fuente e incluya el archivo .ACB.


No ha agregado el archivo de proyecto al control de código fuente. Este proyecto no se ha conectado con el control de código fuente

Este error tiene la siguiente causa y solución:

  • Agregó un nuevo proyecto al control de código fuente, pero no incluyó el archivo de proyecto.

Vuelva a agregar el proyecto e incluya el archivo de proyecto.


Ha intentado cambiar el archivo de proyecto de Visual Basic sin desprotegerlo primero

Este mensaje tiene la siguiente causa y solución:

  • Necesita desproteger el archivo de proyecto de Visual Basic antes de que pueda realizar cambios en él.

Debe desproteger el archivo de proyecto y después realizar sus cambios.


Debe desproteger el proyecto antes de poder realizar este comando

Este error tiene la siguiente causa y solución:

  • Intentó realizar un comando que requiere que se desproteja el archivo de proyecto de Visual Basic antes de desproteger el archivo de proyecto.

    Desproteja el archivo de proyecto de Visual Basic antes de continuar y vuelva a intentar realizar el comando.


No se ha guardado el archivo de proyecto. Guarde el archivo de proyecto antes de realizar operaciones de control de código fuente

Este error tiene la siguiente causa y solución:

  • El control de código fuente requiere que guarde el archivo de proyecto de forma que sólo tenga que trabajar con un archivo.


No se ha guardado el proyecto

Este error tiene la siguiente causa y solución:

  • Debe guardar el proyecto antes de utilizarlo con control de código fuente.

    Guarde el proyecto y vuelva a intentar el comando.


No se ha guardado el proyecto. Guarde el proyecto antes de agregarlo al control de código fuente

Este error tiene la siguiente causa y solución:

  • El control de código fuente requiere que guarde el proyecto para que no se pierdan los cambios.


No se encuentra el tema

No se halló el tema correspondiente. A continuación enumeramos algunas posibles razones y sus soluciones:

  • El archivo (.chm) que contiene el tema de destino no se encuentra en la ubicación esperada.

    Solución: vuelva a ejecutar la instalación de la Biblioteca MSDN.

  • El archivo (.chm) que contiene el tema actual o el de destino no está actualizado y el vínculo ya no es válido.

    Solución: instale la última versión de la Biblioteca MSDN.

  • El CD de la Biblioteca MSDN no está en la unidad de CD-ROM.

    Solución: inserte el CD en la unidad.


¿Desea agregar este proyecto a <proyecto>?

Este mensaje tiene la siguiente causa y solución:

  • No agregó este proyecto al control de código fuente.

Haga clic en Sí para agregar este proyecto al control de código fuente. Haga clic en No para dejar este proyecto fuera del control de código fuente (por ejemplo, para depurar el código primero).


El proveedor de control de código fuente no se inicializó correctamente

Este mensaje tiene la siguiente causa y solución:

  • El proveedor de control de código fuente se cargó pero no se pudo iniciar.

Ejecute de nuevo el programa de instalación de su proveedor de control de código fuente.


Error al abrir el archivo <archivo> para comprobar los cambios

Este mensaje tiene la siguiente causa y solución:

  • Se encontró con un error interno de control de código fuente.

Salga y vuelva a iniciar VSS. Si esto no resuelve el problema, vuelva a instalar VSS y reinicie su equipo. Si esto no resuelve el problema, compruebe que tiene memoria y espacio en disco suficientes, compruebe el espacio en disco del servidor y compruebe la conexión de red con su equipo.


Esta operación requiere desproteger primero el archivo de proyecto de Visual Basic. ¿Desea desproteger el archivo de proyecto de Visual Basic?

Este mensaje tiene la siguiente causa y solución:

  • Necesita desproteger el archivo de proyecto de Visual Basic antes de que pueda realizar cambios en él.

Debe desproteger el archivo de proyecto y después realizar sus cambios.


El proyecto <proyecto> que ha seleccionado no contiene este proyecto de Visual Basic

Este mensaje tiene la siguiente causa y solución:

  • Esta advertencia le informa de que mientras intentaba explorar un proyecto eliminado eligió el proyecto erróneo.

Vuelva a intentar la operación de exploración.


<archivo> no es un archivo de registro válido o está dañado

Este mensaje tiene la siguiente causa y solución:

  • VSS no puede encontrar o leer su archivo de registro.

    Ejecute Analyze.exe con la opción -F. Si es necesario, póngase en contacto con el soporte técnico para obtener más ayuda.


Se ha dañado el historial para el archivo <archivo> después de la revisión <número>

Este mensaje tiene la siguiente causa y solución:

  • La base de datos VSS ha sido dañada.

    Ddconv.EXE guarda todo lo posible de la base de datos, pero perderá irremediablemente alguna información (a menos que haya hecho copia de seguridad de la base de datos y pueda recuperar la información de dicha copia)


Nombre de archivo o de proyecto no válido: <archivo>

Vea también

Este mensaje tiene la siguiente causa y solución:

  • Especificó un nombre de archivo o de proyecto no válido.

    Asegúrese de que el nombre se escribió correctamente. Si no está seguro de qué caracteres puede utilizar en un nombre VSS, compruebe los temas relacionados con la Sintaxis y convenciones de nomenclatura.


La sintaxis de la versión no es válida: <número>

Este mensaje tiene la siguiente causa y solución:

  • El número de versión especificado utiliza una sintaxis no válida.

    Asegúrese de que escribió la información correctamente.


La ruta de distribución <ruta de acceso> no es un archivo de sistema válido o una ruta de distribución FTP

Este mensaje tiene la siguiente causa y solución:

  • Una de las rutas de acceso especificadas para desplegar el proyecto no es una ruta válida del sistema de archivos del sistema operativo o no es una dirección URL válida para FTP.

    Las rutas de acceso ftp tienen la siguiente apariencia.

    ftp://usuario:usuario@www.microsoft.com/spain/ssafe
ftp://usuario@www.microsoft.com/spain/ssafe
ftp://www.microsoft.com/spain/ssafe

    Siempre empiezan con "ftp://". Siempre terminan con la dirección ftp (nombre de servidor y, opcionalmente, ruta de acceso del directorio). En el medio puede no haber nada (como en el último ejemplo anterior). O bien, puede haber un nombre de usuario (como en el ejemplo central) o un nombre de usuario y una contraseña (como en el primer ejemplo).


La dirección URL <URL> no tiene una sintaxis URL de HTTP apropiada

Este mensaje tiene la siguiente causa y solución:

  • La dirección URL que especificó tiene una sintaxis no válida.

    La sintaxis válida para la dirección URL se muestra en estos ejemplos:

    http://www.microsoft.com/spanish/default.htm
http://www.microsoft.com/spanish


Los archivos binarios son diferentes

Este mensaje tiene la siguiente causa y solución:

  • Los archivos binarios que ha seleccionado son diferentes.

    El comando Mostrar diferencias no muestra línea por línea las diferencias entre archivos binarios. Por tanto, VSS sólo puede decirle si la copia maestra de VSS es diferente de su copia local.


No se puede distinguir el elemento <elemento> especificado

Al menos uno de los elementos que ha seleccionado para comparar con otro elemento no se puede distinguir en VSS.


No se puede abrir una conexión para el host FTP <host>

Este mensaje tiene la siguiente causa y solución:

  • VSS no pudo abrir una conexión con el host FTP especificado.

    Compruebe sus conexiones de red y si ha utilizado la sintaxis correcta al escribir el host ftp. Este error se podría producir si su host ftp no está disponible en este momento.


No se puede distribuir <proyecto> al host FTP <host>

Este mensaje tiene la siguiente causa y solución:

  • VSS no pudo abrir una conexión con el host ftp especificado y desplegar su proyecto.

    Compruebe sus conexiones de red y asegúrese de que ha escrito la sintaxis correcta para el host FTP. Este error también se puede producir si su host ftp no está disponible en este momento.


No hay ninguna aplicación asociada con este tipo de archivo

Este mensaje tiene la siguiente causa y solución:

  • Intentó ver un archivo para el que no existe ninguna asociación de archivo. Sin esta asociación, VSS no sabe qué editor debe utilizar para mostrar dicho archivo.

    Use el Administrador de archivos para asignar una asociación a este archivo e intente ejecutar el comando otra vez.

    Si desea invalidar la asociación del Administrador de archivos para un determinado tipo de archivos, puede especificar determinadas asociaciones en el archivo SS.INI; por ejemplo:

    .C = C:\VC\VC.EXE
.FRM = C:\WINDOWS\NOTEPAD.EXE


Se está usando una versión anterior de <archivo> y no se puede cambiar. Deshaga para hacer que esa versión sea la más reciente si necesita cambiarla

Vea también

Este mensaje tiene la siguiente causa y solución:

  • Intentó modificar una versión antigua de archivo.

    Si desea que un proyecto utilice siempre una versión específica y no reciba los cambios protegidos realizados en otros proyectos, puede compartir una determinada versión del archivo mediante el comando Fijar del cuadro de diálogo Historial del archivo.

    Si desea empezar por modificar el archivo desde una versión antigua, puede deshacer los cambios realizados en el archivo. El comando Deshacer sólo afecta al proyecto actual; realiza implícitamente una operación distinta. Bifurcar y Deshacer están disponibles desde el cuadro de diálogo Historial del archivo.


¿Realmente desea quitar todos los archivos de <proyecto>?

Esta advertencia tiene la siguiente causa y solución:

  • Esta acción eliminará todos los archivos especificados en su directorio temporal.

    Puede cancelar la operación o continuar con la eliminación de todos los archivos temporales.


Se ha borrado el directorio local de archivos temporales

Se ha borrado el directorio local de archivos temporales.


No hay elementos sobre los que actuar

Este mensaje tiene la siguiente causa y solución:

  • Está intentando realizar una acción sin seleccionar antes un elemento sobre el que actuar.

    Haga clic en un elemento para seleccionarlo e intente la acción de nuevo.


Algunos conflictos no se han resuelto. ¿Desea guardar el archivo?

Esta advertencia tiene la siguiente causa y solución:

  • No se han resuelto todos los conflictos en el archivo combinado.

    Haga clic en Sí para guardar el archivo no resuelto o en No para descartar los cambios y salir.


<base de datos> ya está en la lista de la base de datos

Este mensaje tiene la siguiente causa y solución:

  • La base de datos ya existe en la lista de Bases de datos disponibles.

    Seleccione la entrada correspondiente en la base de datos, tal y como aparece en la lista de Bases de datos disponibles.


La base de datos <base de datos> no existe. ¿Desea buscarla?

Este mensaje tiene la siguiente causa y solución:

  • Está intentando buscar una base de datos que no existe.

    Haga clic en Sí para buscar la base de datos de VSS correcta o en No para cancelar la operación.


Esta base de datos no tiene nombre. Solicite a su administrador que le proporcione primero un nombre

Este mensaje tiene la siguiente causa y solución:

  • La base de datos no tiene nombre. Falta la entrada de Database_Name en el archivo SRCSAFE.INI.

    Pida a su administrador de VSS que de un nombre a la base de datos.


VSS no puede encontrar una base de datos predeterminada. ¿Desea seleccionar una?

Este mensaje tiene la siguiente causa y solución:

  • VSS está intentando buscar una base de datos predeterminada que no existe.

    Haga clic en Sí para buscar la base de datos de VSS correcta o en No para cancelar la operación.


La base de datos <base de datos> no existe. Seleccione otra

Este mensaje tiene la siguiente causa y solución:

  • Está intentando buscar una base de datos que no existe.

    Haga clic en el botón Examinar para buscar la base de datos de VSS correcta o en No para cancelar la operación.


La ruta de la base de datos de VSS <ruta de acceso> no existe. Seleccione otra base de datos

Este mensaje tiene la siguiente causa y solución:

  • La ruta de acceso de la base de datos de VSS no existe. La entrada de Data_Path en el archivo SRCSAFE.INI no es válida.

    Pida a su administrador de VSS que compruebe la ruta de acceso a la base de datos de VSS en el archivo SRCSAFE.INI.


¿Desea quitar <base de datos> de la lista de la base de datos?

Esta advertencia tiene la siguiente causa y solución:

  • Está eliminando una entrada de base de datos VSS de la lista de Bases de datos abiertas de SourceSafe.

    Haga clic en Sí para eliminar la entrada especificada o en No para dejar la entrada de la base de datos en la lista.


<base de datos> ya está en la lista de la base de datos. ¿Desea cambiar el nombre?

Este mensaje tiene la siguiente causa y solución:

  • Está cambiando el nombre de una entrada de base de datos VSS en la lista de Bases de datos abiertas de SourceSafe.

    Haga clic en Sí para cambiar el nombre de la entrada seleccionada o en No para dejar la entrada de la base de datos tal y como aparece en la lista.


<Archivo> está desprotegido por <usuario>; si lo elimina cancelará la desprotección. ¿Desea continuar?

Esta advertencia tiene la siguiente causa y solución:

  • Está intentando eliminar un archivo desprotegido.

    Este mensaje de advertencia le da la oportunidad de no eliminar un archivo equivocado. Si el nombre del archivo es correcto, haga clic en Sí para continuar. Haga clic en No para cancelar la operación de eliminar.


Tiene desprotegido <archivo>; si lo elimina cancelará la desprotección

Esta advertencia tiene la siguiente causa y solución:

  • Está intentando eliminar un archivo desprotegido.

    Si el nombre del archivo es correcto, haga clic en Sí para continuar. Para cancelar la operación de eliminación, haga clic en No.


No se encontró la carpeta

Este mensaje tiene la siguiente causa y solución:

  • Ha especificado una carpeta del sistema operativo que no se ha podido encontrar.

    Asegúrese de que la carpeta que ha indicado es correcta. Compruebe las mayúsculas y minúsculas en aquellos sistemas operativos en los que se establezcan diferencias entre ellas.


La cadena de fecha no es válida

VSS no puede utilizar la sintaxis que ha usado para la fecha. Este mensaje tiene la siguiente causa y solución:

  • La fecha que ha introducido no es válida.

    La sintaxis correcta para la fecha es Mes/Día/Año, separando cada número con una barra inclinada: por ejemplo, 2/29/64 ó 11/5/1992.


La cadena de hora o fecha no es válida

VSS no puede utilizar la sintaxis que ha usado para la fecha o la hora. Este error tiene las causas y soluciones siguientes:

  • La fecha que ha introducido no es válida.

    La sintaxis correcta para la fecha es Mes/Día/Año, separando cada número con una barra inclinada: por ejemplo, 2/29/64 ó 11/5/1992.

  • La hora que ha introducido no es válida.

    La sintaxis de hora adecuada es Hora:Minuto, seguida de un indicador A.M. o P.M. de una letra: por ejemplo, 9:30A o 5:00p. (El indicador no distingue entre mayúsculas y minúsculas.) O puede usar el formato de 24-horas como 13:45.


Hay demasiados controladores de archivo abiertos

Este mensaje tiene la siguiente causa y solución:

  • Hay demasiados archivos abiertos en el sistema.

    Cerrar algunos archivos abiertos.


Se ha denegado el acceso al archivo <archivo>

Bajo determinadas condiciones, VSS deniega el acceso a un archivo a un usuario. Este error tiene las causas y soluciones siguientes:

  • Se le denegó el acceso (privilegios de lectura o escritura) a un archivo que VSS intentaba abrir.

    Es posible que otro usuario tenga el archivo bloqueado momentáneamente; vuélvalo a intentar.

  • Puede que no tenga suficientes privilegios de red para llevar a cabo la acción que intenta realizar.

    Consulte su administrador de VSS para obtener más información acerca de sus derechos de acceso VSS.


La unidad no es válida: <unidad>

Este mensaje tiene la siguiente causa y solución:

  • La unidad a la que está intentando tener acceso no es válida. Puede que se haya equivocado al especificar la unidad, ya sea en el Explorador de VSS o en un archivo de inicialización.

    Compruebe si ha escrito correctamente la especificación de unidad.


El nombre de archivo no es válido: <archivo>

Este mensaje tiene la siguiente causa y solución:

  • Escribió el nombre de un archivo con una sintaxis no válida.

    Compruebe lo que ha escrito o seleccione otro nombre diferente con caracteres válidos. También puede obtener este error si tiene múltiples archivos seleccionados e intenta usar un comando para un único archivo, como Ver.


El disco está lleno

Este mensaje tiene la siguiente causa y solución:

  • Intentó guardar datos en un disco lleno.

    Libere espacio en disco; para ello, elimine o mueva archivos innecesarios.


El archivo <archivo> ya existe

Este mensaje tiene la siguiente causa y solución:

  • Intentó crear un archivo o una carpeta con un nombre ya existente.

    Puede dar el mismo nombre a varios archivos VSS siempre que estén en diferentes directorios, pero sólo puede aparecer una vez en un único directorio. Seleccione un nombre diferente o cambie el nombre del archivo o el proyecto que está provocando el problema.


El archivo <archivo> está bloqueado

Este mensaje tiene la siguiente causa y solución:

  • El archivo al que está intentando tener acceso está en uso.

    Espere y vuelva intentar la operación más tarde.


No se ha encontrado el archivo <archivo>

VSS no ha podido encontrar el archivo que estaba buscando. Este mensaje tiene las siguientes causas y solución:

  • Es posible que haya tecleado mal un nombre de archivo en el explorador de VSS o en una variable del archivo de inicialización.

  • Puede que el archivo no exista.

    Asegúrese de que ha escrito correctamente el nombre del archivo.


Error al leer el archivo

VSS no puede leer uno de los archivos que ha abierto. Este mensaje tiene la siguiente causa y solución:

  • Puede que haya perdido la conexión con la red.

    Salga de VSS y compruebe todas las conexiones de red antes de reiniciar.


Hay demasiados controladores de archivo abiertos

Este mensaje tiene la siguiente causa y solución:

  • Hay demasiados archivos abiertos en el sistema.

    Compruebe si se puede cerrar alguno de los archivos o bien, puede que desee aumentar el contador de archivos en el archivo de inicialización del sistema operativo.


Error al escribir en el archivo

VSS no puede escribir datos en uno de los archivos que ha abierto. Este mensaje tiene la siguiente causa y solución:

  • Puede que el disco esté lleno.

    Salga de VSS y libere espacio en el disco eliminando los archivos que no sean necesarios.


No se encuentra esta versión del archivo en el archivo de almacenamiento local

No hay elementos eliminados para este proyecto.


No se pudo iniciar la sesión en <sitio ftp>

Este mensaje tiene la siguiente causa y solución:

  • No puede iniciar la sesión en el sitio ftp especificado.

    Puede que esté usando una dirección, un nombre de usuario o una contraseña no válidos, o quizá el sitio no responde. Asegúrese de que tiene la dirección ftp apropiada.


No se pudo distribuir <proyecto> en <host>

Este mensaje tiene la siguiente causa y solución:

  • VSS no pudo abrir una conexión con el host ftp especificado y desplegar su proyecto.

    Compruebe sus conexiones de red y verifique que ha utilizado la sintaxis correcta para el host ftp. Este error también se puede producir si su host ftp no está disponible en este momento.

    Este mensaje puede querer decir también que no queda espacio en el disco. También puede significar que no tiene permiso para escribir en la ubicación aunque pueda tener permiso de lectura.


¿Desea obtener todo el proyecto en esta etiqueta?

Este mensaje tiene la siguiente causa y solución:

  • Ha obtenido el archivo de una etiqueta desde el cuadro de diálogo Historial del proyecto.

    Haga clic en Sí para obtener el proyecto completo en esa etiqueta. Haga clic en no para obtener tan sólo el archivo en esa etiqueta.


¿Desea obtener todo el proyecto que contiene esta versión de archivo?

Vea también

Este mensaje tiene la siguiente causa y solución:

  • Seleccionó un archivo en la lista del cuadro de diálogo Historial del archivo e hizo clic en Obtener.

    Haga clic en Sí, y VSS obtendrá todo el proyecto tal y como existía inmediatamente antes de que se activase la protección seleccionada.

    Haga clic en No, y VSS obtendrá tan sólo la el archivo de la versión que ha seleccionado, sin obtener ningún otro archivo del proyecto.


No hay elementos en la lista

Este mensaje tiene la siguiente causa y solución:

  • Especificó una operación de historial donde no hay elementos que cumplan el criterio especificado.

    Examine las casillas de verificación del cuadro de diálogo Opciones de historial y asegúrese de que estén correctamente establecidas.


El comentario de etiqueta no es válido cuando no se ha especificado ninguna etiqueta

Este mensaje tiene la siguiente causa y solución:

  • Especificó un comentario para una etiqueta pero no ha proporcionado ninguna.

    Si desea etiquetar un archivo o un proyecto y quiere incluir un comentario, debe especificar la etiqueta y el comentario.


No se pueden deshacer los cambios antes de fijar una versión

Esta advertencia tiene la siguiente causa y solución:

  • Intentó deshacer los cambios de un archivo a una versión anterior a la que se fijó.

    No se pueden deshacerse los cambios del archivo a una versión anterior a la versión en la que se fijó. Para deshacer los cambios del archivo, libere el archivo y entonces deshaga los cambios.


No se puede encontrar el archivo de Ayuda <archivo>

Este mensaje tiene la siguiente causa y solución:

  • El archivo de Ayuda no está disponible.

    Pruebe a reinstalar VSS para obtener una copia del archivo de ayuda. Si, aún así, no encuentra el archivo, llame al Servicio de soporte técnico.


No se puede utilizar la carpeta de trabajo predeterminada del proyecto actual, heredada de la carpeta primaria, porque la ruta es demasiado larga

Este mensaje tiene la siguiente causa y solución:

  • VSS crea directorios de trabajo para los proyectos heredándolos de los proyectos primarios, y agregando después los nombres de los proyectos VSS que le sigan. Sin embargo, si el nombre del que se hereda es un nombre largo, no se puede exceder el límite de 260 caracteres.

    Establezca un nuevo directorio de trabajo para el proyecto en uso, o modifique y recorte el directorio de trabajo del proyecto desde el que se hereda.


La variable de inicialización <variable> debe establecerse como "Sí" o "No"

Este mensaje tiene la siguiente causa y solución:

  • La variable de inicialización debería estar establecida a Yes o No, pero no es así.

    Cambie la variable para que quede establecida a Yes (o True) o No (False).

Nota Puede utilizar cualquier editor de textos para modificar o eliminar el valor no válido.


La sintaxis no es válida en la línea <línea> del archivo <archivo>

Este mensaje tiene la siguiente causa y solución:

  • La sintaxis de una o más líneas del archivo de inicialización no es válida.

    Busque en la Ayuda información acerca de la sintaxis adecuada de la variable de inicialización.

Nota Puede utilizar cualquier editor de textos para modificar o eliminar la línea errónea.


La variable de inicialización <variable> contiene un número no válido

Se asignó de forma incorrecta la variable de inicialización especificada. Este mensaje tiene la siguiente causa y solución:

  • La variable de inicialización debería estar establecida como un número arábigo, pero no es así. Por ejemplo, puede estar establecida a "dos" cuando debería haberse establecido a "2".

    Busque en la Ayuda información acerca de la sintaxis adecuada de los archivos de inicialización.

Nota Puede utilizar cualquier editor de textos para modificar o eliminar el número erróneo.


La variable de inicialización <variable> contiene una ruta no válida

Una variable de inicialización que debería contener una ruta de carpeta válida contiene una ruta no válida. Este mensaje tiene la siguiente causa y solución:

  • Puede que la sintaxis de la ruta sea incorrecta o que la ruta no exista.

    Compruebe que la ruta existe o que la sintaxis es correcta y cámbiela si es necesario.

Nota Puede utilizar cualquier editor de textos para cambiar o eliminar la ruta errónea.


La variable de inicialización <variable> contiene un valor no válido

Este mensaje tiene la siguiente causa y solución:

  • Se ha asignado a la variable de inicialización un valor no válido.

    Busque en la Ayuda información acerca de la sintaxis adecuada.

Nota Puede utilizar cualquier editor de textos para modificar o eliminar el valor no válido.


No se puede encontrar la variable de inicialización <variable>

VSS no puede encontrar una variable de inicialización que necesita para realizar una operación. Este mensaje tiene la siguiente causa y solución:

  • No se encuentra la variable de inicialización necesaria para completar la operación.

    Busque en la Ayuda o en Manual del usuario de Microsoft Visual SourceSafe información acerca de la variable, asigne un valor adecuado y agregue la variable a su archivo de inicialización.


La variable de inicialización <variable> debe estar entre <número> y <número>

Un número de inicialización está fuera del intervalo permitido. Este mensaje tiene la siguiente causa y solución:

  • Se ha establecido una variable de inicialización como un número no válido.

    Busque en la Ayuda información acerca de la configuración válida.

Nota Puede utilizar cualquier editor de textos para modificar o eliminar el número erróneo.


No se puede encontrar el archivo SS.INI

VSS no puede encontrar su archivo SS.INI. Este mensaje tiene las siguientes causas y solución:

  • El archivo SS.INI no está donde VSS esperaba encontrarlo. (Pregunte al Administrador de VSS si movió el archivo.)

  • Eliminó sin querer el archivo SS.INI.

    Puede copiar un archivo SS.INI de otro usuario a su carpeta de VSS y después modificarlo para personalizar VSS. Su administrador deberá configurar VSS para que busque el archivo en el lugar correcto.


El valor <valor> en la ficha Tipos de archivo no es válido

Este mensaje tiene la siguiente causa y solución:

  • Intentó crear un tipo de archivo utilizando caracteres que no son válidos.

    Los nombres de tipos de archivo no pueden contener los siguientes caracteres: [ ] ( ) , ;. El valor de un tipo de archivos es un modelo de búsqueda y no puede contener caracteres que no sean válidos. Además, no puede dejar en blanco el cuadro de texto Tipos de archivos incluidos en grupo de archivos. Consecuentemente, se debe escribir algún tipo de archivos.


La dirección <dirección> no es una dirección FTP válida

Este mensaje tiene la siguiente causa y solución:

  • Especificó una dirección ftp no válida.

    Escriba de nuevo la dirección; revise la ortografía y si la dirección está legitimada.


<Tipo> no es una máscara válida

Este mensaje tiene la siguiente causa y solución:

  • Ha especificado una máscara no válida en la ficha Tipos de archivo del cuadro de diálogo Opciones del menú Herramientas.

    Debe especificar un carácter * o ? en su máscara de archivo y no puede tener en la máscara caracteres no válidos como (, ), [ o ].

    Vuelva a escribir la máscara de archivo usando caracteres válidos.


No se ha actualizado el archivo <archivo> de manera apropiada. Pida al administrador de SourceSafe que ejecute la utilidad Analyze para volver a generarlo

Este mensaje tiene la siguiente causa y solución:

  • Mientras intentaba mantener el archivo labels.ini actualizado, VSS no ha podido escribir en el mismo. Cualquier intento de realizar una obtención por etiqueta no verá la etiqueta hasta que el administrador de VSS ejecute Analyze.

    Pida al administrador de VSS que ejecute la utilidad Analyze.


No se puede iniciar el explorador de Web en la página <archivo>

Este mensaje tiene la siguiente causa y solución:

  • VSS no ha podido iniciar su explorador del Web.

    Compruebe que su explorador del Web está funcionando normalmente. Puede que necesite volver a instalar el explorador para comprobar los valores del Registro.


La base de datos actual no coincide con la solicitada

Este mensaje tiene la siguiente causa y solución:

  • Se ha producido un error interno de VSS. VSS asume que la base de datos en la que ha iniciado la sesión debe estar en un formato nuevo.

    Llame al Administrador VSS para ejecutar DDUPD –redo, o para ponerse en contacto con el soporte técnico.


Error al intentar localizar el directorio de archivos temporales

Este mensaje tiene la siguiente causa y solución:

  • Falta la entrada de Temp_Path en el archivo SRCSAFE.INI.

    Pida a su Administrador VSS que arregle la entrada Temp_Path en el archivo SRCSAFE.INI


No se encuentra el directorio local de archivos temporales en la ubicación <ruta de acceso>

Este mensaje tiene la siguiente causa y solución:

  • El directorio local de archivos temporales se ha perdido o se ha eliminado accidentalmente.

    Cree el directorio local de archivos temporales tal y como se especifica, o pida al administrador de VSS que resuelva el problema.


Falló el inicio de sesión. La información de inicio de sesión suministrada no es válida y debe modificarse para validar la información de inicio de sesión para esta base de datos

Este mensaje tiene la siguiente causa y solución:

  • No ha podido iniciar una sesión en VSS.

    Intente iniciar de nuevo la sesión en la base de datos correcta, con la información de usuario apropiada. Asegúrese de que BLOQ MAYÚS está desactivado.


Una combinación de <archivo> ha producido un archivo de 0 bytes. Puede que se hayan perdido datos. ¿Desea deshacer la combinación? (se recomienda)

Este mensaje tiene la siguiente causa y solución:

  • Un archivo de longitud cero indica un posible error interno de VSS que ha dado como resultado la pérdida de los datos durante la operación de combinación.

    Recomendado: deshacer la combinación haciendo clic en Sí. Sin embargo, si está seguro de que ha realizado alguna operación en la que se ha obtenido como resultado un archivo válido de longitud cero, puede hacer clic en No para guardar el archivo combinado de longitud cero.


Error al escribir el archivo de combinación para <archivo>

Se ha producido un error interno y la operación de combinación ha sido deshecha.


No se pudo encontrar el archivo de almacenamiento local de etiquetas <archivo>. Pida al Administrador de VSS que ejecute el utilidad Analyze para volver a generarlo

Este mensaje tiene la siguiente causa y solución:

  • Alguien ha eliminado este archivo de manera intencionada o un equipo se ha quedado bloqueado al intentar escribir en él.

    Ejecute Analyze sobre la base de datos tan pronto como sea posible. No etiquete más archivos o proyectos, ni intente obtener una etiqueta hasta que se complete el análisis.


<ruta de acceso> no es una especificación completa de VSS ni una ruta válida

Este mensaje aparece en el cuadro de diálogo Diferencias de proyecto cuando se ha especificado un nombre de archivo o un nombre de proyecto de VSS no válido.


No se ha encontrado la red

Este mensaje tiene la siguiente causa y solución:

  • No hay ninguna red instalada o VSS no puede encontrar una red válida.

    Puede que no haya instalada ninguna red o que una o más conexiones de red han fallado. Compruebe el hardware de la red y asegúrese de que todos los controladores de red necesarios estén en ejecución. Indique su administrador de VSS que haga comprobaciones adicionales.


El archivo <nombre de archivo> no está bifurcado en <nombre de proyecto>

Este mensaje tiene la siguiente causa y solución:

  • El archivo que está intentando combinar no está bifurcado.

    Cuando un archivo está bifurcado y desea combinar las diferentes versiones del archivo en un archivo combinado, puede utilizar el comando Combinar bifurcaciones. En este caso, el archivo no está bifurcado, por lo que Combinar bifurcaciones no tiene ningún efecto.


No se ha establecido una ruta de distribución para <nombre de archivo o de proyecto>

Este mensaje tiene la siguiente causa y solución:

  • Intentó desplegar un proyecto sin especificar una ruta de despliegue para el proyecto en el programa Administrador.

    Pida al administrador de VSS que establezca una ruta de despliegue para el proyecto Web.


Los archivos son idénticos

Este mensaje tiene la siguiente causa y solución:

  • Los archivos que ha seleccionado, la copia maestra de VSS y la copia local, son idénticos. Puede que haya seleccionado un archivo en la lista de archivos e intentado ejecutar el comando Mostrar diferencias sólo en este archivo, en cuyo caso se está comparando el archivo consigo mismo y, por definición, es idéntico.

    En este caso, antes de volver a aplicar el comando Mostrar diferencias, especifique dos archivos diferentes.


Advertencia: Si no usa una contraseña, otros podrán iniciar una sesión en su cuenta de VSS. ¿Desea continuar sin contraseña?

Esta advertencia tiene la siguiente causa y solución:

  • Intentó iniciar una sesión sin especificar una contraseña.

    Es una advertencia informativa para asegurarse de que desea continuar sin establecer una contraseña en su cuenta. Haga clic en Sí para iniciar la sesión o en No para cancelar.


No se pudo encontrar el archivo <archivo>. Pida al administrador de SourceSafe que ejecute la utilidad Analyze para volver a generarlo

Este mensaje tiene la siguiente causa y solución:

  • El archivo labels.ini no se ha encontrado en la base de datos de VSS.

    Pida a su administrador de VSS que ejecute la utilidad Analyze o ddupd -redo.


El archivo de almacenamiento local (vss.ver) no existe

Este mensaje tiene la siguiente causa y solución:

  • Algunas características como la desprotección de versión local no pueden funcionar si no hay un archivo vssver.scc.

    La siguiente obtención de cualquier archivo creará un archivo vssver.scc.


No se puede desproteger <archivo>. Es de tipo binario y ya está desprotegido

Este mensaje tiene las siguientes causas y solución:

  • El archivo especificado es binario y ya está desprotegido. VSS no permite múltiples desprotecciones en archivos binarios, ya que sus cambios no se pueden combinar.

    Espere para desproteger el archivo a que el otro usuario lo haya protegido.


El archivo <archivo> se ha desprotegido en <carpeta>, no en <carpeta>

Esta advertencia tiene la siguiente causa y solución:

  • El archivo que está protegiendo estaba desprotegido en otra carpeta diferente.

    Al arrastrar un archivo, debe protegerlo desde la misma carpeta donde estaba desprotegido. El archivo que ha arrastrado no será protegido. Si quiere proteger el archivo desde esta carpeta, utilice el comando Proteger de VSS desde el menú SourceSafe.


No se puede mostrar esta dirección URL

Este mensaje tiene la siguiente causa y solución:

  • Ha intentado comprobar un enlace Web externo, pero en el registro no existe ningún explorador Web que permita tratar una ruta http; o, la sintaxis del enlace era incorrecta para ShellExecute (podría suceder si se intenta comprobar una raíz virtual haciendo doble clic en ella en lugar de configurando la raíz virtual).

    Instale Internet Explorer versión 3.0 (o posterior).


Este comando requiere componentes de Internet que no están instalados en su equipo

Este mensaje tiene las siguientes causas y solución:

  • Intentó utilizar el comando Comprobar vínculos de Web en una plataforma RISC pero no había ningún archivo WinINET.DLL para distribuir cuando salió al mercado VSS. Puede obtener este archivo DLL necesario cuando exista una versión RISC del explorador.

  • Falta la versión correcta del archivo WinINET.DLL en su equipo Intel o Alpha. Compruebe si el archivo se ha movido o cambiado de nombre.

    Para asegurarse de que tiene los componentes de Internet más actualizados, vaya a http://www.microsoft.com/spain/ie/ y descargue Microsoft Internet Explorer 3.0 ó posterior. Después, reinicie VSS para activar este comando.


Escriba un número entre 0 y 32767

Este mensaje tiene la siguiente causa y solución:

  • No especificó un número de líneas de contexto entre 0 y 32767.

    Las líneas de contexto son las líneas que hay inmediatamente delante y después de una diferencia. Mostrar estas líneas en la presentación de diferencias le ayuda a entender el contexto del cambio o la diferencia. Si ha activado la casilla de verificación Mostrar contexto en el cuadro de diálogo de opciones avanzadas del comando Mostrar diferencias, necesita especificar el número de líneas que preceden y que siguen que desea mostrar.


No se encontró editor <editor>

Este mensaje tiene la siguiente causa y solución:

  • Intentó ver o modificar un archivo para el que no se pudo encontrar el editor especificado. (Las asociaciones de editor a las extensiones de archivo se establecen en la ficha General a la que se tiene acceso haciendo clic en Opciones del menú Herramientas.)

    Haga clic en Sí si desea especificar otro editor diferente. Haga clic en No para cancelar la operación de edición.


La ruta del editor es un campo necesario cuando se selecciona la petición de editor

Este mensaje tiene la siguiente causa y solución:

  • Cuando active la casilla de verificación Utilizar editor para pedir comentarios debe especificar el editor adecuado.

    Establezca .la ruta en el campo Editor de la ficha Opciones de línea de comandos del cuadro de diálogo Opciones de SourceSafe del menú Herramientas.


No se encontraron diferencias en el proyecto <proyecto>

Este mensaje tiene la siguiente causa y solución:

  • Ha comparado dos elementos sin diferencias.

    Es un mensaje informativo para indicarle que no se encontraron diferencias al comparar los elementos.


Las contraseñas no coinciden

Este mensaje tiene la siguiente causa y solución:

  • La contraseña que ha escrito en el cuadro Contraseña nueva no coincide con la escrita en el cuadro Comprobar.

    Si las contraseñas especificadas son idénticas, VSS supondrá que las ha escrito correctamente y cambiará su contraseña. Si escribe dos contraseñas diferentes, VSS asume que ha escrito una contraseña incorrecta.


No se puede cambiar el nombre por <archivo>; este nombre ya existe

Vea también

El nombre de archivo especificado ya existe en el proyecto. Este mensaje tiene la siguiente causa y solución:

  • Cuando cambia el nombre de un archivo compartido por diferentes proyectos, el nombre del archivo cambia en todos los proyectos que lo comparten. Si cualquier otro de estos proyectos ya tiene un archivo con el mismo nombre, creará una situación antigua que no es válida: dos archivos del mismo proyecto con el mismo nombre. La operación de cambio de nombre falla.

    Para corregirlo, elija otro nombre para el archivo.


Debe especificar un nombre nuevo

Este mensaje tiene la siguiente causa y solución:

  • Está intentando cambiar el nombre de un archivo o un proyecto sin especificar un nombre nuevo para él.

    Escriba un nombre nuevo y después haga clic en Aceptar, o presione ESC para cancelar la operación de cambio de nombre.


No se pudo encontrar el archivo al que hace referencia el acceso directo <archivo>

Este mensaje tiene la siguiente causa y solución:

  • Imposible encontrar el archivo al que hace referencia el archivo .lnk.

    Compruebe que el archivo no se ha movido o eliminado. Haga clic en Aceptar para aceptar y volver a intentar.


<archivo> es un archivo de vínculo de Explorer

Este mensaje tiene la siguiente causa y solución:

  • Ha arrastrado un archivo .lnk en VSS.

    Cuando se arrastra un archivo .lnk a VSS, es necesario indicar al programa si se quiere agregar el archivo .lnk a la base de datos o si se quiere agregar el archivo al que apunta el archivo .lnk. Si desea agregar el archivo al que hacer referencia el archivo .lnk, haga clic en Sí. De lo contrario, haga clic en No.


Se han resuelto todos los conflictos. ¿Desea guardar el archivo?

Este mensaje tiene la siguiente causa y solución:

  • Resolvió correctamente todos los conflictos de combinación.

    Haga clic en Sí para guardar el archivo o en No para descartar los cambios.


No se encontraron coincidencias

Este mensaje tiene la siguiente causa y solución:

  • VSS ha buscado en todos los archivos seleccionados y no ha encontrado la cadena que estaba buscando.

    Asegúrese de que ha escrito la cadena correctamente.


La base de datos no está disponible. ¿Desea desactivar la integración del control de código fuente?

Este mensaje tiene la siguiente causa y solución:

  • La base de datos VSS no está disponible. Haga lcic en Sí para desactivar la integración de control de código fuente.

    Una vez que se restablezca la conexión a la base de datos de VSS, reinicie el programa con el que lo esté usando (por ejemplo, Visual C, Visual Basic o Visual J) para usar el control de código fuente.


Se ha desactivado el control de código fuente en esta aplicación. Reinicie la aplicación para usar el control de código fuente

Este mensaje tiene la siguiente causa y solución:

  • Se ha perdido la conexión al servidor, por lo que se ha desactivado el control de código fuente.

    Una vez que se restablezca la conexión a la base de datos de VSS, reinicie el programa con el que lo esté usando (por ejemplo, Visual C, Visual Basic o Visual J) para usar el control de código fuente.


¿Desea compartir siempre la versión más reciente de <archivo>?

Vea también

Generalmente, todo proyecto que comparte un archivo siempre tiene la versión más reciente del archivo. Cuando protege el archivo en cualquier proyecto se actualizan automáticamente todos los proyectos. Sin embargo, puede utilizar el botón Fijar del cuadro de diálogo Historial del archivo para compartir una determinada versión de un archivo. Este mensaje tiene la siguiente causa y solución:

  • Si hace clic en el botón Fijar del cuadro de diálogo Historial del archivo, el proyecto compartirá explícitamente la versión fijada y no recibirá los cambios protegidos realizados en otros proyectos.

  • Si hace clic en Liberar el proyecto volverá al estado compartido en el que se utiliza siempre la versión más reciente del archivo.


Debe introducir un nombre de archivo sin ruta de acceso para el mapa de sitios

Este mensaje tiene la siguiente causa y solución:

  • Ha especificado una ruta de archivo para el archivo del mapa del Sitio que no está permitida. La especificación del archivo de mapa del Sitio no admite una ruta.

    Escriba sólo el nombre del archivo, como por ejemplo Sitemap.htm.


<archivo> es un archivo de almacenamiento local de SourceSafe y no se puede agregar

Este mensaje tiene la siguiente causa y solución:

  • Ha intentado agregar en VSS un archivo existente de VSS.

    Detener la operación.


Error al crear <archivo> mientras se intentaba bloquear la base de datos. La base de datos no está bloqueada.

Este mensaje tiene la siguiente causa y solución:

  • Es necesario crear un archivo en el siguiente directorio, sin embargo, el proceso de creación ha fallado: <directorio de instalación de vss>\data\loggedin

    Es posible que se haya quedado sin espacio en disco, o que no tenga derecho de escritura en esa carpeta.

    Asegúrese de que tiene acceso de escritura a la carpeta de VSS.


Error al eliminar <archivo> mientras se intentaba desbloquear la base de datos. La base de datos no está desbloqueada

Este mensaje tiene la siguiente causa y solución:

  • Es necesario eliminar un archivo en el siguiente directorio, sin embargo, el proceso de eliminación ha fallado: <directorio de instalación de vss>\data\loggedin

    No tiene permisos de eliminación en la carpeta.

    Asegúrese de que tiene permisos de eliminación en la carpeta VSS.


No se encontró la carpeta <ruta de acceso>. ¿Desea crearla?

La carpeta de trabajo especificada no existe. Este mensaje tiene la siguiente causa y solución:

  • Puede que se haya eliminado la carpeta o que haya escrito su especificación incorrectamente. Puede que se haya interrumpido la conexión con una ubicación de red.

    Restablezca la carpeta de trabajo de este proyecto (con el comando Establecer carpeta de trabajo del menú Archivo) o haga clic en Sí para crear la carpeta. Así indicará a VSS que esta es la carpeta de trabajo local. Cuando vuelva a abrir el proyecto, VSS irá automáticamente a esta carpeta de trabajo.

    Si la carpeta de trabajo parece estar bien, compruebe si este proyecto está centralizado en otra ubicación y que la conexión con dicha ubicación sigue siendo correcta.


¿Se han resuelto correctamente los conflictos en <archivo>?

Este mensaje tiene la siguiente causa y solución:

  • Ha intentado proteger un archivo de la versión almacenada actualmente en VSS.

    Este mensaje de advertencia aparece a menudo cuando varios usuarios han desprotegido el mismo archivo para más de un usuario o equipo. Se muestra para que sepa que hay conflictos de combinación que se deben resolver. En algunos casos, esta advertencia puede aparecer incluso si no se producen conflictos en la combinación. Si esto sucede, haga clic en Sí y siga trabajando.

    Si hubiera conflictos y no abrió el archivo original para solucionarlos, haga clic en No. Cuando haya terminado, vuelva a intentar la operación Proteger.


No se puede desproteger una versión antigua de un archivo

Vea también

El comando Desproteger siempre utiliza la versión más reciente de un archivo. Este mensaje tiene la siguiente causa y solución:

  • Está intentando desproteger una versión antigua de un archivo.

Para utilizar y modificar una versión anterior

  1. Desproteja la versión más reciente del archivo.

  2. Elimínelo de la carpeta de trabajo (no de la base de datos VSS).

  3. Obtenga la versión antigua que desea modificar.

  4. Realice los cambios en la versión antigua. (Puede que necesite quitar manualmente el indicador de sólo lectura.)

  5. Proteja el archivo modificado en VSS.

Nota También puede utilizar el botón Deshacer del cuadro de diálogo Historial del archivo (en el menú Herramientas, haga clic en Mostrar historial). Si vuelve a una determinada versión, todas las versiones posteriores a ella son eliminadas. Entonces podrá desproteger el archivo y comenzar a modificarlo. La desventaja de este método, sin embargo, es que perderá todas las versiones posteriores y no podrá recuperarlas.


El archivo <archivo> se ha desprotegido en la carpeta <ruta de acceso>

Cuando desprotege un archivo, VSS hace un seguimiento de la carpeta de trabajo en la que lo desprotegió. En general, las modificaciones se hacen en esa carpeta y luego se protege el archivo o se deshace la desprotección desde la misma carpeta cuando se ha terminado. Esta advertencia tiene la siguiente causa y solución:

  • Está intentando proteger o deshacer la desprotección del archivo en una carpeta que no es la misma en la que lo desprotegió.

    La carpeta de trabajo de un proyecto aparece justo encima del panel de archivos en el Explorador de VSS, y puede modificarse con el comando Establecer carpeta de trabajo del menú Archivo (Ctrl-D). La carpeta de desprotección de un archivo se muestra en la lista de archivos. (La carpeta de desprotección puede ser diferente de la carpeta de trabajo asignada al proyecto, por ejemplo si otro usuario tiene desprotegido el archivo.) Aunque puede proteger un archivo desde otra carpeta que la carpeta en la que lo desprotegió, asegúrese de que eso es lo que desea.


El archivo <archivo> está desprotegido en el proyecto <proyecto> y usted está en <proyecto>

Cuando un archivo se comparte entre varios proyectos, un archivo de un proyecto está vinculado a todos los demás proyectos que lo comparten. Por tanto, cuando desprotege el archivo de un proyecto, también se desprotege de todos los proyectos que lo comparten. Esta advertencia tiene la siguiente causa y solución:

  • Desprotegió un archivo de un proyecto y está intentando proteger o deshacer la desprotección del archivo en otro proyecto que comparte el mismo archivo.

    Es una acción válida. VSS sólo le avisa por si no pretendía realizar esta acción. Para continuar, haga clic en Sí; para cancelar la operación, haga clic en No.

Nota Puede proteger un archivo o deshacer la desprotección en cualquier proyecto que comparta un archivo.


El archivo <archivo> está desprotegido actualmente por <usuario>

Vea también

Esta advertencia tiene la siguiente causa y soluciones:

  • Cuando otro usuario tiene un archivo desprotegido, hay algunas cosas que usted no puede hacer con el archivo. Por ejemplo, no puede eliminar o cambiar el nombre de un archivo desprotegido.

    Haga clic en Sí para desproteger el archivo de todas formas. (Sí a todo desprotege todos los archivos seleccionados aunque ya estén desprotegidos por otro usuario.) Si elije Sí, puede haber conflictos entre sus cambios y los realizados por otro usuario, y después habrá que resolverlos y combinarlos.

    Haga clic en No para cancelar el comando Desproteger. (No a todo cancela el comando para todos los archivos seleccionados.)

Si desea trabajar con un archivo desprotegido, lo mejor es comprobar en la columna Usuario del explorador de VSS el nombre del usuario que ha desprotegido el archivo y pedirle que lo protega lo antes posible. Si no puede contactar con el usuario, el Administrador VSS puede desprotegerlo por usted.


Ha ocurrido una combinación automática y hay conflictos. Modifique <archivo> para resolverlos

Vea también

Los cambios que realizó en el archivo desde que lo desprotegió entran en conflicto con los cambios realizados (y protegidos) en el archivo de origen por otro usuario. Este mensaje tiene la siguiente causa y solución:

  • Debe resolver los conflictos entre sus cambios y los realizados por otro usuario antes de poder proteger el archivo.

    Abra el archivo en su carpeta de trabajo y busque seis signos igual consecutivos (======). VSS los utiliza para señalar la ubicación de un conflicto.

Es posible que prefiera utilizar la característica Combinación Visual para facilitar la resolución del conflicto. Para evitar esta situación, su administrador VSS puede desactivar desprotecciones múltiples en su proyecto.


Ya existe un vínculo eliminado a <archivo>

Vea también

Un archivo eliminado permanece como parte de un proyecto, pero no aparece en la lista de archivos. Este mensaje tiene la siguiente causa y solución:

  • Está intentando compartir un archivo desde otro proyecto con el proyecto actual. Sin embargo, el archivo ya existe en el proyecto actual. No aparece en la lista de archivos porque se ha eliminado.

    Para que el archivo aparezca en la lista de archivos, no lo comparta desde otro proyecto; mejor recupérelo en este proyecto mediante el botón Recuperar de la ficha Elementos eliminados del cuadro de diálogo Propiedades del menú Archivo.


Ya se ha eliminado de este proyecto un elemento llamado <elemento>

Vea también

En VSS sólo puede eliminar una instancia de un archivo o un proyecto con un determinado nombre en un proyecto dado. Este mensaje tiene la siguiente causa y solución:

  • Eliminó un archivo y creó uno con el mismo nombre, para después intentar eliminar de nuevo el archivo.

    Puede hacer clic en Sí para purgar el archivo anterior o en No para cancelar la operación de eliminación. Si purga el archivo original, perderá toda la información histórica, pero podrá continuar con la operación de eliminación. Si quiere guardar el historial del archivo antiguo, puede hacer clic en No y asignar un nombre diferente al nuevo archivo antes de eliminarlo.


Esta versión de <nombre> ya tiene una etiqueta. ¿Desea sobrescribirla?

Cualquier versión de un archivo o proyecto de VSS puede tener una etiqueta, que se utiliza para identificar ese número de versión. Este mensaje tiene la siguiente causa y solución:

  • Una versión de un archivo o un proyecto no puede tener más de una etiqueta. Por tanto, cuando intente etiquetar una versión que ya tiene una etiqueta, VSS mostrará este mensaje.

    Haga clic en Sí para aplicar la nueva etiqueta y reemplazar la antigua. Haga clic en No para cancelar la acción y dejar la antigua etiqueta en su lugar.


Esta etiqueta <etiqueta> ya está en uso. ¿Desea quitar la etiqueta antigua?

Una etiqueta de VSS se utiliza para identificar un determinado número de versión de un archivo o un proyecto. Este mensaje tiene la siguiente causa y solución:

  • Está intentando asignar una etiqueta a un archivo o un proyecto, pero hay otra versión de este archivo o proyecto que tiene la misma etiqueta.

    Haga clic en Sí para aplicar la nueva etiqueta y eliminar la antigua. Haga clic en No para dejar la antigua etiqueta sin cambiar. Haga clic en Cancelar para cancelar la operación de etiquetado.


Ya existe una copia modificable de <archivo>

Al obtener un archivo VSS, el archivo es marcado como sólo lectura. No puede modificar el archivo. Cuando desprotege el archivo para modificarlo, se elimina el indicador de sólo lectura. Al protegerlo, el archivo se vuelve a marcar como de sólo lectura. Este mensaje tiene la siguiente causa y solución:

  • Intentó utilizar el comando Obtener la última versión sobre un archivo que ya existía en el disco duro en formato lectura/escritura. Si la copia local es de lectura/escritura, probablemente estará desprotegida, VSS no sustituye el archivo y muestra este mensaje de error.

    Haga clic en Sí o en Sí a todos para sustituir el archivo o archivos por la versión actual de la base de datos VSS.

    Haga clic en No o en No a todos para no reemplazar el(los) archivo(s).

    Haga clic en Cancelar para cancelar el comando Obtener la última versión.


El proyecto <proyecto> no existe

Este mensaje tiene la siguiente causa y solución:

  • Está intentando mover un proyecto a un proyecto primario que no existe.

    Compruebe la ruta del proyecto primario y vuélvalo a intentar. Si no sabe con seguridad la sintaxis de proyecto de VSS, pruebe a seleccionar el proyecto primario de la lista de proyectos en el Explorador de VSS y anote la ruta del proyecto mostrada en la parte superior de la lista de archivos.

Nota Para mover un archivo o un subproyecto a un primario nuevo, debe haber creado el nuevo proyecto primario. Utilice el comando Crear proyecto para crear un proyecto nuevo.


No se pueden deshacer los cambios hasta la versión más reciente de <archivo>

Vea también

El comando Deshacer devuelve un archivo a su versión anterior. Este mensaje tiene la siguiente causa y solución:

  • Intentó deshacer los cambios a un archivo hasta su versión más reciente o no especificó la versión a la que desea volver.

    No se puede deshacer los cambios a un archivo hasta su versión más reciente en VSS. Si quiso especificar una versión anterior, vuelva a intentar ejecutar el comando con la versión anterior especificada.


No tiene permiso de destrucción para <elemento>

Este mensaje tiene la siguiente causa y solución:

  • Ha intentado destruir algo sin los permisos apropiados (derechos de destruir).

    Pida a su administrador de VSS que configure sus derechos de destruir, o abandone el intento de destrucción.


El archivo <archivo> no está compartido con ningún otro proyecto

El comando Bifurcar se utilizar para romper un vínculo compartido. Este mensaje tiene la siguiente causa y solución:

  • El archivo que ha elegido para aplicar el comando Bifurcar no tiene vínculo con otros proyectos.

    Seleccione otro comando o seleccione un archivo compartido para aplicar en él el comando Bifurcar.


Ruta <ruta de acceso> demasiado larga

Vea también

La ruta especificada es demasiado larga. Este error tiene la siguiente causa y solución:

  • Escribió una ruta de VSS demasiado larga.

    Los nombres de proyecto de VSS tienen un límite de 64 caracteres. Los nombres completos de ruta de proyecto no pueden tener más de 255 caracteres.


Cambiar nombre no mueve un elemento a otro proyecto

Vea también

No se pueden implementar al mismo tiempo los comandos Cambiar nombre y Mover proyecto. Este mensaje tiene la siguiente causa y solución:

  • Los comandos Cambiar nombre y Mover de VSS son operaciones distintas, por lo que no puede realizar ambas a la vez.

    Realice primero una acción y luego la otra.


No se puede eliminar, cambiar de nombre o mover el proyecto raíz

Este mensaje tiene la siguiente causa y solución:

  • No se puede aplicar los comandos Eliminar, Cambiar nombre y Mover proyecto al proyecto raíz ($/),que es análogo a la carpeta raíz del disco duro (C:\).

    Como no hay ninguna forma de modificar el proyecto raíz, considere la posibilidad de reestructurar su proyecto.


Su carpeta de trabajo contiene una copia modificable de <archivo>

Este mensaje tiene la siguiente causa y solución:

  • Tiene un archivo modificable en su disco no desprotegido por usted, y no ha realizado un comando Get.

    Seleccione una de las opciones que se presentan. Abandone el archivo, reemplácelo, desprotéjalo manteniendo los cambios o cancel la obtención.


Su carpeta de trabajo contiene una copia modificable de una versión antigua de <archivo>

Este mensaje tiene la siguiente causa y solución:

  • Tiene un archivo modificable en su disco no desprotegido por usted, y no ha realizado un comando Get.

    Seleccione una de las opciones que se presentan. Abandone el archivo, reemplácelo, desproteja la versión antigua al mantener los cambios, desproteja la versión antigua al combinar los cambios o cancele la obtención.


Ya existe un vínculo del archivo <archivo> en el proyecto de destino

¿Desea recuperar el archivo enlazado?


El archivo <archivo> ya está compartido con este proyecto

Vea también

Este mensaje tiene la siguiente causa y solución:

  • Está intentando compartir un archivo con el proyecto actual, pero ese archivo ya existe en el proyecto actual.

    Si desea compartir una versión diferente del archivo, especifique una versión en el cuadro de diálogo Historial del archivo y haga clic en Fijar. Si desea compartir este archivo con otro proyecto, seleccione ese proyecto en el explorador de VSS y haga clic en Compartir en el menú SourceSafe. Después, seleccione el archivo que desea compartir en el cuadro de diálogo Compartir.


El archivo <archivo> ya está desprotegido por otro usuario. ¿Desea continuar?

Esta advertencia tiene la siguiente causa y solución:

  • El archivo que ha seleccionado para desproteger ya está desprotegido por otro usuario.

    Cancele la desprotección o siga adelante.


Ya ha desprotegido el archivo <archivo> en otra ubicación. ¿Desea continuar?

Esta advertencia tiene la siguiente causa y solución:

  • El archivo que ha seleccionado para desproteger ya está desprotegido por usted en una ubicación diferente.

    Cancele la desprotección, o desproteja el archivo en una nueva ubicación.


El archivo <archivo> ya está desprotegido por <usuario>. ¿Desea continuar?

Vea también

Esta advertencia tiene la siguiente causa y solución:

  • Ha intentado realizar una operación en un archivo VSS que está desprotegido pro otro usuario.

    VSS le ofrece la posibilidad de continuar, lo que implica que cualquier diferencia entre los cambios que realice y los cambios que realicen otros usuarios necesitarán combinarse en el futuro. Haga clic en Sí para seguir adelante y crear una situación de desprotecciones múltiples, haga clic en No para cancelar la acción de desprotección.


La ruta <ruta de acceso> de SourceSafe no es válida

Vea también

Este mensaje tiene la siguiente causa y solución:

  • Especificó un nombre de archivo o de proyecto de VSS no válido.

    Asegúrese de que escribió la ruta correctamente o utilice el Explorador de VSS para elegir el elemento en la lista de proyectos o en la lista de archivos.

    Si eligió el elemento en el Explorador de VSS, es posible que otro usuario haya eliminado o cambiado el nombre del elemento desde que utilizó por última vez VSS. Contraiga el proyecto raíz y vuélvalo a expandir para actualizar el panel de proyectos.


<archivo> no es un archivo de texto

Aunque la mayoría de los comandos VSS funcionan con archivos de texto o binarios, este comando no lo hace. Este mensaje tiene la siguiente causa y solución:

  • Ha intentado ejecutar un comando que sólo funciona con archivos de texto, como Ver archivo del menú Editar o Buscar en archivos en el menú Herramientas.

    Los archivos binarios son configurados automáticamente por VSS utilizando la ficha Tipos de archivos del cuadro de diálogo Opciones de SourceSafe del menú Herramientas.


Se ha eliminado <elemento>

Vea también

Este mensaje tiene la siguiente causa y solución:

  • Está intentando actuar sobre un archivo o un proyecto que no se ha eliminado del proyecto actual.

    Antes de poder hacer algo con el archivo debe recuperarlo mediante el comando Recuperar.

    Si desea eliminar el archivo de forma permanente de la base de datos de VSS, en el menú Archivo haga clic en Propiedades y, en la ficha Elementos eliminados, haga clic en Purgar.


Este comando sólo funciona en proyectos, no en archivos (como <archivo>)

Este comando sólo funciona sobre proyectos. Este mensaje tiene la siguiente causa y solución:

  • Intentó ejecutar el comando sobre un archivo.

    En el Explorador de VSS, seleccione un proyecto en la lista de proyectos y vuelva a intentar ejecutar el comando.


Este comando sólo funciona en archivos, no en proyectos (como <proyecto>)

Este comando sólo funciona sobre archivos. Este mensaje tiene la siguiente causa y solución:

  • Intentó ejecutar el programa sobre un proyecto.

    En el Explorador de VSS, seleccione un archivo en la lista de archivos y vuelva a intentar ejecutar el comando.


<elemento> no es un archivo o proyecto eliminado

Vea también

Los comandos Recuperar y Purgar sólo funcionan con elementos eliminados. Este mensaje tiene la siguiente causa y solución:

  • Intentó utilizar los comandos Recuperar o Purgar sobre un elemento que no se ha eliminado.

    Si está intentando recuperar un archivo o proyecto, el archivo o proyecto ya existe en VSS. Para ver el archivo, utilice el comando Ver archivo.


Este comando actúa sobre un único elemento

En muchas listas de los cuadros de diálogo de VSS, puede seleccionar más de un elemento a la vez, y después actuar sobre todos los elementos de una sola vez. Sin embargo, algunas acciones no pueden actuar sobre más de un elemento a la vez. Este mensaje tiene la siguiente causa y solución:

  • Seleccionó más de un elemento y aplicó un comando que sólo actúa sobre un elemento a la vez. Por ejemplo, puede que intentara utilizar el comando Ver, que sólo funciona con un archivo a la vez.

    Presione la barra espaciadora sobre un elemento para convertirlo en el único elemento seleccionado de la lista.


<elemento> especifica un número de versión, lo cual no es válido para este comando

Este comando sólo funciona sobre la versión más reciente de un archivo. Este mensaje tiene la siguiente causa y solución:

  • Intentó ejecutar el comando sobre una versión más antigua del archivo.

    Seleccione otro comando o aplique el comando elegido a la versión más reciente del archivo.


La sintaxis de SourceSafe no es válida: <sintaxis>

Vea también

La sintaxis utilizada no es válida en VSS. Este mensaje tiene la siguiente causa y solución:

  • Especificó una ruta de archivo o de proyecto de VSS con una sintaxis no válida.

    En la sintaxis de VSS, todos las rutas empiezan con un signo de dólar seguido de una serie de nombres de proyecto, separados por barras y, opcionalmente, seguidos por un nombre de archivo. Por ejemplo:

    • $/ es el proyecto raíz.

    • $/Code es un subproyecto de $/.

    • $/Code/Win/Test.C es un archivo del proyecto $/Code/Win.

    Muchas partes de la sintaxis son opcionales. Puede omitir el signo de dólar en la mayoría de las circunstancias. También puede abreviar la ruta basándola en el proyecto actual; por ejemplo, si está en $/Code, puede escribir WIN como abreviatura de $/Code/Win, Test.C para $/Code/Test.C y ".." para el raíz.

  • Los nombres de archivo pueden ser nombres de archivo válidos en cualquier sistema operativo, excepto para la siguiente restricción que es específica de VSS. Los nombres de archivo en VSS no deben comenzar con un signo dólar ($), un punto y coma (;), o un punto (.), independientemente de si el sistema operativo permite uno o más de estos caracteres.

  • Los nombres de proyecto pueden incluir espacios y pueden tener hasta 256 caracteres de largo. Los nombres de proyecto no distinguen mayúsculas de minúsculas (por ejemplo, para VSS, Code y CODE son el mismo proyecto).


La sintaxis del nombre de usuario no es correcta: <sintaxis>

Este mensaje tiene la siguiente causa y solución:

  • Ha introducido un nombre de usuario con una sintaxis de usuario de VSS no válida.

    Pregúntele a su administrador VSS cuál es su nombre de usuario VSS correcto.


La contraseña no es válida

Este mensaje tiene la siguiente causa y solución:

  • Su combinación nombre de usuario/contraseña no es válida.

    Vuelva a escribir la contraseña. Vuelva a especificar la contraseña. Como no aparece en la pantalla, es muy fácil escribirla de forma incorrecta. Observe que la contraseña de VSS distingue entre mayúsculas y minúsculas. Si cree que ha escrito la contraseña correctamente y VSS no la reconoce, pida a su administrador de VSS que cambie su nombre de usuario y su contraseña. Si ha olvidado la contraseña, el administrador de VSS puede utilizar el programa Administrador para asignarle una nueva.


No se puede eliminar/cambiar de nombre/modificar el usuario Admin

Este mensaje tiene la siguiente causa y solución:

  • Intentó cambiar eliminar, cambiar el nombre o cambiar el usuario Admin. El administrador VSS siempre debe existir en la lista de usuarios del Administrador de VSS, aunque no debe utilizar Admin como un usuario real.

    Sin embargo, puede cambiar la contraseña del usuario Admin utilizada para iniciar la sesión en el Administrador de VSS.


Permiso denegado

Este mensaje tiene la siguiente causa y solución:

  • Está intentando llevar a cabo una acción y no tiene los privilegios adecuados para ejecutarla.

    Hable con su administrador de VSS. Si usted es el Administrador de VSS, ejecute el Administrador de VSS para comprobar o cambiar su nombre de usuario, su contraseña y sus derechos de acceso.


El usuario <usuario> ya existe

Este mensaje tiene la siguiente causa y solución:

  • Intentó agregar un usuario con un nombre de usuario que ya existe. Puede seleccionar otro nombre; por ejemplo, si ya existe Juan, agregue JuanG.

    Observe que los nombres no distinguen entre mayúsculas y minúsculas, por lo que si ya existe Juan, agregar JUAN genera este error.


No se ha encontrado el usuario <usuario>

Este mensaje tiene la siguiente causa y solución:

  • No se encontró su nombre de usuario.

    Indíquelo a su administrador de VSS. Si es usted el administrador de VSS, ejecute Administrador de VSS para agregar su nombre de usuario.


El archivo <archivo> no ha cambiado

Este mensaje tiene la siguiente causa y solución:

  • Está intentando proteger un archivo desprotegido que no ha cambiado.

    Haga clic en Sí, y VSS protegerá el archivo. (Si hace clic en Sí a todo protegerá todos los archivos seleccionados.) Una protección crea una nueva versión del archivo, con un comentario opcional.

    Haga clic en No, y VSS deshará la desprotección del archivo. (Haga clic en No, y VSS deshará la desprotección del archivo.) En este caso no se creará una versión nueva del archivo.

Nota Para omitir este mensaje en próximas ocasiones, deshabilite esta notificación en la ficha General a la que se accede seleccionando Opciones en el menú Herramientas.


La dirección URL base de este proyecto Web, <proyecto>, tiene una sintaxis de URL errónea

Este mensaje tiene la siguiente causa y solución:

  • La dirección URL que ha especificado para la dirección URL base de un proyecto Web de VSS tiene una sintaxis errónea.

    La sintaxis válida para la dirección URL se muestra en estos ejemplos:

    http://www.microsoft.com/spanish/default.htm
http://www.microsoft.com/spanish

    Puede cambiar la dirección URL en la ficha Proyectos Web a la está teniendo acceso seleccionando Opciones desde el menú Herramientas, o bien puede modificar la dirección URL en el archivo SRCSAFE.INI.


La dirección URL para el proyecto <proyecto> no se ha establecido apropiadamente

Este mensaje tiene la siguiente causa y solución:

  • Estableció una dirección URL incorrecta para un proyecto Web o la dirección URL usa una sintaxis que VSS no entiende (por ejemplo, puede que use www.microsoft.com/spanish/... en lugar de http://www.microsoft.com/spanish/...)

    Use el programa Administrador para establecer una dirección URL correcta.


Se ignoró un hipervínculo en <archivo> porque era demasiado largo

Este mensaje tiene la siguiente causa y solución:

  • La dirección URL es muy larga para el búfer interno.

    Utilice una dirección URL más corta.


Error al comprobar los hipervínculos de <archivo>

Este mensaje tiene la siguiente causa y solución:

  • La ruta del directorio de trabajo, la especificación de VSS o la URL son muy grandes.

    Compruebe que no está sobrepasando los límites de ruta de la carpeta, de la especificación o de la dirección URL. Compruebe que Htmlfilt.dll está todavía presente en su sistema y se ha registrado correctamente (vuelva a ejecutar la instalación del cliente para solucionar este problema).


No hay archivos HTML disponibles en este proyecto para comprobar los hipervínculos

Este mensaje tiene la siguiente causa y solución:

  • Este mensaje informativo indica que no hay archivos desprotegidos para hipervínculos Web porque no se encontraron archivos HTML.

    Si esperaba archivos HTML en este proyecto, compruebe que se han agregado correctamente y que ha escrito correctamente el nombre del proyecto.


No se puede cargar el analizador de HTML

Este mensaje tiene la siguiente causa y solución:

  • Tiene una instalación de VSS corrupta. El archivo DLL ha desaparecido o en el registro no se ha especificado el archivo DLL correcto.

    Vuelva a instalar VSS de nuevo.


No se ha encontrado ninguna base de datos de SourceSafe (SRCSAFE.INI). Utilice la variable de entorno SSDIR o ejecute NETSETUP

Vea también

Este mensaje tiene la siguiente causa y solución:

  • No se ha encontrado el archivo SRCSAFE.INI. Esto puede ser el resultado de una instalación del cliente, en lugar de realizarla mediante NETSETUP.

    Haga la instalación mediante NETSETUP o establezca la variable de entorno SSDIR.

Configurando la variable de entorno SSDIR se indica a VSS dónde ha de buscar el archivo SRCSAFE.INI para la instalación de servidor de VSS a la que se desea conectar. Hágalo escribiendo lo siguiente en la línea de comandos de MS-DOS:

set ssdir=\\server\share\vss

Donde \\server\share\vss es la carpeta donde se encuentra el archivo srcsafe.ini.

Nota No ponga espacios entre el signo igual y la ubicación de la instalación de servidor de VSS. La cadena siguiente no funciona: set ssdir= \\server\share\vss.


Advertencia: el comando Deshacer bifurcará este archivo, rompiendo los vínculos con otros proyectos que lo compartan

Esta advertencia tiene la siguiente causa y solución:

  • Esta advertencia puede producirse cuando deshaga un archivo que se ha bifurcado o que está fijado a otro proyecto.

    Haga clic en Sí para continuar o en No para cancelar.


Su versión gratuita de prueba de VSS caducó hace más de 30 días

Se ha deshabilitado parte de la funcionalidad de VSS.

Para cumplir con su contrato de licencia y restaurar la funcionalidad completa de VSS, es necesario solicitar una licencia.

Para realizar un pedido de Microsoft VSS o recibir una relación de distribuidores, llame al 1-800-621-7930. Fuera de los Estados Unidos o Canadá, póngase en contacto con su distribuidor local de Microsoft.

Se elige que no desea solicitar una versión con licencia de VSS, debe desinstalar completamente VSS puesto que está produciendo una violación de su acuerdo de licencia.


Su versión gratuita de prueba de VSS ha caducado

Para continuar usando Microsoft VSS, debe solicitar una copia con licencia. Para realizar un pedido de VSS o recibir una relación de distribuidores, llame al 1-800-621-7930. Fuera de los Estados Unidos o Canadá, póngase en contacto con su distribuidor local de Microsoft.

Se elige que no desea solicitar una versión con licencia de VSS, debe desinstalar completamente VSS puesto que está produciendo una violación de su acuerdo de licencia.


Le quedan <número> días para probar la versión gratuita de VSS de prueba

Para realizar un pedido de Microsoft VSS u obtener una relación de distribuidores, llame al 1-800-621-7930. Fuera de los Estados Unidos o Canadá, póngase en contacto con su distribuidor local de Microsoft.


Ya existe un elemento con el nombre <nombre>

Vea también

Cada elemento de un proyecto de VSS debe tener un nombre único. Este mensaje tiene la siguiente causa y solución:

  • Intentó asignar nombre a un archivo o a un subproyecto inmediato con el mismo nombre que el proyecto. (Puede existir un elemento con este nombre en otros proyectos de la base de datos, incluidos subproyectos.)

    Para resolver este error, asigne un nombre diferente y único al nuevo elemento. O bien, puede eliminar o cambiar el nombre del elemento existente.

Nota En VSS, los nombres de los proyectos y de los archivos no distinguen entre mayúsculas y minúsculas. Por ejemplo, si tiene un archivo llamado Test.C, no podrá crear un subproyecto o un archivo llamado "Test.c" o "test.c" dentro del mismo proyecto.


No se puede mover un proyecto bajo él mismo

Vea también

Un proyecto no puede ser un proyecto de él mismo. Este mensaje tiene la siguiente causa y solución:

  • Ha intentado crear en la jerarquía de su proyecto un bucle no válido, por ejemplo, moviendo el proyecto $/Word bajo el proyecto $/Word, o moviendo $/Word under $/Word/Apps. Esto crea un bucle recursivo sin fin, lo que produce este error.

    Reestructure la jerarquía del proyecto para que no se produzca un bucle no válido.


El archivo <archivo> no mantiene las versiones anteriores de sí mismo

Vea también

Este mensaje tiene la siguiente causa y solución:

  • Cuando protege un archivo, VSS conserva la versión actual del archivo y la información necesaria para reconstruir versiones anteriores. Ha desactivado el almacenamiento de versiones históricas para este archivo.

    Si de forma explícita desactivó esta información de modificaciones en el cuadro de diálogo Propiedades o, cuando utilizaba el comando Agregar archivos, VSS le puede dar la versión más reciente, pero no puede reconstruir versiones anteriores.


No se puede compartir una versión antigua del archivo <archivo> porque sólo está almacenada la versión más reciente

Este mensaje tiene la siguiente causa y solución:

  • Ha intentado compartir una versión antigua de un archivo. VSS sólo guarda la última versión de un archivo.

    Sólo puede compartir la versión más reciente de un archivo.


El archivo no ha sido desprotegido por usted

Vea también

Algunas operaciones de VSS sólo se pueden realizar sobre archivos que estén desprotegidos. Este error tiene las causas y soluciones siguientes:

  • Intentó proteger o deshacer la desprotección de un archivo que no está desprotegido.

    Desproteja el archivo antes de protegerlo. Si ha realizado cambios en un archivo, vea las opciones Avanzadas del cuadro de diálogo Desproteger y luego, en Reemplazar modificable, seleccione Saltar para desproteger el archivo sin sustituir los cambios en su carpeta de trabajo.

  • Intentó realizar una operación que sólo se puede efectuar sobre un archivo desprotegido.

    Desproteja el archivo.


No se ha encontrado el archivo o el proyecto

Vea también

VSS está buscando un archivo o proyecto que no existe. Este mensaje tiene las siguientes causas y solución:

  • Se equivocó al escribir el nombre del archivo o el proyecto, o el archivo o el proyecto especificado no existe.

  • La base de datos VSS está dañada.

    Pruebe a escribir de nuevo el nombre o seleccione el nombre en la lista del explorador de VSS. Si sospecha que la base de datos está dañada, ejecute la utilidad Analyze.exe.


No se ha encontrado el primario

Este mensaje tiene la siguiente causa y solución:

  • Avisa que la base de datos está dañada.

    Pida a su administrador de VSS que ejecute Analyze.exe para encontrar y corregir el problema. Si esto no funciona, llame al Soporte técnico de Microsoft y pida ayuda para recuperar la base de datos.


Se ha destruido el archivo <archivo> y no puede volver a generarse

Vea también

Es posible que VSS no pueda reproducir el archivo que ha solicitado. Este mensaje tiene la siguiente causa y solución:

  • Destruyó de forma permanente un archivo o lo cambió de lugar. Por ejemplo, debía haber un archivo en un proyecto que ha eliminado o purgado. Después intentó volver a una versión anterior del proyecto. VSS intenta reconstruir el proyecto exactamente como era anteriormente, pero no puede porque no puede recuperar el archivo.

    Haga clic en Sí, y VSS intentará recuperar el archivo antiguo, aunque la recuperación no está garantizada.

    Haga clic en No y se detendrá el intento de restaurar el archivo antiguo.

    Haga clic en Sí a todo y VSS no le avisará de la posible existencia de otros archivos irrecuperables; continuará llevando a cabo la reconstrucción de la mejor forma posible.


Se ha destruido el proyecto <proyecto> y no puede volver a generarse

Vea también

Es posible que VSS no pueda reproducir la versión de proyecto que ha solicitado. Este mensaje tiene la siguiente causa y solución:

  • Destruyó de forma permanente un subproyecto o cambió de lugar el subproyecto. Por ejemplo, debía haber un subproyecto que ha eliminado o purgado. Después intentó volver a una versión anterior del proyecto. VSS intenta reconstruir el proyecto exactamente como era anteriormente, pero no puede porque no puede recuperar el subproyecto.

    Haga clic en Sí, y VSS intentará recuperar el proyecto antiguo, aunque la recuperación no está garantizada.

    Haga clic en No y se detendrá el intento de restaurar la versión anterior del proyecto.

    Haga clic en Sí a todo y VSS no le avisará de la posible existencia de otros subproyectos irrecuperables; continuará llevando a cabo la reconstrucción de la mejor forma posible.


No se ha encontrado esta versión

Vea también

No se puede encontrar la versión especificada. Este error tiene las causas y soluciones siguientes:

  • Especificó una versión que no existe.

    En VSS, haga clic en el comando Mostrar historial del menú Herramientas y seleccione una versión de las mostradas en el cuadro de diálogo Historial del archivo.

  • Si está utilizando VSS desde la línea de comandos, puede que no esté utilizando correctamente el parámetro -V.

    Busque en la Ayuda en pantalla más información acerca de la correcta utilización del parámetro (haga clic en el botón Contenido).


Este comando sólo funciona sobre archivos

Este comando sólo puede operar sobre archivos. Este mensaje tiene la siguiente causa y solución:

  • Está intentando realizar una operación (como utilizar el comando Ver) sobre un proyecto.

    Seleccione el comando adecuado o seleccione un archivo que funcione con el comando elegido.


Este comando sólo funciona sobre proyectos

Este comando sólo puede operar sobre proyectos. Este mensaje tiene la siguiente causa y solución:

  • Está intentando realizar una operación de proyecto (como el comando Mover proyecto) sobre un archivo.

    Seleccione el comando adecuado o seleccione un proyecto que funcione con el comando que ha elegido.


No se puede deshacer la destrucción. Perderá la información definitivamente.

Vea también

Esta advertencia tiene la siguiente causa y solución:

  • Cuando utiliza el comando Destruir en un archivo o en un proyecto, la acción es irreversible.

    Haga clic en Sí para continuar con la operación de destrucción. Haga clic en No para cancelar la operación.

Nota Su no quiere recibir este mensaje cada vez que destruya un archivo o proyecto, puede deshabilitarlo en la ficha Advertencias del cuadro de diálogo Opciones de SourceSafe del menú Herramientas.


No se puede deshacer el purgado; perderá la información definitivamente

Vea también

Esta advertencia tiene la siguiente causa y solución:

  • Cuando purga un archivo o un proyecto, la acción es irreversible.

    Haga clic en Sí para continuar con la operación de purgado. Haga clic en No para cancelar la operación.

    Si no desea perder permanentemente el archivo o el proyecto, utilice en su lugar el comando Eliminar.

Nota Su no quiere recibir este mensaje cada vez que elimine un archivo o proyecto, puede deshabilitarlo en la ficha Advertencias del cuadro de diálogo Opciones de SourceSafe del menú Herramientas.


¿Desea eliminar todos los elementos especificados?

Vea también

Esta advertencia tiene la siguiente causa y solución:

  • Está a punto de eliminar un archivo o un proyecto.

    Haga clic en Sí, para que VSS elimine el archivo o proyecto.

    Haga clic en No, y VSS no lo hará.

    Utilice el comando Recuperar para deshacer Eliminar.

Nota Su no quiere recibir este mensaje cada vez que elimine un archivo o proyecto, puede deshabilitarlo en la ficha Advertencias del cuadro de diálogo Opciones de SourceSafe del menú Herramientas.


No se puede deshacer. Se perderán algunas versiones definitivamente

Vea también

Esta advertencia tiene la siguiente causa y solución:

  • Está a punto de deshacer los cambios de un archivo o proyecto a una versión anterior. El comando Deshacer es irreversible.

Para convertir la versión antigua a la más reciente sin perder todas las versiones intermedias

  1. Desproteja el archivo.

  2. Elimine la copia local.

  3. Obtenga la versión hasta la que desea deshacer.

  4. Proteja esa versión en VSS.

Nota Su no quiere recibir este mensaje cada vez que deshaga un archivo, puede deshabilitarlo en la ficha Advertencias del cuadro de diálogo Opciones de SourceSafe del menú Herramientas.


<archivo> ha cambiado. ¿Desea deshacer la desprotección y perder los cambios?

Vea también

Esta advertencia tiene la siguiente causa y solución:

  • Está a punto de deshacer la desprotección de un archivo. Si lo hace, descartará todos los cambios realizados desde que desprotegió el archivo.

    Si quiere guardar los cambios en VSS en lugar de perderlos, utilice el comando Proteger en su lugar.

Nota Su no quiere recibir este mensaje cada vez que desproteja un archivo o proyecto, puede deshabilitarlo en la ficha Advertencias del cuadro de diálogo Opciones de SourceSafe del menú Herramientas.


Se ha cambiado automáticamente el nombre de <nombre de archivo> a <nombre de archivo> en el proyecto <proyecto> para que coincida con el archivo actual de la base de datos

Este mensaje sólo es informativo. Ha sido generando por un comando de archivo.


Eliminadas las desprotecciones de <ruta de acceso> (<usuario>)

Este es un mensaje de información que indica que han sido eliminadas algunas desprotecciones. En cualquier momento puede volver a desproteger cualquier archivo.


Las versiones <número> a <número> están en <archivo>. No se realizará ninguna acción.

Este mensaje tiene la siguiente causa y solución:

  • Está intentando eliminar un rango de versiones que VSS no puede localizar (quizá ya se ha archivado).

    Determina el rango de versiones válido y después archívelo.


<archivo> ya existe en el proyecto <nombre de proyecto> y no es el mismo que el archivo almacenado. No se puede restaurar

Este mensaje tiene la siguiente causa y solución:

  • Está intentando recuperar un archivo en una base de datos diferente a la base de datos desde la cual lo archivó y ya existe un archivo con el mismo nombre.

    Mantenga el archivo existente, elimínelo o cambie su nombre y ejecute después SSRESTOR.


No se ha encontrado la información del nombre para el desplazamiento <número> en el archivo de almacenamiento. El nombre se truncará a <nombre>

Este mensaje tiene la siguiente causa y solución:

  • Por razones de mantenimiento, VSS recorta los nombres de archivo largos a nombres de archivo más cortos. La información de un nombre de archivo largo se ha perdido para este archivo o proyecto particular, por tanto VSS ahora hará referencia a él mediante su nombre corto.

    Para remediarlo, cambie el nombre del archivo o proyecto a su nombre largo original.


El archivo primario <proyecto> del archivo <archivo> (<archivo de base de datos de SourceSafe) no existe. Puede que el archivo esté dañado. Se pasará por alto este archivo primario

Este mensaje tiene la siguiente causa y solución:

  • Mientras la utilidad Analyze estaba procesando este archivo, un registro de uno de los proyectos estaba compartido, o estaba bifurcado desde los archivos, o no se ha encontrado.

    Este mensaje sólo es informativo. No es necesaria ninguna acción.


<archivo VSS> (<archivo de base de datos>) es una bifurcación primaria de un archivo que no se va a archivar. No se ha eliminado ninguna versión

Este mensaje tiene la siguiente causa y solución:

  • Este mensaje sólo tiene carácter informativo, y se genera al realizar una operación de Archivar. Archivar no elimina el archivo por el que se pregunta, puesto que contiene una porción del historial del archivo que se bifurca en cualquier parte y permanece activa.

    Si necesita eliminar el archivo, necesitará eliminar el registro de todas las bifurcaciones del archivo (mediante la ficha Rutas de acceso del cuadro de diálogo Propiedades), y después indicar también a Archivar que elimine todas las bifurcaciones del archivo.


No se han podido establecer todas las opciones correctamente

Este error tiene la solución siguiente:

  • En la mayoría de los casos, no se puede establecer correctamente las opciones debido a falta de memoria o de espacio en disco. Libere memoria o espacio en disco y vuélvalo a intentar.


Memoria insuficiente; no se puede terminar la operación

No tiene memoria suficiente en el equipo para realizar la operación deseada. Este error tiene las siguientes causas y soluciones:

  • Tiene abiertas demasiadas aplicaciones, documentos o archivos de origen.

    Cierre las aplicaciones, documentos o archivos de origen abiertos que no necesite.

  • Está ejecutando Microsoft Windows en modo estándar.

    Vuelva a iniciar Microsoft Windows en modo extendido.

  • Está ejecutando Microsoft Windows en modo extendido, pero se ha agotado la memoria virtual.

    Incremente la memoria virtual liberando espacio en disco o asegúrese de que tiene espacio disponible.

  • Hay programas residentes en ejecución.

    Elimine los programas residentes.

  • Tiene cargados muchos controladores de dispositivos.

    Elimine los controladores de dispositivos innecesarios.


Bloquear la base de datos de SourceSafe (Comando, menú Herramientas)

Vea también

Le permite impedir la conexión de todos los usuarios a la base de datos de VSS mientras ejecute un programa, actualice los ejecutables o haga copia de seguridad de la base de datos.

Derechos de acceso

Debe tener el permiso de Administrador para usar este comando.

Comentarios

Utilice este comando si necesita archivar, hacer una copia de seguridad o ejecutar un programa de VSS en la base de datos. Tenga en cuenta que el hecho de activar la casilla de verificación Bloquear la base de datos de SourceSafe hace que realmente queden bloqueados los usuarios. Después de activar esta casilla, nadie podrá conectarse a la base de datos. Los usuarios de la lista que ya están conectados no se verán afectados; necesitará comunicarles manualmente que deben desconectarse.


Opciones (Comando, menú Herramientas)

Vea también

Le permite personalizar el entorno de VSS para todos los usuarios.

Comentarios

Haga clic en la ficha que contiene la información que desea. Cada ficha contiene grupos de opciones que puede establecer para modificar el comportamiento de VSS en ciertas situaciones. Las fichas del cuadro de diálogo Opciones de SourceSafe cambian el comportamiento de VSS para todos los usuarios incluidos en la lista de usuarios del Administrador de VSS. (Los usuarios pueden pasar por alto alguna de las configuraciones mediante el comando Opciones del menú Herramientas del Explorador de VSS.)

Fichas del cuadro de diálogo

General

Establece las opciones generales aplicables a una serie de comandos de VSS.

Seguridad del proyecto

Establece las opciones de seguridad, como si la seguridad del proyecto está activada, y la asignación de derechos de acceso predeterminados del usuario.

Proyectos Web

Designa un proyecto como proyecto de sitio Web.

Web

Establece cómo se transmite cierta información de Internet para proyectos Web.

Tipos de archivo

Establece cómo se determina la información de tipo de archivo para todos los usuarios.


Salir (Comando, menú Archivo)

Sale de VSS.

Derechos de acceso

Cualquier usuario de VSS puede utilizar este comando.


Editar archivo (Comando, menú Edición)

Vea también

Le permite modificar un archivo controlado de origen asegurándose de que está desprotegido para después abrir el archivo en el editor asociado.

Derechos de acceso

Debe tener el permiso Escribir para utilizar este comando.

Comentarios

Cuando selecciona Editar archivo, lo primero que hace VSS es comprobar que lo ha desprotegido. Si no lo ha hecho, le desprotegerá el archivo, a no ser que algo lo impida, como que el archivo ya esté desprotegido por otro usuario (cuando el administrador de VSS no haya activado varias desprotecciones para ese proyecto).

Tras desprotegerle el archivo, VSS abre el archivo. Es posible seleccionar un editor al hacer clic en el botón Avanzadas del cuadro diálogo Archivo.

La selección del editor predeterminado se establece de una de las formas siguientes, en el orden siguiente:

  1. VSS busca en sus archivos de inicialización una línea con la extensión del archivo que se está viendo.

  2. VSS utiliza el Explorador de Microsoft Windows (la base de datos de registro y WIN.INI) para asociar una aplicación con la extensión de archivo.

  3. VSS busca su entrada en Editor para ver archivos de la ficha General del cuadro de diálogo Opciones de SourceSafe.

  4. Si VSS no puede determinar una asociación para el archivo después de haber utilizado estos métodos, mostrará el archivo con su propio editor.

Nota Si no se puede encontrar ningún editor para un tipo determinado de archivo, el archivo permanecerá desprotegido para usted en su carpeta de trabajo, por lo que podrá abrirlo con normalidad en el editor que desee.

También puede establecer el comportamiento de doble clic de VSS en la ficha General del cuadro de diálogo Opciones del menú Herramientas. Si establece la opción Doble clic en un archivo a Modificar archivo, podrá hacer doble clic en un archivo en VSS para modificarlo. De todas formas, se recomienda la opción Preguntar (para evitar que escriba accidentalmente sobre un archivo local durante la operación de desprotección).


Invertir selección (Comando, menú Edición)

Selecciona todos los archivos no seleccionados actualmente y anula la selección de los seleccionados actualmente.

Derechos de acceso

Cualquier usuario de VSS puede utilizar este comando.

Comentarios

El comando Invertir selección invierte el estado de selección de cada archivo mostrado actualmente en la lista de archivos del Explorador de VSS. El comando puede ser muy útil cuando ha realizado una operación sobre todos los archivos seleccionados y desea realizar otras sobre los archivos restantes.


Seleccionar (Comando, menú Edición)

Vea también

Selecciona uno o más archivos sobre los cuales realizar operaciones. El panel de archivos del Explorador de VSS debe estar activo para que este comando esté disponible.

Derechos de acceso

Cualquier usuario de VSS puede utilizar este comando.

Comentarios

El comando Seleccionar abre un cuadro de diálogo dentro del cual puede escribir el nombre de un único archivo, varios nombres de archivo separados por signos de punto y coma (;) o los nombres de varios archivos mediante caracteres comodín.

Opciones del cuadro de diálogo

Elemento

Escriba el nombre de un único archivo o de múltiples archivos. Para seleccionar todos los archivos de la lista de archivos, escriba *.*; para seleccionar todos los archivos que tienen la extensión .RTF, escriba *.RTF y así sucesivamente. Utilice el punto y coma (;) como delimitador entre tipos de archivo que desee incluir en la selección, por ejemplo "*.RTF; *.EXE".

Seleccionar

Selecciona el archivo.

Anular selección

Anula la selección de un archivo.

Aceptar

Confirma la selección.

Cancelar

Cancela la operación, cierra el cuadro de diálogo y vuelve al Explorador de VSS.


Seleccionar todo (Comando, menú Edición)

Vea también

Selecciona todos los archivos mostrados actualmente en el panel de archivos del Explorador de VSS de forma que pueda realizar una operación de grupo sobre todos los archivos.

Derechos de acceso

Cualquier usuario de VSS puede utilizar este comando.


Ver archivo (Comando, menú Edición)

Vea también

Muestra el texto de la copia maestra del archivo de VSS. Para ver una versión anterior del archivo, utilice el botón Ver del cuadro de diálogo Historial de archivo (menú Herramientas). Para ver un archivo antes de compartirlo en el proyecto actual, utilice el botón Ver del cuadro de diálogo Compartir.

Derechos de acceso

Debe disponer del derecho de acceso Leer para utilizar este comando.

Comentarios

El comando Ver archivo abre y muestra una copia maestra de VSS del archivo utilizando el editor asociado a ese archivo. También puede seleccionar un editor haciendo clic en el botón Avanzado del cuadro de diálogo Archivo. No cambia nada en la base de datos de VSS ni en la carpeta de trabajo.

El editor asociado se selecciona de una de las siguientes maneras, en el orden siguiente:

  1. VSS busca en sus archivos de inicialización una línea con la extensión del archivo que se está viendo.

  2. VSS utiliza el Explorador de Microsoft Windows (la base de datos de registro y WIN.INI) para asociar una aplicación con la extensión de archivo.

  3. VSS busca su entrada en Editor para ver archivos de la ficha General del cuadro de diálogo Opciones de SourceSafe.

  4. Si VSS no puede determinar una asociación de archivo tras utilizar estos métodos, muestra el archivo en su propio editor.


Opciones (Comando, menú Herramientas)

Vea también

Le permite personalizar su entorno VSS.

Derechos de acceso

Cualquier usuario de VSS puede utilizar este comando.

Comentarios

Haga clic en la ficha que contiene la información que desea. Cada ficha contiene grupos de opciones que puede establecer para personalizar VSS.

Fichas del cuadro de diálogo

General

Le permite establecer opciones generales aplicables a una serie de comandos de VSS.

Archivos locales

Configura los archivos de la carpeta de trabajo y cómo se tratan durante el funcionamiento de diferentes comandos.

Ver

Establece opciones de presentación, como mostrar o no la barra de herramientas o la barra de estado, y opciones de la lista de archivo.

Diferencias

Le permite especificar opciones para ver diferencias entre archivos y proyectos. Estas opciones se utilizan en otros cuadros de diálogo de VSS como el cuadro de diálogo Diferencias de proyecto y Combinación visual.

Cuadros de diálogo de comandos

Configura la presentación de cuadros de diálogo intermedios relacionados con varios comandos de VSS. Estos cuadros de diálogo intermedios suelen presentar opciones adicionales.

Advertencias

Determina cuándo se muestran los mensajes de advertencia.

Tipos de archivo

Establece cómo se determina la información sobre el tipo de archivo.

Opciones de línea de comandos

Personaliza el funcionamiento de los comandos de la línea de comandos.


Abrir base de datos de SourceSafe (Comando, menú Archivo)

Vea también

Le permite alternar entre bases de datos de VSS a través del Explorador de VSS.

Derechos de acceso

Debe disponer del derecho de acceso Leer para utilizar este comando.

Comentarios

Utilice este comando si necesita tener acceso periódicamente a varias bases de datos de VSS. Por supuesto, necesitará tener permisos de acceso al servidor donde se encuentre la base de datos y a la base de datos a la que intenta tener acceso. Cuando utilice este comando, la base de datos actual de VSS se cerrará y se abrirá la recién especificada.

Puede asignar un nombre fácil de recordar a cada base de datos y, cada vez que se conecte a una nueva base de datos, se agregará a la lista en el cuadro de diálogo Abrir base de datos de SourceSafe.

Nota Si ha utilizado Visual SourceSafe 4.0 con varias bases de datos, es probable que haya usado el antiguo método de variable inicialización que consiste en alternar entre bases de datos. En la mayoría de los casos, cada base de datos tendrá su propio archivo SRCSAFE.INI y puede utilizar el botón Examinar una vez para encontrar cada base de datos y agregarla a la lista de base de datos; a partir de ese momento, puede utilizar el comando Abrir base de datos de SourceSafe.

Si tiene una base de datos sin un archivo SRCSAFE.INI, cree un archivo SRCSAFE.INI para dicha base de datos. Ponga ese archivo SRCSAFE.INI en la carpeta situada inmediatamente encima de la carpeta DATA.


Menú Ayuda (Comandos)

Los comandos del menú Ayuda proporcionan Ayuda acerca de la utilización de VSS y de comandos específicos de VSS. Además, puede presionar F1 en cualquier momento para ver Ayuda acerca del elemento de menú o del cuadro de diálogo seleccionado actualmente.

Comando de Ayuda | Acción
Contenido | Ejecuta la Ayuda y muestra la Tabla de contenido de VSS.
Buscar ayuda acerca de | Muestra el cuadro de diálogo Buscar Ayuda de forma que pueda encontrar rápidamente la información que desea.
Soporte técnico | Muestra información acerca del Soporte técnico de productos de Microsoft.
Acerca de Microsoft Visual SourceSafe | Muestra un cuadro de diálogo con información acerca de su copia de Microsoft VSS, incluyendo el número de versión y los avisos sobre derechos de autor, consideraciones legales y licencia.

Derechos de acceso

Cualquier usuario de VSS puede utilizar estos comandos.

Comentarios

Una forma rápida de encontrar información consiste en utilizar Buscar y un índice automático con cientos de entradas de índices y referencias cruzadas.

También puede buscar temas de ayuda en la Tabla de contenido de VSS.

A medida que lee un tema en la Ayuda de VSS, puede desplazarse por el tema con la barra de desplazamiento, las teclas de dirección o las teclas RE PÁG y AV PÁG.


Obtener ayuda del Soporte Técnico de Microsoft

Si no puede encontrar las respuestas que necesita en el archivo de Ayuda o el manual del producto, puede resolver los problemas rápidamente mediante una de entre muchas opciones.

Nota Los servicios y precios que se enumeran aquí están disponibles sólo en EE.UU. y Canadá, y está sujeto a cambios sin previo aviso. El soporte fuera de EE.UU y Canadá puede variar. Póngase en contacto con el distribuidor de Microsoft más cercano mediante la lista mundial de distribuidores del archivo de Ayuda de este producto.

Soporte Online

Soporte estándar sin cargo

Soporte con pago por incidente

Respuesta Web

Soporte adicional

Soporte fuera de los EE.UU y Canadá


Mostrar diferencias (Comando Archivo, menu Herramientas)

Vea también

Compara dos archivos y muestra las diferencias, si las hay.

Nota Si desea ver las diferencias entre proyectos, seleccione un proyecto en el panel de proyectos del Explorador de VSS y haga clic en Mostrar diferencias.

Derechos de acceso

Debe disponer del derecho de acceso Leer para utilizar este comando. Debe tener una carpeta de trabajo establecida antes de utilizar este comando.

Comentarios

La mayoría de las veces, utilizará el comando Mostrar diferencias inmediatamente antes de proteger un archivo para comparar su copia del archivo con la copia maestra de VSS. Esto le da una lista de los cambios que ha realizado, lo cual puede ayudarle a generar un comentario.

Al utilizar el comando Mostrar diferencias sobre un archivo de texto ASCII, VSS muestra una lista coloreada de las diferencias entre los archivos.

En el caso de archivos binarios, VSS puede decirle si la copia local del archivo es diferente de la copia maestra, pero no puede mostrar las diferencias.

Nota También es posible comparar dos versiones anteriores de un archivo entre sí o comparar una versión anterior con la versión actual. Cuando selecciona un elemento en el cuadro de diálogo Historial de archivo y después hace clic en Diferencias.

Opciones del cuadro de diálogo

Nota Active la presentación de este cuadro de diálogo en la ficha Cuadros de diálogo de comandos del cuadro de diálogo Opciones de SourceSafe (menú Herramientas).

De forma predeterminada, VSS utiliza el cuadro de diálogo Diferencia visual. Si especifica una presentación UNIX, VSS utiliza la opciones de presentación de VSS correspondientes a las casillas Pasar por alto MAY e Ignorar diferencias en espacios en blanco. La opción de presentación de VSS utiliza anchos de línea calculados para que éstas quepan dentro de su pantalla y no muestra líneas de contexto.

Comparar / Con

Cuando realiza una comparación de archivo rutinaria, el campo Comparar contendrá de forma predeterminada el archivo de VSS y el campo Con el archivo correspondiente en la carpeta de trabajo. Puede escribir en el campo Comparar o hacer clic en el botón Examinar con el fin de especificar su selección. Puede también utilizar los botones Examinar para comparar dos archivos de VSS (en el mismo proyecto o en otros proyectos), dos archivos locales (en la misma carpeta o en otras carpetas) o bien un archivo de VSS con otro archivo local.

Visual

Muestra el archivo completo, con anotaciones para los cambios.

SourceSafe

Muestra una lista de las líneas que se agregaron, eliminaron y cambiaron, optimizada para su legibilidad.

UNIX

Muestra las diferencias de formato utilizadas por el programa Diff de UNIX.

Ignorar espacios en blanco

Muestra las diferencias sin tener en cuenta los caracteres espaciadores tales como los tabuladores.

Pasar por alto MAY/min

Muestra las diferencias sin distinguir entre mayúsculas y minúsculas.

Mostrar sólo cuando se presiona Máyus

Si activa esta casilla, el cuadro de diálogo Mostrar diferencias se mostrará sólo si mantiene presionada la tecla MAYÚSCULAS mientras ejecuta el comando Mostrar diferencias.

Aceptar

Muestra el cuadro de diálogo Diferencias de proyecto.

Cancelar

Cancela el comando Mostrar diferencias.

Informe

Envía un informe al Portapapeles, a un archivo de texto a la impresora.

Opciones avanzadas

Ignorar diferencias del SO

Especifica que VSS pase por alto las diferencias entre los caracteres de salto de línea entre sistemas operativos. Esta opción es útil si está comparando archivos en una red en la que hay un equipo Macintosh, por ejemplo, y el otro equipo funciona con Microsoft Windows NT.

Mostrar contexto

Incluye el número especificado de líneas de contexto en la pantalla de diferencias. Las líneas de contexto son las líneas del archivo que rodean la línea identificada como diferente por VSS. Por ejemplo, establecer Mostrar contexto a tres significa que verá tres líneas de contexto por encima y tres por debajo de la línea de diferencia.

Nota Si utiliza Diferencia visual, esta opción se pasará por alto.

Guardar configuración

Guarda la configuración seleccionada para utilizaciones futuras.


Mostrar historial (Comando, menú Herramientas)

Vea también

Muestra el historial de un archivo o un proyecto de VSS.

Derechos de acceso

Debe disponer del derecho de acceso Leer para utilizar este comando.

Comentarios

Cada vez que proteja un archivo o un proyecto en VSS, el archivo o el proyecto se considera una nueva versión. Utilice el comando Mostrar historial para ver una lista de las versiones anteriores de un archivo o un proyecto.

Las versiones se muestran comenzando con la más reciente y hacia atrás hasta la creación del archivo o el proyecto. VSS proporciona información acerca del número de versión, que puede utilizarse con otros comandos (como Obtener la última versión) para indicar una versión específica.

De forma predeterminada, el historial de un proyecto incluye los historiales de todos sus archivos, pero no incluye los subproyectos.

Puede comparar una versión de un archivo con otra si selecciona las dos versiones simultáneamente (mantiene presionada la tecla CTRL y hace clic en cada versión) y después hace clic en el botón Diferencias.

Opciones del cuadro de diálogo

Nota Active la presentación de este cuadro de diálogo en la ficha Cuadros de diálogo de comandos del cuadro de diálogo Opciones de SourceSafe (menú Herramientas).

Incluir historiales de archivos (sólo en historial de proyecto)

Incluye archivos en el historial del proyecto.

Recursivo (sólo para historiales de proyectos)

Incluye subproyectos y todos los archivos que contienen.

Sólo etiquetas

Incluye sólo las etiquetas en el historial del proyecto.

Desde

Escriba una hora, fecha, versión o etiqueta. Utilice el prefijo D para indicar una fecha o fecha y hora, y el prefijo L para indicar una etiqueta. Por ejemplo "D02/29/95;12:15" o "Lbeta1". Es posible escribir la fecha en el formato 08.15.97, 08-15-97 ó 08/15/97, pero no como 15 de agosto, 1997. Observe que, si tiene un proyecto seleccionado para ver su historial, no podrá examinarlo en busca de etiquetas; para ello deberá seleccionar el archivo y utilizar el comando Mostrar historial para encontrar una etiqueta en concreto.

En

Escriba la hora, la fecha, la versión o la etiqueta. Utilice el prefijo D para indicar una fecha o fecha y hora, y el prefijo L para indicar una etiqueta. Por ejemplo "D02/29/95;12:15" o "Lbeta1". Las fechas pueden especificarse en el formato 08.15.95, 08-15-95 u 08/15/95, pero no como 15 de agosto de 1995.

Usuario

Muestra un historial de los archivos en los que ha trabajado el usuario especificado.

Aceptar

Muestra el cuadro de diálogo Historial de proyecto o Historial de archivo, dependiendo de si se seleccionó un archivo o un proyecto en el Explorador de VSS. En estos cuadros de diálogo, haga clic en cualquiera de los elementos de la lista y después haga clic en Detalles para mostrar el cuadro de diálogo Detalles del historial. Desde dentro del cuadro de diálogo Detalles del historial puede hacer clic en los botones Siguiente y Anterior para moverse hacia arriba y hacia abajo por el historial. También puede modificar el comentario y la etiqueta asociados con la versión que está viendo.

Mostrar sólo cuando se presiona Máyus

Salta este cuadro de diálogo en las futuras operaciones de Mostrar historial y utiliza los valores especificados como predeterminados. Para restaurar el cuadro de diálogo, haga clic en la casilla de verificación apropiada de la ficha Cuadros de diálogo de comandos en el cuadro de diálogo Opciones de SourceSafe.


Propiedades (Comando, menú Archivo)

Vea también

Muestra el cuadro de diálogo Propiedades, que contiene información básica acerca de un archivo o un proyecto de VSS, incluyendo el tamaño, nombre y tipo.

Derechos de acceso

Debe disponer del derecho de acceso Leer para ver el cuadro de diálogo Propiedades.

Debe disponer del derecho de acceso Agregar para cambiar el tipo de un archivo.

Debe disponer del derecho de acceso Destruir para cambiar el estado de Almacenar sólo la última versión de un archivo.

Comentarios

Haga clic en la ficha que contiene la información que desea. El contenido de la ficha varía dependiendo si un archivo o un proyecto está seleccionado actualmente en el Explorador de VSS.

Nota Haga clic en el botón Informe de cualquiera de las fichas para crear un informe para enviarlo al Portapapeles, a un archivo de texto o a una impresora.

Fichas del cuadro de diálogo Propiedades de archivo

General

Muestra el nombre de archivo, su tipo, tamaño el número de la versión más reciente, la fecha de la última modificación, el comentario, además de indicar si todo el historial del archivo (o sólo la última versión) está almacenado en la base de datos de SourceSafe. Puede cambiar el comentario y establecer que se almacene sólo la última versión del archivo para ahorrar espacio de disco. Aquí también puede modificar el tipo de archivo.

Estado de desprotección

Muestra el nombre del archivo, quién lo ha desprotegido (si lo ha desprotegido alguien), si está desprotegido de forma exclusiva, cuando fue desprotegido, la versión que está desprotegida, el ordenador para el que está desprotegido la ruta de desprotección, el proyecto en el que está el archivo y el comentario de desprotección. Puede modificar el comentario de desprotección.

Vínculos

Muestra los vínculos compartidos actuales que tiene un archivo con otros proyectos.

Rutas de acceso

Muestra los proyectos que han bifurcado versiones de este archivo anteriormente.

Fichas del cuadro de diálogo Propiedades del proyecto

General

Muestra el nombre del proyecto actual, el número de archivos y subproyectos que contiene, el número de versión más reciente, cuándo se cambió por última vez, si el proyecto está escondido y el comentario del proyecto. Puede cambiar el comentario.

Elementos eliminados

Muestra los archivos que se han eliminado del proyecto desde la última vez que se agregó a VSS. Utilice este cuadro de diálogo para recuperar o purgar un archivo eliminado.


Mostrar diferencias (Comando, Proyecto, menú Herramientas)

Vea también

Compara un proyecto de VSS y el correspondiente proyecto de su carpeta de trabajo y muestra las diferencias, si las hay. También puede ver las diferencias de líneas individuales en los archivos con diferentes y reconciliar las diferencias entre la carpeta de trabajo y el proyecto.

Nota Si desea mostrar diferencias entre un archivo del proyecto y ese archivo en la carpeta de trabajo. seleccione un archivo en el panel de archivos del Explorador de VSS y después haga clic en Mostrar diferencias.

Derechos de acceso

Debe disponer del derecho de acceso Leer para utilizar este comando.

Comentarios

El comando Mostrar diferencias de un proyecto genera un cuadro de diálogo con dos paneles en el que se muestran las diferencias entre un proyecto VSS y otro proyecto VSS, un proyecto VSS y una carpeta de Windows o dos carpetas de Windows. Antes de que se muestren las listas de proyectos, aparecerá un cuadro de diálogo de comando que le permite filtrar la lista de archivos, si lo desea, de forma que podrá limitar la información a los archivos que le interesen.

Una utilización común de este comando es buscar los archivos que otro usuario ha eliminado del proyecto, de forma que pueda eliminarlos de su carpeta de trabajo. También puede ser útil si toma un proyecto durante un momento para ver dónde ha realizado sus cambios a nivel de proyecto.

Después de examinar los archivos en ambos paneles, puede reconciliar las diferencias entre la carpeta de trabajo y el proyecto de SourceSafe de varias formas. Por ejemplo, puede obtener o proteger todos los archivos que son diferentes en su carpeta de trabajo, o agregar a su proyecto todos los archivos que todavía no se encuentren en él.

Opciones del cuadro de diálogo Diferencias de proyecto

Nota Active la presentación de este cuadro de diálogo en la ficha Cuadros de diálogo de comandos del cuadro de diálogo Opciones de SourceSafe (menú Herramientas).

Las opciones que aparecen en este cuadro de diálogo no son mutuamente excluyentes, sino que puede combinarlas para filtrar las listas de archivos de cada panel. Cada casilla de verificación puede agregar más archivos a las listas de los paneles.

Comparar / En

Cuando realiza una comparación de archivo rutinaria, el campo Comparar contendrá de forma predeterminada el archivo de VSS y el campo En el archivo correspondiente en la carpeta de trabajo. Puede escribir en el campo Comparar o hacer clic en el botón Examinar con el fin de especificar su selección. Puede también utilizar los botones Examinar para comparar dos archivos de VSS (en el mismo proyecto o en otros proyectos), dos archivos locales (en la misma carpeta o en otras carpetas) o bien un archivo de VSS con otro archivo local.

Mostrar los archivos que están sólo en el proyecto

Incluye, en el panel izquierdo, archivos de proyecto que no están en la carpeta de trabajo en ese momento. Esta opción aparecerá activada de forma predeterminada.

Mostrar los archivos que están sólo en la carpeta de trabajo

Incluye, en el panel derecho, los archivos de la carpeta de trabajo que no se encuentran en el proyecto de VSS en ese momento. Esta opción aparecerá activada de forma predeterminada.

Mostrar los archivos que son diferentes en los dos sitios

Incluye todos los archivos que se encuentran tanto en la carpeta de trabajo como en el proyecto de VSS, pero que son distintos entre sí. En el caso de estos archivos, lo más frecuente es que tenga que obtener el archivo para actualizar la versión en su carpeta de trabajo. Esta opción aparecerá activada de forma predeterminada.

Mostrar los archivos que son iguales en los dos sitios

Incluye archivos en los proyectos que son iguales en ambos lugares. Esta opción aparecerá activada de forma predeterminada.

Recursivo

Busca el contenido del proyecto actual; también busca en los subproyectos bajo el proyecto actual y muestra las diferencias entre la lista de proyectos completa y su lista de carpeta local.

Mostrar sólo cuando se presiona Máyus

Si activa esta casilla, el cuadro de diálogo Mostrar diferencias se mostrará sólo si mantiene presionada la tecla MAYÚSCULAS mientras ejecuta el comando Mostrar diferencias.

Aceptar

Muestra el cuadro de diálogo Diferencias de proyecto.

Cancelar

Cancela el comando Mostrar diferencias.


Buscar (Comando, menú Ver)

Vea también

Filtra la lista de archivos del Explorador de VSS para buscar los archivos desprotegidos cuyos nombres coinciden con un patrón o cadena especificado. Busca uno o más archivos especificados en la lista de proyectos y limita la presentación de la lista de archivos a esos archivos.

Derechos de acceso

Debe disponer del derecho de acceso Leer para utilizar este comando.

Comentarios

La búsqueda por estado puede utilizarse para buscar únicamente los archivos desprotegidos por un determinado usuario. Cuando un archivo se comparte en múltiples proyectos, el comando Buscar muestra para qué proyectos está desprotegido el archivo.

Sugerencia Presione Mayúsculas-Ctrl-S para buscar todos los archivos desprotegidos del proyecto actual. No se muestra el cuadro de diálogo Buscar.

Opciones del cuadro de diálogo Buscar por estado

Mostrar todos los archivos desprotegidos

Muestra todos los archivos desprotegidos, sin tener en cuenta quién los desprotegió.

Mostrar archivos desprotegidos por

Haga clic en este botón y escriba un nombre de usuario si sólo desea ver los archivos que ha desprotegido dicho usuario, en lugar de ver todos los archivos desprotegidos. También puede seleccionar nombres de usuario de la lista desplegable. También puede seleccionar nombres de usuario de la lista desplegable.

Área de búsqueda

Especifique qué proyectos o subproyectos desea incluir en la búsqueda. Puede buscar sólo en el proyecto actual, en el proyecto actual y en todos sus subproyectos, o bien en todos los proyectos de la base de datos.

Opciones del cuadro de diálogo Buscar con comodín

Comodín

Escriba un nombre de archivo o una cadena con caracteres comodín. Por ejemplo, archivo.*.

Área de búsqueda

Especifique qué proyectos o subproyectos desea incluir en la búsqueda. Puede buscar sólo en el proyecto actual, en el proyecto actual y en todos sus subproyectos, o bien en todos los proyectos de la base de datos.

Nota Si desactiva simultáneamente las casillas de verificación Comodín, se cancelará la búsqueda. Además, si escribe * o *.* en el cuadro Comodín y la casilla de verificación Buscar en todos los proyectos está desactivada, también se cancelará la búsqueda.

Recuerde que, en realidad, la búsqueda con comodines de SourceSafe es una operación de filtrado. Está buscando aquellos archivos del proyecto actual que coinciden con un criterio especificado. Si escribe *.* en el cuadro Comodín, suprimirá cualquier criterio de filtrado, por lo que se cancelará la búsqueda.


Fuente (Comando, menú Herramientas)

Cambia la fuente utilizada en el Explorador de VSS o en el Administrador de VSS.

Comentarios

Establezca el nombre, estilo y tamaño de fuente de VSS en el cuadro de dialogo Fuente. El cuadro Ejemplo muestra una vista previa de la fuente actualmente seleccionada.

Los valores de fuente no afectan a la fuente utilizada en el visor de diferencias de archivo. Para establecer estas opciones, utilice la ficha Opciones de diferencia.


Establecer carpeta de trabajo (Comando, menú Archivo)

Vea también

Establece la carpeta de trabajo.

Derechos

Cualquier usuario de VSS puede utilizar este comando.

Comentarios

Es importante designar, tras crear un nuevo proyecto, una carpeta de trabajo en la cual trabajar con los archivos del proyecto. Si no lo hace, SourceSafe le solicitará una carpeta de trabajo siempre que utilice un comando que requiera que haya una establecida.

Puede utilizar como carpeta de trabajo una carpeta ya existente en el disco duro del equipo. También puede crear una nueva carpeta desde VSS o desde Windows.

Si sólo hace clic en Aceptar, este comando establece temporalmente la carpeta de trabajo para el proyecto. La configuración no se guarda al cerrar VSS. Si hace clic en la casilla de verificación Guardar como predeterminada, la carpeta se guardará como carpeta de trabajo predeterminada para el proyecto actual.

Opciones del cuadro de diálogo

Nombre

Nombre y ruta de acceso de la carpeta de trabajo.

Carpeta

Tu actual carpeta de trabajo.

Carpetas

Su carpeta de trabajo actual.

Unidades

Selecciona la unidad que contiene la carpeta de trabajo.

Aceptar

Confirma la selección.

Cancelar

Cancela la selección, cierra el cuadro de diálogo y vuelve al Explorador de VSS.

Crear carpeta

Crea una nueva carpeta para la carpeta de trabajo. Escriba un nuevo nombre de carpeta en el cuadro Nombre y después haga clic en Crear carpeta para crearla.

Guardar como predeterminada

Guarda la carpeta que especifique como su carpeta de trabajo predeterminada para el proyecto.


Ordenar (Comando, menú Ver)

Ordena la lista de archivos del Explorador de VSS. Las opciones de orden permiten ordenar por nombre de archivo, tipo, usuario, fecha o carpeta de desprotección.

Derechos de acceso

Cualquier usuario de VSS puede utilizar este comando.

Comentarios

La lista de archivos del Explorador de VSS suele estar ordesnada por nombre de archivo. Puede cambiar el criterio de ordenación:

  • Nombre (nombre de archivo)

  • Tipo (extensión del tipo de archivo)

  • Usuario (los nombres de usuario que tienen archivos desprotegidos)

  • Fecha: hora

  • Carpeta de desprotección

Tipo, Nombre, Usuario y Carpeta de desprotección se ordenan en sentido ascendente; Fecha y hora se ordena en sentido descendente, de forma que los archivos más recientes están en la parte superior. El criterio de ordenación actual se muestra siempre en la barra de estado.


Cancelar búsqueda (Comando, menú Ver)

Vea también

Restaura toda la lista de archivos en el Explorador de VSS para el proyecto actual. Este comando se utiliza tras una operación de búsqueda, que normalmente filtra la lista de archivos a un subconjunto más pequeño.

Derechos de acceso

Cualquier usuario de VSS puede utilizar este comando.

Comentarios

Cuando ejecuta el comando Buscar, VSS muestra la palabra Búsqueda en la barra de estado. Haga clic en el comando Cancelar búsqueda para volver a ver la presentación completa de archivos del Explorador de VSS. La palabra Búsqueda desaparece de la barra de estado.


Actualizar la lista de archivos (Comando, menú Ver)

Vea también

Actualiza la lista de archivos del Explorador de VSS.

Derechos de acceso

Cualquier usuario de VSS puede utilizar este comando.

Comentarios

Actualiza sólo la lista de archivos, no la lista de proyectos. Para actualizar ambas listas, contraiga la lista de proyectos a un proyecto primario y después haga doble clic en ese proyecto para expandir la lista de proyectos.

También puede actualizar la lista de archivos automáticamente. Configure el periodo de actualización con la opción Actualizar automáticamente la lista de archivos en la ficha Ver del cuadro de diálogo Opciones de SourceSafe (menú Herramientas).


Comprobar hipervínculos (Comando, menú Web)

Vea también

Le permite comprobar los vínculos Web en los archivos HTML.

Derechos de acceso

Debe tener el derecho de acceso Escribir para utilizar este comando.

Comentarios

Puede utilizar este comando para comprobar los vínculos del Web en los archivos HTML, tanto los archivos que se encuentren en la carpeta de trabajo como los que estén en un proyecto de VSS. VSS sólo comprueba los vínculos que saltan a otros archivos del proyecto; los vínculos con páginas externas no se comprueban.

Se comprueban los vínculos identificados con las etiquetas <A HREF>, <IMG SRC> y <OPTION VALUE> de HTML, así como dentro de los archivos .MAP (para las zonas activas de una imagen). No se comprueban los vínculos con otras direcciones del Web creados mediante código como VBScript o Java.

Cuando ha terminado la comprobación de vínculos, VSS presenta un cuadro de diálogo con tres cuadros de lista. El cuadro superior presenta una lista con todos los archivos en los que se encontraron errores. El cuadro del centro muestra los vínculos internos (saltos a otros archivos dentro del mismo proyecto Web) que parecen no ser válidos en el archivo seleccionado en el cuadro superior y el cuadro inferior muestra los vínculos externos que se han encontrado pero no han sido comprobados.


Crear mapa de sitios (menú Web)

Vea también

Le permite crear automáticamente un mapa de los archivos HTML que se encuentran en un proyecto Web.

Derechos de acceso

Debe tener el derecho de acceso Escribir para utilizar este comando.

Comentarios

Los mapas de sitios cada vez son más populares como métodos de exploración a través de un sitio Web. Este comando le permite generar fácilmente una lista de los archivos HTML que hay en su proyecto Web y crea la lista como un archivo HTML que se vincula a cada archivo. Con una mínima personalización, podrá agregar el archivo resultante a su sitio Web y proporcionar a sus usuarios un método de exploración clásico.

Cada vez que ejecute este comando se creará un archivo totalmente nuevo. Es decir, este comando no compara el material nuevo con el antiguo y únicamente realiza cambios. Por tanto, si ha agregado alguna personalización al archivo de mapa de sitios resultante, debe estar preparado para agregarlo de nuevo cada vez que ejecute este comando o para utilizar tecnología como archivos de inclusión en el lado del servidor para almacenarlo en un lugar aparte. Además, el código HTML generado por este comando es bastante rudimentario (etiquetas de HTML 2.0). Si desea una página más personalizada, puede cortar y pegar a partir del código HTML proporcionado por este comando o agregar etiquetas HTML al archivo para que quede mejor en su sitio Web.

El comando Crear mapa de sitios funciona obteniendo los títulos de los archivos HTML a partir de su etiqueta <TITLE>. Si tiene un archivo HTML sin una etiqueta <TITLE>, VSS utilizará su nombre de archivo. Para generar un buen mapa de sitios, debe utilizar cadenas únicas y descriptivas en las etiquetas <TITLE> de sus archivos. Los nombres de categorías del mapa de sitios proceden del nombre del proyecto de VSS. Por tanto, es importante utilizar nombres de proyectos buenos y descriptivos en los proyecto de sitios Web.

Una vez creado el archivo de mapa de sitios HTML, puede agregarlo a su proyecto mediante el comando Agregar archivos. Si agrega el archivo a su proyecto de sitio Web, no olvide desprotegerlo antes de ejecutar el comando Crear mapa de sitios.

A modo de ejemplo, considere un proyecto Web externo como el siguiente:

Si ejecuta Crear mapa de sitios en el proyecto Web externo se creará un archivo HTML cuya apariencia será igual a la de éste en un explorador Web:

Usando este HTML:

Por supuesto, en este momento puede personalizar el código HTML para lograr una apariencia del mapa de sitios que le satisfaga; utilice un color o un diseño de fondo diferente, cambie los niveles de sangría, elimine o agregue elementos, etc. Una forma de personalizar el mapa de sitios consiste en cambiar los archivos gráficos utilizados para los iconos de la carpeta y del archivo. Para obtener más información acerca de cómo hacerlo, vea las variables de inicialización IMG_Folder e IMG_File.


Distribuir (Comando, menú Web)

Vea también

Le permite distribuir un conjunto de archivos Web en un servidor Web o en varios servidores Web. Este comando sólo funciona con proyectos, no con archivos.

Derechos de acceso

Debe disponer del derecho de acceso Destruir para utilizar este comando.

Comentarios

Una vez terminado el desarrollo y la comprobación de sus páginas Web, el comando Distribuir se utiliza para copiar los archivos al servidor Web activo. La ubicación de dicho servidor es una carpeta o un sitio FTP especificado por el administrador de VSS. Cuando elija el comando Distribuir, se copiará el contenido del proyecto actual a dicha ubicación.

En muchos aspectos, el comando Distribuir se comporta igual que el comando Obtener: copia archivos de un proyecto de VSS a una carpeta local. Sin embargo, Obtener realiza una copia para su uso personal, mientras que Distribuir hace el proyecto público, potencialmente para todo el mundo. Por este motivo, el comando Distribuir requiere privilegios del nivel de Destruir en el proyecto seleccionado.

El administrador de VSS tiene que establecer una ruta de acceso para la distribución en la ficha Sitios Web del cuadro de diálogo Opciones (menú Herramientas del Administrador) para activar este comando. Sólo puede distribuir un proyecto completo marcado como un proyecto de sitio Web, pero no archivos individuales. La carpeta de distribución puede ser un conjunto de lugares delimitados por una coma a donde desea que se copien sus archivos.

Al utilizar el comando Distribuir sobreescribirá los archivos ya existentes con el mismo nombre en la carpeta de distribución, incluso si la casilla de verificación Reemplazar archivos modificables de la ficha Archivos locales (cuadro de diálogo Opciones del menú Herramientas) está establecida a Saltar.

Observe que este comando es útil en varias situaciones no necesariamente relacionadas con la distribución de sitios Web. Por ejemplo, si ha seleccionado un conjunto de archivos .DOC de especificación del producto que desee publicar en un servidor público.


Acerca de VSS (Menú Ayuda)

Muestra un cuadro de diálogo con información acerca de su copia de Microsoft VSS, incluyendo el número de versión, el tipo de plataforma y los avisos sobre derechos de autor, legales y licencia.

Haga clic en Aceptar para cerrar el cuadro de diálogo.


Agregar grupo de archivos (Cuadro de diálogo)

Vea también

Agrega un nuevo grupo de archivos a la ficha Tipos de archivo del cuadro de diálogo Opciones de SourceSafe (menú Herramientas).

Para ver el cuadro de diálogo Agregar grupo de archivos

  • En el menú Herramientas haga clic en Opciones y a continuación en la ficha Tipos de archivos. Haga clic en el botón Agregar.

Opciones del cuadro de diálogo

Nombre

Escriba el nombre del grupo de archivos de la forma en que le gustaría identificarlo en la lista de grupos de archivos de la ficha Tipos de archivo.

Aceptar

Agrega el grupo de archivos.

Cancelar

Cancela el comando Agregar grupo de archivos.


Agregar archivos (Comando, menú Archivo)

Vea también

Copia un archivo o un grupo de archivos al proyecto actual de VSS. En el cuadro de diálogo Agregar archivo puede especificar un archivo de cualquier unidad y carpeta, y que ese archivo se copie al proyecto actual de VSS.

Derechos de acceso

Debe disponer del derecho de acceso Agregar para utilizar este comando.

Comentarios

Puede utilizar el comando Purgar para deshacer una operación Agregar archivos, pero no es recomendable puesto que no conserva una copia recuperable del archivo en la base de datos de VSS. En su lugar, considere la utilización del comando Eliminar, puesto que conserva una copia recuperable del archivo.

Opciones del cuadro de diálogo

Nombre de archivo

Seleccione o escriba el nombre del archivo que desee abrir. Este cuadro muestra los elementos que tienen la extensión de archivo seleccionada en el cuadro Mostrar archivos de tipo.

Mostrar archivos de tipo

Muestra el tipo de archivo o indica a VSS cómo clasificar un archivo.

La lista de tipos de archivo disponibles se determina en el filtro Tipos de archivo incluidos en grupo de archivos y en el filtro Grupos de archivo establecidos en la ficha Tipos de archivo del cuadro de diálogo Opciones de SourceSafe. Todos los archivos (*.*) muestra una lista de todos los archivos de la carpeta actual.

Carpetas

Especifica la carpeta que contiene el archivo que desea agregar.

Unidades

Selecciona la unidad que contiene el archivo que desea agregar.

Cerrar

Cierra el cuadro de diálogo sin agregar el archivo al proyecto.

Agregar

Abre el cuadro de diálogo Comentario avanzado, permitiéndole agregar los archivos seleccionados al proyecto seleccionado. El cuadro de diálogo Comentarios avanzados muestra un cuadro de comentarios en el que puede introducir comentarios (opcional). Seleccione la casilla Aplicar el mismo comentario a todos para utilizar el mismo comentario para todos los archivos que está agregando. Haga clic en elk botón Avanzados del cuadro de diálogo Comentarios avanzados para acceder a más opciones.

Ver

Muestra el archivo seleccionado con el comando Ver archivo.

Aplicar el mismo comentario para todos

Utiliza el mismo comentario a todos los archivos implicados en la operación Agregar archivos. Si esta casilla de verificación está desactivada, puede especificar un comentario diferente para cada archivo. El valor predeterminado es que esté activada (su comentario se aplicará a todos los archivos seleccionados para esta operación).

Recursiva

Indica que quiere agregar todos los archivos de las subcarpetas cuando selecciona toda una carpeta para agregar. Sólo está disponible cuando selecciona una carpeta y hace clic en Agregar.

Opciones avanzadas

Guardar sólo la última versión

Indica que no desea guardar versiones antiguas del archivo o los archivos que se agregan a la base de datos de VSS. VSS conserva un historial de archivo con los registros de cambios con comentarios. De todas formas, la versiones antiguas del archivo no se almacenan y, por tanto, no se pueden recuperar.

Nota Para incrementar el rendimiento y ahorrar espacio del disco, use esta opción cuando almacene programas ejecutables en VSS.

Desproteger inmediatamente

Desprotege el archivo justo después de agregarlo a VSS.

Quitar copia local

Elimina el archivo de la carpeta de trabajo después de agregarlo a VSS.

Tipo de archivo

Seleccione una opción del cuadro de lista.

  • Detección automática: VSS determina el tipo de archivo.

  • Binario: VSS trata al archivo como un archivo binario.

  • Texto: VSS trata al archivo como un archivo de texto.

Nota Al agregar una carpeta, el campo Tipos de archivo se pasa por alto. Sin embargo, los archivos agregados durante una operación de carpeta Agregar archivos se filtran mediante el valor de Máscaras relevantes de la ficha Tipos de archivo del cuadro de diálogo Opciones de SourceSafe.


Agregar asignación para usuario (Cuadro de diálogo)

Vea también

Cambia los derechos de acceso del usuario seleccionado en la lista de usuarios.

Para mostrar el cuadro de diálogo Agregar asignación para usuario:

  1. En el menú Herramientas, haga clic en Asignaciones de derechos para usuario.

  2. En el cuadro de diálogo Asignaciones de derechos para usuario, haga clic en Agregar asignación.

Comentarios

Para asignar o cambiar derechos de acceso para el usuario seleccionado, en Proyecto, seleccione un proyecto de la lista de proyectos, y haga clic en la casilla de verificación Derechos de usuario con el nivel de derechos de acceso que desee asignar.

Nota Para utilizar el cuadro de diálogo Agregar asignación para usuario, primero debe activar la casilla de verificación Activar seguridad del proyecto en la ficha Seguridad del proyecto del cuadro de diálogo Opciones de SourceSafe del menú Herramientas.

Opciones del cuadro de diálogo

Proyecto

Lista de proyectos de la base de datos de VSS actual.

Derechos de usuario

Especifica el nivel de derechos de acceso (Leer, Desproteger, Agregar o Destruir) que tiene el usuario en el proyecto seleccionado.

Aceptar

Confirma las selecciones.

Cancelar

Cancela las selecciones y vuelve al cuadro de diálogo Asignaciones para usuario.


Agregar usuario (Comando, menú Usuarios)

Vea también

Agrega un nuevo usuario a la lista de usuarios del Administrador de VSS.

Comentarios

Es posible cambiar después el nombre de usuario y los derechos de acceso de Sólo lectura con el comando Modificar usuario y se puede cambiar la contraseña con el comando Cambiar contraseña del Administrador de VSS. Los usuarios también pueden cambiar sus propias contraseñas mediante el comando Cambiar contraseña del Explorador de VSS.

Opciones del cuadro de diálogo

Nombre de usuario

Escriba el nombre del usuario que desea agregar al sistema.

Contraseña

Escriba una contraseña opcional de VSS. A medida que los escribe, los caracteres se muestran como asteriscos.

Sólo lectura

Asigna el derecho de acceso Leer. Selecciónelo si no desea que el usuario tenga el derecho de acceso Leer y escribir.

Aceptar

Agrega el usuario.

Cancelar

Cancela el comando Agregar usuario y vuelve al Administrador de VSS.


Asignaciones de derechos para usuario (Comando, menú Herramientas)

Vea también

Muestra y cambia los derechos de acceso de un proyecto en la base de datos de VSS asignados explícitamente al usuario seleccionado en la lista de usuarios.

Comentarios

Se asignan los derechos de acceso predeterminados a cada nuevo usuario con la seguridad predeterminada o mediante la ficha Seguridad del proyecto del cuadro de diálogo Opciones de SourceSafe del menú Herramientas.

Nota Para utilizar el comando Agregar asignación de derechos de usuario, primero debe seleccionar la casilla de verificación Activar seguridad del proyecto en la ficha Seguridad del proyecto del cuadro de diálogo Opciones de SourceSafe del menú Herramientas.

El cuadro de diálogo Asignaciones para usuario sólo muestra los derechos de acceso que se han modificado explícitamente; no se muestra el efecto de la propagación de derechos. Para ver la propagación de derechos de acceso, utilice el comando Derechos por proyecto del menú Herramientas.

Opciones del cuadro de diálogo

Derechos de usuario

Especifica el nivel de derechos de acceso [image] Leer, Desproteger, Agregar o Destruir [image] que tiene el usuario en el proyecto seleccionado en Proyectos. Para cambiar estas asignaciones, haga clic en el proyecto que desee y seleccione después la casilla de verificación correspondiente al derecho de acceso apropiado.

Derechos

Nivel de los derechos de acceso asignados al usuario seleccionado para cada proyecto. Puede cambiar el tamaño de esta columna si arrastra el separador de columna tras la palabra "Derechos".

Proyectos

Proyectos en los que el usuario seleccionado tiene asignados derechos de acceso explícitamente.

Cerrar

Cierra el cuadro de diálogo y vuelve al Administrador de VSS.

Agregar asignación

Muestra el cuadro de diálogo Agregar asignación para usuario. Para agregar proyectos y asignar o cambiar derechos de acceso para el usuario seleccionado, seleccione un proyecto de la lista de proyectos, haga clic en el nivel de derechos de acceso que desee asignarle y luego haga clic en Aceptar.

Eliminar asignación

Elimina derechos de acceso de un usuario en los proyectos seleccionados.


Cambiar contraseña (Comando, menú Usuarios)

Vea también

Establece la contraseña de los usuarios, incluido el usuario Admin.

Comentarios

El administrador raramente tiene que cambiar la contraseña de un usuario, ya que éstos pueden cambiar sus contraseñas en el Explorador de VSS (comando Cambiar contraseña del menú Herramientas). Sin embargo, cuando los usuarios olvidan la contraseña no pueden ejecutar VSS. No es posible averiguar la contraseña del usuario. Sin conocer la contraseña puede utilizar el comando Cambiar contraseña para cambiarla.

Nota Cuando ejecute el Administrador de VSS, se le pedirá la contraseña del usuario Admin. Si desea proporcionar una contraseña para el usuario Admin, utilice el comando Cambiar contraseña para darle una contraseña. Tras hacerlo, no olvide la contraseña del usuario Admin, ya que no hay ninguna forma de descubrirla y deberá llamar a los Servicios de soporte técnico de Microsoft.

Opciones del cuadro de diálogo

Nombre de usuario

Nombre del usuario seleccionado en el Administrador de VSS.

Contraseña nueva

Escriba la contraseña nueva. Una contraseña consiste en cualquier combinación de uno a 15 caracteres. A medida que los escribe, los caracteres se muestran como asteriscos. Las contraseñas de VSS no distinguen entre mayúsculas y minúsculas.

Confirmar contraseña

Vuelva a escribir la nueva contraseña para comprobarla.

Aceptar

Confirma la nueva contraseña.

Cancelar

Cancela el comando Cambiar contraseña.


Copiar derechos de usuario (Comando, menú Herramientas)

Vea también

Actúa como plantilla y copia los derechos de acceso de un usuario a otro.

Comentarios

En vez de agregar los derechos de acceso de un usuario en cada proyecto en el que trabaja un usuario, puede simplemente copiar todos los derechos de acceso de otro usuario similar.

Para copiar derechos de un usuario

  1. En la lista de usuarios, haga clic en el usuario cuyos derechos de acceso desea modificar.

  2. En el menú Herramientas, haga clic en Copiar derechos de usuario. Aparecerá el cuadro de diálogo Copiar asignaciones de derechos a usuario con una lista de todos los usuarios de VSS.

  3. Haga clic en el usuario que va a utilizar como plantilla de derechos de acceso y haga clic en Copiar.

Tras haber copiado los derechos, los dos usuarios tienen derechos de acceso idénticos en todos los proyectos. Sin embargo, puede cambiar los derechos de acceso individualmente en proyectos específicos. Los futuros cambios realizados en un usuario no se duplicarán en el otro, a menos que utilice este comando para copiar de nuevo los derechos de usuario.

Opciones del cuadro de diálogo

Copiar desde

Usuario cuyos derechos de acceso desea copiar.

Copiar

Copia los derechos de acceso del usuario seleccionado en Copiar desde al usuario seleccionado en el Administrador de VSS.

Cancelar

Cancela el comando Copiar derechos de usuario.


Eliminar usuario (Comando, menú Usuarios)

Elimina un usuario de la lista de usuarios del Administrador de VSS.

Comentarios

Para eliminar un usuario

  • Haga clic en el usuario que desea eliminar de la lista de usuarios del Administrador de VSS y, en el menú Usuarios, elija Eliminar usuario. Haga clic en Sí para confirmar la eliminación.

Se eliminará al usuario de la lista y ya no podrá ejecutar VSS.

Si el usuario eliminado tiene archivos desprotegidos, no se generará un mensaje de advertencia. Para desbloquear estos archivos, ejecute VSS como el usuario Admin y utilice el comando Deshacer desprotección.


Modificar usuario (Comando, menú Usuarios)

Vea también

Cambia el nombre de usuario y los derechos de acceso del usuario seleccionado en el Administrador de VSS.

Comentarios

Utilice el comando Cambiar contraseña del menú Usuarios para cambiar la contraseña de un usuario.

Nota Un método abreviado para mostrar el cuadro de diálogo Modificar usuario consiste en seleccionar el nombre de usuario en la lista de usuarios del Administrador de VSS y presionar ENTRAR.

Opciones del cuadro de diálogo

Nombre de usuario

Escriba el nombre nuevo para cambiar el nombre del usuario seleccionado en el Administrador de VSS.

Sólo lectura

Asigna el derecho de acceso Leer. Selecciónelo si no desea que el usuario tenga el derecho de acceso Leer y escribir.

Aceptar

Confirma los cambios.

Cancelar

Cancela el comando Editar usuario.


Agregar usuarios a proyecto (Cuadro de diálogo)

Vea también

Agrega usuarios al proyecto seleccionado en Proyectos en el cuadro de diálogo Derechos por proyecto.

Comentarios

Los usuarios que se muestran en este cuadro de diálogo son usuarios de la base de datos de VSS que no tienen derechos de acceso en el proyecto seleccionado en el cuadro de diálogo Derechos por proyecto.

Para mostrar el cuadro de diálogo Agregar usuarios a proyecto:

  • En el menú Herramientas, haga clic en Derechos por proyecto y, luego, en el cuadro de diálogo Derechos por proyecto, haga clic en Agregar usuario.

Nota Para utilizar el cuadro de diálogo Agregar usuarios a proyecto, primero debe activar la casilla de verificación Activar seguridad del proyecto en la ficha Seguridad del proyecto del cuadro de diálogo Opciones de SourceSafe del menú Herramientas.

Opciones del cuadro de diálogo

Derechos

Derechos de acceso asignados al usuario.

Usuarios

Usuarios que no tienen derechos de acceso en el proyecto seleccionado.

Derechos de usuario

Especifica el nivel de derechos de acceso (Leer, Desproteger, Agregar o Destruir) que desea asignar al usuario seleccionado en la columna Usuario. Tras hacer clic en una casilla de verificación, se muestran en Derechos los derechos de acceso.

Nota Si el usuario que desea agregar al proyecto tiene el derecho de acceso Sólo lectura y desea asignarle derechos de acceso adicionales, en el menú Usuarios, haga clic en Editar usuario y desactive la casilla de verificación Sólo lectura.

Aceptar

Confirma las selecciones.

Cancelar

Cancela las selecciones y vuelve al cuadro de diálogo Derechos por proyecto.


Derechos por proyecto (Comando, menú Herramientas)

Vea también

Muestra y cambia los derechos de acceso para los usuarios seleccionados en los proyectos seleccionados.

Comentarios

Se asignan los derechos de acceso predeterminados a cada nuevo usuario con la seguridad predeterminada o mediante la ficha Seguridad del proyecto del cuadro de diálogo Opciones de SourceSafe del menú Herramientas.

Este comando muestra el efecto de la propagación de derechos en el cuadro de diálogo Derechos por proyecto. Por ejemplo, si un usuario tiene el derecho de acceso Destruir en el proyecto raíz, en Proyectos verá que el usuario tiene el derecho de acceso Destruir en todos los subproyectos [image] a menos que cambie explícitamente los derechos de acceso. Los cambios explícitos se muestran en el cuadro de diálogo Asignaciones para usuario, disponible en el menú Herramientas.

Nota Para utilizar el comando Derechos por proyecto, deberá primero seleccionar la casilla Activar seguridad del proyecto en la ficha Seguridad del proyecto del cuadro de diálogo Opciones de SourceSafe del menú Herramientas.

Opciones del cuadro de diálogo

Proyectos

Lista de proyectos de la base de datos de VSS actual. Seleccione el proyecto en el que desea ver o cambiar los derechos del usuario.

Derechos

Derechos de acceso asignados al usuario.

Usuarios

Usuarios que tienen derechos de acceso en el proyecto seleccionado.

Derechos de usuario

Especifica el nivel de derechos de acceso [image] Leer, Desproteger, Agregar o Destruir [image] que desea asignar al usuario seleccionado en la columna Usuario. Para cambiar los derechos de acceso del usuario seleccionado en el proyecto seleccionado, seleccione la casilla de verificación correspondiente.

Cerrar

Cierra este cuadro de diálogo y vuelve al Administrador de VSS.

Agregar usuario

Muestra el cuadro de diálogo Agregar usuario a proyecto, que agrega usuarios al proyecto seleccionado en Proyectos.

Eliminar usuario

Elimina los derechos de acceso del usuario seleccionado en el proyecto seleccionado, tras mostrar un mensaje de advertencia.


Establecer carpeta central o sitio Web (Cuadro de diálogo)

Seleccione un proyecto para el que quiera establecer una carpeta central o un sitio Web en su base de datos VSS.

Opciones del cuadro de diálogo

Proyecto

Seleccione el proyecto para que desee establecer una carpeta central o un sitio Web.

Aceptar

Acepta el proyecto seleccionado.

Cancelar

Cancela la selección de la carpeta central o el sitio web.


General (Opciones de la ficha, menú Herramientas)

Establece las opciones generales del usuario.

Comentarios

La configuración afecta a todos los usuarios de la lista de usuarios del Administrador de VSS.

Para mostrar la ficha General:

  • En el menú Herramientas, haga clic en Opciones y, después, haga clic en la ficha General.

Opciones del cuadro de diálogo

Permitir varias desprotecciones

Controla si varias personas pueden desproteger un archivo simultáneamente. En circunstancias normales, sólo una persona puede tener desprotegido un archivo de VSS cada vez. Sin embargo, si activa esta casilla de verificación, VSS permitirá que varias personas desprotejan el mismo archivo. Cuando el primer usuario protege el archivo, VSS lo actualiza; más tarde, VSS combina todos los cambios subsiguientes.

Usar el nombre de red para iniciar la sesión del usuario automáticamente

Establece si VSS lee el nombre de inicio de sesión del usuario del sistema operativo. Si activa esta casilla de verificación, VSS intentará obtener automáticamente los nombres de usuario del sistema operativo. Desactive esta casilla de verificación si desea que los usuarios utilicen nombres de inicio de sesión diferentes de sus nombres de inicio de sesión en la red; VSS mostrará un cuadro de diálogo Inicio de sesión a menos que los usuarios especifiquen el nombre de usuario de otra forma (por ejemplo, mediante una variable de entorno).

Nombre de la base de datos predeterminada

Establece el nombre de la base de datos VSS actual como se muestra en la barra de título del Explorador de VSS. Si no se define, en la barra de título del Explorador de VSS aparece "Explorador de Visual SourceSafe", sin el nombre de la base de datos.

Sugerencia Si tiene diferentes bases de datos de VSS, a menudo puede terminar ejecutando VSS sin saber a cuál está conectado. Puede utilizar la opción Nombre de la base de datos predeterminada para identificar de forma única la base de datos y en qué carpeta está la copia de VSS y puede incluir la carpeta o el nombre de recurso compartido con el nombre de la base de datos. Hay un límite de 31 caracteres para el nombre de la base de datos.

Nota Si desea utilizar el nombre de la base de datos antes de que alguien ejecute VSS o contenga usuarios, elimine la lista del su registro HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SourceSafe\Databases y comience entonces una nueva sesión de VSS.

Expandir palabras clave en archivos de tipo

Indica en qué archivos utilizar la expansión de palabras clave. De forma predeterminada, VSS no explora los archivos en busca de expansión de palabras clave cuando ejecuta los comandos Proteger o Agregar.

Registrar todas las acciones en el archivo de diario

Establece el archivo donde se registran todos los comandos de VSS que modifican datos almacenados. (Los comandos que no modifican datos en la base de datos de SourceSafe no se registran.) Si selecciona esta opción, el archivo especificado es un archivo de texto que muestra todas las acciones de VSS que realiza el usuario.

Aceptar

Confirma las selecciones.

Cancelar

Cancela las selecciones.


Opciones de la ficha Seguridad del proyecto

Vea también

Controla la seguridad de un proyecto de VSS. Utilice esta ficha para activar o desactivar la seguridad; si la seguridad está activada, puede establecer los derechos de acceso predeterminados de los usuarios.

Comentarios

Su primera decisión es si debe activar la seguridad del proyecto. Si la casilla de verificación Activar seguridad del proyecto está desactivada, la seguridad de proyecto está desactivada (la seguridad predeterminada de VSS está siempre operativa). Si la casilla de verificación Activar seguridad del proyecto está activada, puede establecer los derechos de acceso de los nuevos usuarios que se agreguen a la lista de usuarios del Administrador de VSS. El comando Agregar usuario del menú Usuarios agrega usuarios a la lista.

Por ejemplo, si las casillas de verificación Leer, Desproteger, Proteger, Agregar, Cambiar nombre o Eliminar están activadas, los nuevos usuarios tienen el derecho de acceso Agregar en el proyecto raíz (y, por tanto, en todos los proyectos) de forma predeterminada. Puede cambiar estos derechos en cualquier proyecto mediante los comandos Derechos por proyecto o Asignaciones de derechos para usuario.

Para mostrar la ficha Seguridad del proyecto:

  • En el menú Herramientas, haga clic en Opciones y, después, haga clic en la ficha Seguridad del proyecto.

Opciones de la ficha

Activar seguridad del proyecto

Activa el sistema de seguridad del proyecto, que proporciona los cuatro niveles de derechos de acceso mostrados a continuación.

Leer

Permite al usuario ver copias de sólo lectura de los archivos.

Desproteger/Proteger

Permite al usuario utilizar los comandos Desproteger y Proteger, pero no le permite cambiar el nombre, agregar y eliminar archivos o proyectos y así sucesivamente.

Agregar/Cambiar nombre/Eliminar

Permite al usuario utilizar los comandos Agregar, Cambiar nombre, Eliminar, Desproteger y Proteger pero no le permite realizar acciones que destruyan de forma permanente archivos o proyectos.

Destruir

Permite al usuario utilizar todos los comandos de VSS. Es igual a los derechos de acceso de lectura y escritura en el sistema de seguridad predeterminado.


Carpetas centrales (Opciones de la ficha)

Vea también

Establece las carpetas centrales.

Comentarios

Utilice la opción Establecer la carpeta central para el proyecto con el fin de especificar un proyecto. Una vez especificado, todas las demás opciones de la ficha se aplicarán sólo al proyecto especificado.

Para mostrar la ficha Carpetas centrales:

  • En el menú Herramientas, haga clic en Opciones y, después, haga clic en la ficha Carpetas centrales.

Opciones del cuadro de diálogo

Establecer la carpeta central para el proyecto

Especifica el proyecto en el que desea establecer la carpeta central. Haga clic en Examinar para examinar la base de datos de VSS en busca del proyecto que desea. Después de que haya especificado el nombre del proyecto, cualquier información acerca de las carpetas centrales existentes se muestra en los campos restantes de la ficha. Recuerde que la configuración central de un determinado proyecto se puede establecer explícitamente o se hereda de sus proyectos primarios.

Establecer la carpeta central en

Especifica la carpeta central. Puede ser cualquier carpeta de la red, pero en la mayoría de los casos está en el servidor con la base de datos de VSS. Haga clic en Examinar para buscar en el sistema de archivos una ubicación adecuada.

Establecer otra

Aplica la carpeta central especificada en los demás campos de este cuadro de diálogo y borra el cuadro de diálogo para que pueda establecer otra carpeta central. Este botón no está disponible a menos que haya especificado una carpeta y un proyecto válidos en los dos campos siguientes.

Establecer indicador de sólo lectura para todos los archivos

Controla si los archivos de la carpeta central son de sólo lectura.

Carácter de fin de línea para archivos

Establece el carácter de fin de línea utilizado en la carpeta central. Cuando VSS copia un archivo a la carpeta central, utiliza el carácter de fin de línea utilizado por su propio sistema operativo. Por ejemplo, VSS para Windows utiliza la combinación retorno de carro y salto de línea. En un entorno multiplataforma, los archivos de la carpeta central son una combinación de caracteres de fin de línea, basándose en el último sistema operativo en que se actualizó el archivo.

Esta configuración pasa por alto ese mecanismo, obligando a que todas las versiones de VSS utilicen el carácter de fin de línea especificado. Establezca este campo como AL para salto de línea (el valor predeterminado en UNIX), RC para retorno de carro o RC/AL para parejas de retorno de carro y salto de línea (valor predeterminado para Intel). Observe que los compiladores de Macintosh generalmente pueden aceptar parejas de retorno de carro y salto de línea, por lo que RC/AL es una buena opción para las instalaciones Intel-Macintosh.

Fecha y hora del archivo

Establece la marca de fecha y hora proporcionada a los archivos de la carpeta central.

De forma predeterminada, siempre que VSS coloca un archivo en la carpeta central, asigna a la fecha y hora del archivo la fecha y hora actuales.

Sin embargo, si asigna a esta variable el valor Modificación o Protección, VSS asignará al archivo de la carpeta central la fecha y hora que tenía el archivo la última vez que se modificó o protegió, respectivamente.

Aceptar

Confirma las selecciones y guarda la configuración central en el archivo SRCSAFE.INI.

Cancelar

Cancela las selecciones y vuelve al Administrador de VSS.


Web (Opciones de la ficha)

Vea también

Hay tres valores generales que se aplican a la vez a todos los proyectos Web de su base de datos de VSS. Dos de ellos se aplican a proyectos Web que se distribuyen mediante FTP a través de un servidor de seguridad y otro se aplica al comando Comprobar hipervínculos. Estos valores se establecen en la ficha Web. No confunda la ficha Web con la ficha Proyectos Web, que establece opciones para un determinado proyecto Web, no para todos los proyectos Web simultáneamente.

Proxy para distribuir sobre ftp

Si necesita distribuir de forma remota a través de un servidor de seguridad, utilice este campo para especificar un proxy. Establece la variable de inicialización Deploy_Proxy en el archivo SRCSAFE.INI.

No usar el proxy para estos servidores locales

Use este campo para especificar los servidores locales para los cuales el proxy no es apropiado porque están dentro de un servidor de seguridad. Establece la variable de inicialización Deploy_Host_Local en el archivo SRCSAFE.INI.

Nombre predeterminado para las páginas Web

Use este campo para especificar el nombre de archivo que VSS anexa a una dirección URL que termina con un nombre de carpeta durante la ejecución del comando Comprobar hipervínculos. El valor predeterminado es "Default.htm"; sólo necesita especificarlo si desea usar otro nombre diferente. Establece la variable de inicialización Web_Default_Filename en el archivo SRCSAFE.INI.

Aceptar

Confirma las selecciones y guarda los valores de Web en el archivo SRCSAFE.INI.

Cancelar

Cancela las selecciones y vuelve al Administrador de VSS.


Proyectos Web (Opciones de la ficha)

Vea también

Establece información que se aplica a los proyectos; es decir, proyectos que tienen archivos con significado para los exploradores de HTML. No confunda la ficha Proyectos Web con la ficha Web, que establece opciones para todos los proyectos Web de una vez, no para los proyectos Web individuales.

Comentarios

Use el cuadro de lista de arriba para especificar un proyecto de VSS existente como un proyecto Web. Una vez especificado, todas las demás opciones de la ficha (excepto la información de proxy, que es global) se aplicarán únicamente al proyecto especificado.

Para quitar de un proyecto la designación de proyecto Web, borre el contenido del campo Dirección URL y haga clic en Aceptar.

Para ver la ficha Proyectos Web:

  • En el menú Herramientas, haga clic en Opciones y, después, haga clic en la ficha Proyectos Web.

Opciones del cuadro de diálogo

Esta ficha contiene cinco campos de texto. El primer campo y uno o ambos de los campos Dirección URL y Raíz virtual deben completarse antes de poder designar un proyecto como proyecto Web. Los dos campos restantes son opcionales.

Este proyecto representa un sitio Web

Escriba en este campo el nombre del proyecto o utilice el botón Examinar para encontrar el proyecto. Todos los demás valores se aplican a este proyecto.

Dirección URL

Escriba en este campo la dirección del Localizador de recursos universal para el proyecto Web.

Raíz virtual

Cierto software de servidor Web lo acepta; si ha especificado una raíz virtual en el software servidor, debe especificarlo aquí, sin una barra oblicua inicial. Si escribe un valor en este campo se establecerá una variable Virtual_Root en el archivo SRCSAFE.INI. Las búsquedas comprueban el archivo SRCSAFE.INI para cualquier proyecto que tenga la raíz virtual especificada.

Nombre de archivo del mapa de sitios

Escriba en este campo el nombre del archivo que desea que VSS utilice cuando cree un mapa de sitios. (Si no especifica ningún valor, se usará de forma predeterminada Sitemap.htm.)

Cuando haya completado los campos de la ficha, haga que los clientes del proyecto Web salgan de VSS y reinicien. El Explorador de VSS mostrará el proyecto designado con un icono especial para indicar que se trata de un proyecto Web.

Nota Debe designar una dirección URL y una raíz virtual para el proyecto. Los demás campos son opcionales cuando el proyecto se designa como proyecto Web.

Ruta de distribución

Una ubicación de distribución puede estar en una unidad de disco duro del equipo o en otro lugar de una red de área local. Si una ruta de distribución es local, especifíquela con una letra de unidad o en formato UNC. Haga clic en el botón Examinar para buscar servidores de la red. Si escribe un valor en este campo establecerá una variable de inicialización Deploy_Path en el archivo SRCSAFE.INI.

Como alternativa, la ubicación puede ser remota, en cuyo caso se llegará a ella mediante el Protocolo de transferencia de archivos (FTP). Utilice el formato URL para especificar una ruta de acceso FTP. La ruta de acceso debe incluir la especificación de protocolo ("ftp://") y la ubicación. En este caso puede agregar un nombre de usuario o un nombre de usuario y una contraseña y, si es necesario, una ruta de acceso de carpeta. Separe el nombre de usuario y la contraseña con un signo de dos puntos (:). Puede especificar más de una ruta de acceso en este campo; separe las rutas de acceso mediante comas.

Por ejemplo:

ftp://www.trassi.com/

ftp://SamBal@www.trassi.com/ssafe

ftp://SamBal:baDJak@www.trassi.com/ssafe

ftp://www.trassi.com/ssafe,\\mi\servidor\ssafe

VSS almacena toda la ruta de acceso ftp en la variable Deploy_Path.

Nota Puede distribuir cualquier proyecto que se haya designado como proyecto Web, cualesquiera que sean los tipos de archivo que contiene. Un único comando envía todo el proyecto a la ubicación o ubicaciones remotas que haya especificado.

Puede especificar varias rutas de distribución en este cuadro, separadas por comas. Por ejemplo, puede establecer que cuando un usuario distribuya este sitio Web, vaya a su ubicación ftp y también a una carpeta de su servidor local.

Al definir una ruta para un sitio FTP, la información de la carpeta se obtiene de la raíz del servidor FTP. Al usar comandos típicos de FTP para PC o UNIX, no suele ser la sesión en el servidor FTP comenzando en la ruta particular que normalmente no es la raíz del servidor. Puede pensar que es una especie de raíz "particular".

Por ejemplo, si desea colocar un archivo en su sitio Web en Argentina, debe realizar los siguientes pasos:

  1. ftp://ftp.eos.ncsu.edu

  2. Escriba el nombre de usuario y su contraseña.

  3. Cambie a la carpeta temp (una subcarpeta).

  4. Use el comando de FTP "put" para escribir el archivo.

Para especificar esta ubicación en el cuadro de diálogo Distribuir, tiene que escribir lo siguiente:

ftp://usuario:contraseña@ftp.eos.ncsu.edu/usr/name/temp

Tenga en cuenta que es necesario especificar /usr/name/, ya que la distribución a FTP funciona desde la raíz del servidor y no desde la carpeta actual. Tenga en cuenta también que muchos sistemas usan el carácter tilde (~) para especificar la carpeta principal del usuario. Por tanto, tendrá que escribir lo siguiente (donde el servidor UNIX admita esta sintaxis de comandos):

ftp://usuario:contraseña@ftp.eos.ncsu.edu/~/temp

Además, debe tener cuidado cuando escriba el carácter "/". Por ejemplo, "cd ~/temp" es un comando de FTP válido pero "cd /~/temp" no lo es.

Establecer otra

Aplica la información de sitio Web especificada en los demás campos de este cuadro de diálogo y borra el cuadro de diálogo para que pueda establecer otro proyecto de sitio Web. Este botón no está activado a menos que haya especificado un proyecto y una dirección URL válidos en el campo de arriba.

Aceptar

Confirma las selecciones y guarda las opciones del sitio Web en el archivo SRCSAFE.INI.

Cancelar

Cancela las selecciones y vuelve al Administrador de VSS.

Para quitar la designación de proyecto Web

Borre los campos Dirección URL y Raíz virtual de esta ficha; después, haga clic en Aceptar.


Desproteger (Comando, menú SourceSafe)

Vea también

Copia la versión más reciente de uno o más archivos seleccionados del proyecto actual a su carpeta de trabajo.

Derechos de acceso

Debe disponer del derecho de acceso Desproteger para utilizar este comando. Debe tener una carpeta de trabajo establecida antes de utilizar este comando.

Comentarios

El comando Desproteger recupera archivos editables de VSS y los coloca en su carpeta de trabajo, de forma que pueda modificarlos. VSS muestra el archivo como desprotegido en el Explorador de VSS.

Nota Hay una diferencia importante entre los comandos Desproteger y Obtener la última versión. El comando Obtener última versión coloca una copia de sólo lectura de un archivo en su carpeta e trabajo. Desproteger coloca en el directorio de trabajo una copia del archivo en la que se puede escribir.

Para devolver el archivo a VSS, puede utilizar el comando Proteger para confirmar los cambios y copiar el archivo local modificado a la base de datos de VSS.

Nota También puede utilizar el comando Deshacer desproteger. Deshacer desproteger no actualiza VSS. En su lugar, copia la versión más reciente del archivo en VSS sobre su copia local, de forma que todos los cambios realizados en la copia local desde la última vez que la desprotegió se pierden. Además, el comando Deshacer desprotección cancela la desprotección y quita la versión editable del archivo de la carpeta de trabajo. Para mostrar un cuadro de diálogo cuando utilice el comando Deshacer desprotección, utilice la ficha Cuadros de diálogo de comandos del cuadro de diálogo Opciones de SourceSafe en el menú Herramientas.

Generalmente, sólo un usuario puede tener un archivo desprotegido para modificación en un momento dado. Sin embargo, si el administrador de VSS permite desprotecciones múltiples, varios usuarios podrán desproteger el mismo archivo a la vez. Cuando el primer usuario proteja el archivo en VSS, ese archivo se convertirá en la versión actual. Cuando los siguientes usuarios protejan sus copias locales, sus cambios se combinarán en el archivo y se creará una nueva versión en VSS. Los archivos en formato binario sólo los puede desproteger una persona cada vez.

También puede desproteger elementos de forma exclusiva; es decir, desprotegerlos de forma que nadie más pueda desprotegerlos mientras usted tenga el archivo o el proyecto desprotegido. El administrador de VSS puede establecer una opción administrativa para desactivar desprotecciones múltiples en todo un proyecto todo el tiempo o usted puede desactivar la casilla de verificación de opción avanzada Permitir varias desprotecciones del diálogo del comando Desproteger para que sólo se pueda desproteger un archivo por sesión.

Opciones del cuadro de diálogo

Si tiene activada la casilla de verificación Desproteger a nivel de archivo en la ficha Cuadros de diálogo de comandos del cuadro de diálogo Opciones (menú Herramientas), el comando Desproteger muestra el cuadro de diálogo Desproteger, que tiene las siguientes opciones. Hay una opción Recursivo adicional si se activa también la casilla de verificación Desproteger a nivel de proyecto:

Comentario

Describa brevemente la razón por la que desprotege el archivo. Mientras el archivo esté desprotegido, la ficha Estado de desprotección muestra este comentario. El límite para los comentarios de desprotección es 63 caracteres.

En

Muestra la carpeta de trabajo a la cual VSS copia el archivo. De forma predeterminada, VSS copia el archivo con su propio nombre de archivo en su carpeta de trabajo. Sin embargo, puede especificar una carpeta y un nombre de archivo diferentes o hacer clic en Examinar para seleccionar una ubicación diferente en su árbol de carpetas.

Recursivo (sólo al desproteger a nivel de proyecto)

Desprotege el proyecto y todos sus subproyectos.

Generar árbol: ignora carpetas de trabajo (sólo al desproteger a nivel de proyecto)

Ignora la carpeta de trabajo establecida en los subproyectos implicados en una operación recursiva y genera el árbol de proyecto que refleja la organización del proyecto en su equipo local. Se pasa por alto la configuración de carpeta de trabajo para los subproyectos individuales. Está disponible sólo cuando hace clic en la casilla de verificación Recursivo.

No obtener copia local

Indica a VSS que no copie el archivo a su carpeta de trabajo. VSS registra que el archivo se ha desprotegido, pero no escribe una nueva copia en la carpeta de trabajo.

Opciones avanzadas

También puede establecer los valores predeterminados para las tres primeras opciones de la ficha Archivos locales del cuadro de diálogo Opciones de SourceSafe (menú Herramientas).

Permitir varias desprotecciones

Permite que varios usuarios desprotejan simultáneamente este archivo o proyecto. Si hay otro usuario que ya tiene este archivo desprotegido, la casilla de verificación estará activada pero sin marca de verificación. Si se han desactivado las desprotecciones múltiples para este proyecto, la casilla de verificación estará desactivada y sin marca de verificación. Cuando se ha desprotegido en modo exclusivo un archivo o un proyecto, el icono del Explorador de VSS para dicho elemento está rodeado por un recuadro rojo.

Reemplazar modificable

Determina cómo se comporta VSS cuando intenta desproteger un archivo que ya está marcado como editable en la carpeta de trabajo. Seleccione una de las posibilidades siguientes en el cuadro de lista:

  • Preguntar. Le pregunta qué hacer cuando se encuentre una versión editable de un archivo.

  • Reemplazar. Reemplaza el archivo editable con una versión de sólo lectura.

  • Saltar. No realiza la operación de desprotección para el archivo editable. Se muestra un error en la ventana Resultados, si está abierta.

  • Combinar. Combina los cambios entre el archivo editable y el que está desprotegiendo ahora. Si el archivo no puede combinarse (por ejemplo, es un archivo binario), se salta la operación de desprotección para ese archivo y se muestra un error en la ventana Resultados, si está abierta.

  • Predeterminado. Utiliza los valores predeterminados de la ficha Archivos locales o los heredados de un proyecto primario. No puede establecer esta opción; se utiliza automáticamente cuando se seleccionan explícitamente (en la lista de archivos) o implícitamente (activando Recursivo) múltiples archivos.

Establecer hora de archivo

Cambia la fecha asociada a la operación de desprotección. Seleccione una de las posibilidades siguientes en el cuadro de lista: hora actual, hora de la última modificación del archivo, hora de la última protección del archivo o la hora predeterminada (establecida en la ficha Archivos locales).

Mostrar sólo cuando se presiona Máyus

Salta este cuadro de diálogo durante operaciones de desprotección futuras y, de forma predeterminada. utiliza la configuración que ha especificado. Para restaurar el cuadro de diálogo, desactive la casilla de verificación correspondiente en la ficha Diálogos de comandos del cuadro de diálogo Opciones de SourceSafe. Si presiona la tecla MAYÚSCULAS al hacer clic en el comando Desproteger se muestra este cuadro de diálogo, sin tener en cuenta la configuración de la ficha Cuadros de diálogo de comandos.


Estado de desprotección (Ficha, cuadro de diálogo Propiedades )

Vea también

Muestra información de desprotección acerca de un archivo de VSS.

Para ver la ficha Estado de desprotección

  1. Haga clic en un archivo del panel de archivos del Explorador de VSS.

  2. En el menú Archivo, elija Propiedades y después elija la ficha Estado de desprotección.

Derechos de acceso

Debe disponer del derecho de acceso Leer para utilizar esta ficha.

Comentarios

Si más de un usuario tiene un archivo desprotegido, al hacer clic en Estado de desprotección se muestra una lista de todas las desprotecciones. Haga doble clic en una determinada desprotección para ver los detalles de esa desprotección. También puede proteger un archivo o deshacer la desprotección de un archivo.

Si el archivo seleccionado no se ha desprotegido, cuando elija Estado de desprotección VSS indicará que el archivo no está desprotegido y no mostrará las opciones de la ficha.

Opciones de la ficha

Nombre

Nombre del archivo seleccionado.

Por

Usuario que desprotegió el archivo seleccionado.

Fecha

Fecha y hora en que se desprotegió el archivo seleccionado.

Versión

Número de versión del archivo seleccionado.

Equipo

Nombre del equipo desde el que se desprotegió este archivo.

Carpeta

Carpeta de trabajo en la que está el archivo desprotegido.

Proyecto

Nombre del proyecto en el que está el archivo.

Desprotección exclusiva

Si aparece debajo del nombre, significa que el archivo o el proyecto está desprotegido exclusivamente para un usuario.

Comentario

Comentario que se especificó para el archivo. Es posible modificar o agregar un nuevo comentario en este cuadro de texto, con la condición de que no supere los 64 caracteres.

Cerrar

Cierra el cuadro de diálogo Propiedades y vuelve al Explorador de VSS.

Informe

Envía un informe al Portapapeles, a un archivo o a una impresora.


Desprotegidos (Cuadro de diálogo)

Muestra las distintas ubicaciones en las que tiene desprotegido un archivo.

Para ver el cuadro de diálogo Desprotecciones

  • En el menú Archivo, haga clic en Propiedades de archivo y seleccione la ficha Lista de desprotegidos.

Opciones del cuadro de diálogo

Desprotegidos

Enumera las ubicaciones en las que está desprotegido el archivo.

Detalles

Muestra los detalles del archivo seleccionado.

Proteger

Protege el archivo seleccionado.

Deshacer Desproteger

Deshace la desprotección del archivo seleccionado.

Cerrar

Cierra el cuadro de diálogo y cancela el comando.


Crear proyecto (Comando, menú Archivo)

Vea también

Crea un nuevo subproyecto bajo el proyecto seleccionado actualmente.

Derechos de acceso

Debe disponer del derecho de acceso Agregar en el proyecto primario para utilizar este comando.

Comentarios

Utilice el comando Crear proyecto para crear un subproyecto bajo el proyecto actual de VSS. El subproyecto está vacío hasta que coloque archivos u otros subproyectos en él. Todos los derechos de usuario que tenga en el proyecto primario se propagan al proyecto recién creado.

Opciones del cuadro de diálogo

Proyecto

Escriba un nombre para el nuevo proyecto.

Comentario

Escriba una breve descripción del proyecto.


Obtener en el diálogo del archivo desprotegido

Este mensaje tiene la siguiente causa y solución:

  • Eligió obtener un archivo que ya estaba desprotegido.

    Cuando obtiene un archivo, se escribe una nueva copia del mismo a su carpeta de trabajo. Si ya tiene el archivo desprotegido, puede que se sobrescriban algunos cambios. En esta situación, VSS le da varias opciones:

    • Haga clic en Reemplazar para sobrescribir el archivo de la carpeta de trabajo.

    • Haga clic en Combinar para combinar los cambios del archivo de la carpeta de trabajo en el archivo de base de datos VSS.

    • Haga clic en Mantener para dejar el archivo de la carpeta de trabajo (se pasará por alto el comando Obtener para dicho archivo).

    • Haga clic en Cancelar para cancelar la operación Obtener.

    • Haga clic en Aplicar a todos los elementos para que las decisiones que ha tomado en este cuadro de diálogo se apliquen a todos los demás archivos que tiene desprotegidos.


Examinar la base de datos de Visual SourceSafe (Cuadro de diálogo)

Vea también

Permite nombrar una base de datos de VSS.

Opciones del cuadro de diálogo

Ruta de la base de datos

Especifica la ruta para la base de datos seleccionada. No puede cambiar este valor aquí.

Nombre de la base de datos

Especifica el nombre amigable que desea dar a esta base de datos. Dicho nombre aparece en el cuadro de diálogo Abrir base de datos de SourceSafe.

Aceptar

Confirma sus selecciones.

Cancelar

Cancela sus selecciones.


Tipos de archivos (Ficha Opciones)

Existen dos fichas de opciones de tipos de archivo disponibles, una para el usuario de VSS y la otra para el administrador de VSS.

Seleccione una de las posibilidades siguientes:

  • Administrador de VSS - Ficha opciones de tipos de archivo

  • Usuario de VSS - Ficha opciones de tipos de archivo


Tipos de archivo - Administrador VSS (Ficha)

Vea también

Establece las opciones relativas a los tipos de archivo que los usuarios almacenan en VSS.

Comentarios

Muchos de los cuadros de diálogo de VSS contienen listas de archivos que permiten a los usuarios seleccionar varios archivos para una operación determinada. Utilice esta ficha para filtrar estas listas de archivos de forma que tengan más sentido de acuerdo con el tipo de trabajo que realicen los usuarios. Por ejemplo, si sus usuarios son desarrolladores de Microsoft Visual C++, puede que quieran guardar archivos .c, .h, .obj, y .exe en VSS. Por otra parte, si son programadores de Microsoft Visual Basic, preferirán archivos .mak y .frm.

Para mostrar la ficha Tipos de archivos:

  • En el menú Herramientas, haga clic en Opciones y, después, haga clic en la ficha Tipos de archivo.

Opciones del cuadro de diálogo

Archivos binarios

Pasa por alto la detección automática de archivos de texto y binarios de VSS e indica que ciertos tipos de archivo son siempre binarios. Por ejemplo, puede especificar en este cuadro *.obj, *.xls, *.frx para especificar que todos los archivos de objeto, las hojas de cálculo de Microsoft Excel y los archivos .frx de Microsoft Visual Basic deben tratarse como archivos binarios.

Grupos de archivos

Agrupa tipos de archivos según el tipo de trabajo de los usuarios, junto con la opción Tipos de archivo incluidos en grupo de archivos. Estos grupos se muestran en Mostrar archivos de tipo en muchos de los cuadros de diálogo de VSS, de modo que pueda especificar grupos que filtren de forma eficiente para sus usuarios la lista de archivos.

Agregar

Agrega a la lista un nuevo grupo de tipos de archivos. En el cuadro de diálogo Agregar grupo de archivos, escriba un nombre para el nuevo grupo de archivos que desee agregar, como "VC" o "VB".

Eliminar

Elimina el grupo seleccionado actualmente.

Tipos de archivo incluidos en grupo de archivos

Muestra la lista de los tipos de archivo incluidos en el grupo de archivos seleccionado actualmente en Grupos de archivos. Para modificar un grupo específico, seleccione el grupo en Grupos de archivos y agregue o elimine las extensiones en este cuadro.

Aceptar

Confirma las selecciones.

Cancelar

Cancela las selecciones.


Tipos de archivos (Ficha Opciones, usuario de VSS)

Vea también

Establece opciones relacionadas con el tipo de los archivos que almacena en VSS.

Para mostrar la ficha Tipos de archivos:

  • En el menú Herramientas haga clic en Opciones y a continuación en la ficha Tipos de archivos.

Derechos de acceso

Cualquier usuario de VSS puede utilizar esta ficha.

Comentarios

Muchos de los cuadros de diálogo de VSS contienen listas de archivos que le permiten seleccionar archivos múltiples para una operación específica. Utilice esta ficha para filtrar estas listas de archivos de forma que tengan más sentido para el tipo de trabajo que realice. Por ejemplo, si es un desarrollador de C++, es posible que quiera guardar archivos .CPP, .H, .RC, y .BMP en VSS. Por otro lado, si es un programador en Visual Basic, puede preferir almacenar archivos .VBP y .FRM. Es posible usar la ficha con el fin de restringir las listas de archivos y mostrar solamente esos tipos de archivos en lugar de todos los de una carpeta específica.

Opciones de la ficha

Archivos binarios

Modifica la detección automática de VSS de los archivos de texto y binarios con el fin de permitirle considerar siempre algunos tipos de archivos como binarios. Por ejemplo, puede escribir *.OBJ, *.XLS, *.FRX en este campo con el fin de especificar que todos los archivos de objeto, las hojas de cálculo de Microsoft Excel y los archivos .FRX de Visual Basic siempre deben considerarse como archivos binarios.

Crear archivo SCC

Esta casilla sólo sirve para los usuarios de Visual Basic. Cuando trabaja con un proyecto de Visual Basic en VSS, se crea un archivo especial en su carpeta de trabajo llamado MSSCCPRJ.SCC. Este archivo nunca puede ser agregado a VSS: permanece en su carpeta de trabajo y almacena información importante utilizada para la integración de VSS en Visual Basic.

La opción Crear archivo SCC determina cuándo VSS debe crear este archivo. Su valor predeterminado (*.VBP, *.MAK) significa que siempre que obtenga o agrege un archivo con una extensión .VBP (archivo de proyecto de Visual Basic 4.0) o .MAK (utilizado por las versiones anteriores de Visual Basic), VSS creará el archivo MSSCCPRJ.SCC. Este archivo es muy importante, ya que sin él la integración de VSS en Visual Basic no funcionará correctamente.

Por su lado, Visual C++ y los otros entornos de desarrollo no utilizan este archivo para nada. Puede que no le interese mostrar este archivo inservible en su carpeta de Visual C++. Para impedir que aparezca el archivo MSSCCPRJ.SCC en su carpeta de Visual C++, elimine el archivo *.MAK de este campo. (Conviene hacer este cambio tan sólo si no utiliza archivos .MAK de Visual Basic 3.0)

Grupos de archivos

Junto con la opción "Tipos de archivo incluidos en grupo de archivos", esta opción permite agrupar tipos de archivos en agrupaciones lógicas. Estos grupos se muestran en las opciones Mostrar archivos de tipo de muchos de los cuadros de diálogo de VSS con el fin de especificar grupos que filtren eficientemente la lista de archivos durante su trabajo.

Utilice el botón Agregar para agregar un nuevo grupo de extensiones a la lista, y el botón Eliminar para eliminar el grupo actualmente seleccionado. El ejemplo siguiente podría crear grupos de archivos que incluyen archivos .FRM y .BAS pero excluyen explícitamente el archivo HELP.FRM:

*.frm; *.bas; !HELP.FRM

El grupo de archivos <Máscaras relevantes> es un caso especial. No es posible eliminar este grupo y sirve para indicar qué archivos podría colocar en un proyecto típico. Esto no le impide colocar otros archivos dentro del proyecto; sin embargo tiene efectos potencialmente útiles.

  1. Si agrega a VSS una carpeta completa con un único comando (al escribir ss add * en la línea de comandos de VSS o al arrastrar una carpeta desde el Administrador de archivos dentro de VSS), tan solo se agregan los archivos que coinciden con las máscaras relevantes. Es posible agregar otros archivos individualmente.

  2. Cuando ejecuta el comando de VSS Mostrar diferencias a nivel de proyecto con el fin de comparar el proyecto actual con su carpeta de trabajo, no se muestran como diferencias los archivos que no coinciden con las máscaras relevantes.

  3. La máscaras relevantes se utilizan como opción predeterminada en Agregar archivos de tipo en el cuadro de diálogo Agregar archivos; por consiguiente, tan sólo se muestran esos archivos de forma predeterminada.

Tipos de archivo incluidos en grupo de archivos

Muestra la lista de los tipos de archivo (sus extensiones) incluidos en el grupo de archivos actualmente seleccionado en Grupos de archivos. Para modificar un grupo específico, seleccione el grupo bajo Grupos de archivos y a continuación agregue o elimine extensiones.

Agregar

Agregue un nuevo grupo de extensiones de archivo a la lista Grupos de archivos.

Eliminar

Elimina el Grupo de archivos actualmente seleccionado.


Deshacer desprotección (Comando, menú SourceSafe)

Vea también

Cancela una operación Desproteger, y deshace todos los cambios. Debe tener establecida una carpeta de trabajo para que este comando funcione correctamente.

Derechos de acceso

Debe disponer del derecho de acceso Desproteger para utilizar este comando.

Comentarios

El comando Deshacer desprotección deshace todos los cambios; el archivo ya no está desprotegido por usted, pero en lugar de actualizar VSS con la copia modificada, Deshacer desprotección conserva la versión que VSS tenía previamente y la copia sobre el archivo en su carpeta de trabajo.

Puede utilizar el comando Deshacer Desproteger únicamente en los archivos que tiene desprotegidos actualmente, pero no en archivos desprotegidos por otros usuarios.

Nota Su administrador de VSS puede deshacer la desprotección de otro usuario. Consulte el capítulo 8, "Administración", del Manual del usuario de Visual SourceSafe si desea más información al respecto.

Opciones del cuadro de diálogo

Importante Las siguientes opciones son exclusivas de VSS. Access u otros productos integrados pueden tener opciones diferentes.

Nota Active la presentación de este cuadro de diálogo en la ficha Cuadros de diálogo de comandos del cuadro de diálogo Opciones de SourceSafe (menú Herramientas).

Copia local

  • Reemplazar: reemplaza el archivo de la carpeta de trabajo. VSS ejecuta el comando Obtener la última versión sobre el archivo. Esto mantiene la sincronización de su carpeta de trabajo con el contenido del proyecto, al pasar por alto todas sus modificaciones.

  • Eliminar: Elimina el archivo en su carpeta de trabajo.

  • Dejar: No toca el archivo aislado.

    Predeterminado utiliza el valor predeterminado establecido en la ficha Archivos locales o el heredado de un proyecto primario. Esta opción no puede configurarse; se utiliza automáticamente cuando de forma explícita (en la lista de archivos) o implícita (activando Recursivo) selecciona múltiples archivos.

Mostrar sólo cuando se presiona Máyus

Salta este cuadro de diálogo en las operaciones Deshacer Desproteger futuras y utiliza los valores que estableció como predeterminados. Para restaurar el cuadro de diálogo, haga clic en la casilla de verificación apropiada de la ficha Cuadros de diálogo de comandos en el cuadro de diálogo Opciones de SourceSafe.

Recursivo (sólo para deshacer desprotecciones a nivel de proyecto)

Deshace la desprotección de todos los archivos en el proyecto seleccionado, con todos los archivos de todos sus proyectos secundarios.

Modificar (sólo para deshacer desprotecciones a nivel de proyecto)

Modifica el conjunto de carpetas de trabajo a las que se aplica una operación recursiva. Esto es útil si tiene archivos desprotegidos en más de un proyecto y desea deshacer la desprotección de todos ellos al mismo tiempo. Está disponible sólo cuando hace clic en la casilla de verificación Recursivo.


Informe de archivos (Comando, menú Herramientas)

Crea un informe con formato del proyecto actual e información de archivo que puede enviar al Portapapeles, a un archivo o a una impresora.

Derechos de acceso

Debe disponer del derecho de acceso Leer para utilizar este comando.

Comentarios

Puede preparar un informe que contenga una relación de todos los archivos del proyecto actual. (El informe incluye sólo los archivos y subproyectos que están actualmente en el proyecto, no los archivos o subproyectos eliminados.) El comando Informe de archivos es útil para proyectos grandes para los cuales el Explorador de VSS puede que no sea capaz de mostrar todos los nombres de archivo en la pantalla de una vez.

Nota Las opciones del cuadro de diálogo varían dependiendo de si tiene un archivo o un proyecto seleccionado en el Explorador de VSS.

Opciones del cuadro de diálogo

Todos los archivos mostrados (sólo disponible cuando hay un archivo seleccionado)

Incluye todos los archivos mostrados en el panel de archivos del Explorador de VSS.

Archivos seleccionados (sólo disponible cuando hay un archivo seleccionado)

Crea un informe sólo con los archivos seleccionados.

Recursivo (sólo disponible cuando hay un proyecto seleccionado)

Crea un informe que incluye información de los subproyectos del proyecto actual.

Incluir archivos (sólo disponible cuando hay un proyecto seleccionado)

Crea un informe que incluye los nombre de los archivos que forman parte del proyecto.

Sólo nombres de archivos

Crea un informe que incluye sólo los nombres de archivo. Si este cuadro no está activado, el informe de archivo incluirá cuatro columnas en lugar de mostrar sólo una para el nombre de archivo. Las cuatro columnas son Nombre de archivo, Nombre de usuario, Fecha y hora y Carpeta de desprotección (como en el Explorador de SourceSafe). La columna Nombre de archivo acepta nombres de archivo largos, los cuales pueden ajustarse a la columna como sea necesario.

Imprimir en

  • Impresora: Envía el informe a una impresora.

  • Archivo: Envía el informe al cuadro de diálogo Archivo.

  • Portapapeles: Coloca el informe en el Portapapeles.

Aceptar

Confirma la selección.

Cancelar

Cancela el informe.

Vista previa

Muestra una presentación previa del informe.


Obtener la última versión (Comando, menú SourceSafe)

Vea también

Recupera una copia de sólo lectura de los elementos seleccionados de VSS. Para obtener la versión más reciente, haga clic en Obtener la última versión en el menú SourceSafe. Para obtener una versión más antigua, haga clic en Obtener en el cuadro de diálogo Historial de archivo o Historial de proyecto.

Derechos de acceso

Debe disponer del derecho de acceso Leer para utilizar este comando. Debe tener una carpeta de trabajo establecida antes de utilizar este comando.

Comentarios

El comando Obtener la última versión recupera la versión más reciente de un archivo, un grupo de archivos o un proyecto completo de VSS y crea copias de sólo lectura para ver o compilar en su carpeta de trabajo.

Nota Puede elegir una carpeta de trabajo diferente para la operación Obtener actual si escribe una nueva ruta de acceso en el cuadro de diálogo Obtener la última versión. Haga clic en Examinar para desplazarse y elegir su carpeta.

La obtención de un archivo no reemplaza el archivo que ha desprotegido actualmente en su carpeta de trabajo, a menos que establezca la opción avanzada Reemplazar.

Resultado de una operación Obtener

Utilizar el comando Obtener la última versión tiene cuatro resultados posibles:

  • Si el archivo que está recuperando no se encuentra ya en su carpeta de trabajo, VSS simplemente obtiene el archivo.

  • Cuando el archivo de la carpeta de trabajo es idéntico al archivo que está recuperando, VSS no lo recupera o modifica de ninguna forma.

  • Cuando el archivo de la carpeta de trabajo es diferente de la copia maestra de VSS y su copia local es de sólo lectura, VSS reemplaza su copia local.

  • Cuando el archivo de la carpeta de trabajo no es de sólo lectura, VSS asume que tiene el archivo desprotegido y no lo reemplaza. Puede cambiar el comportamiento de VSS en este caso con la opción Reemplazar archivos modificables de la ficha Archivos locales del cuadro de diálogo Opciones.

Combinar con el comando Obtener la última versión

En una situación de desprotección múltiple, puede utilizar el comando Obtener la última versión para recuperar los cambios de otros usuarios antes de proteger su versión del archivo. Puede indicar a VSS que combine los cambios en la copia local del archivo o puede especificar que desea comprobar cada cambio antes de permitir la combinación. Para ello, establezca la opción Reemplazar archivos modificables a Combinar en la ficha Archivos locales del cuadro de diálogo Opciones de SourceSafe.

Opciones del cuadro de diálogo

Si activa el cuadro de diálogo del comando Obtener la última versión en la ficha Cuadros de diálogo de comandos del cuadro de diálogo Opciones de SourceSafe (menú Herramientas) o presiona la tecla MAYÚSCULAS al hacer clic en el comando Obtener la última versión, tiene las siguientes opciones:

En

Escriba la ruta de acceso en la que desea que VSS coloque los archivos.

Recursivo (sólo al Obtener a nivel de proyecto)

Obtiene un proyecto, todos los archivos del proyecto y sus subproyectos. Se copia cada archivo de un subproyecto a su propia carpeta de trabajo, que puede ser una carpeta situada en cualquier lugar de su equipo o de un equipo accesible remoto. Para invalidar la configuración de la carpeta de trabajo y crear una estructura de archivos idéntica a la estructura del proyecto de SourceSafe, utilice la opción Generar árbol.

Generar árbol: ignora carpetas de trabajo (sólo al Obtener a nivel de proyecto)

Invalida la carpeta de trabajo establecida para los subproyectos implicados en una operación recursiva y genera en su equipo local un árbol de proyecto que refleja la organización del proyecto. Se pasa por alto la configuración de carpeta de trabajo para los subproyectos individuales. Está disponible sólo cuando hace clic en la casilla de verificación Recursivo.

Crear modificable

Establece el indicador de lectura-escritura de forma que el archivo sea editable. No es el comportamiento predeterminado, pero puede resultar útil si desea probar un cambio temporal en el archivo o desea cambiar el nombre del archivo después de obtenerlo.

Opciones avanzadas

También puede establecer los valores predeterminados para las tres primeras opciones avanzadas de la ficha Archivos locales del cuadro de diálogo Opciones de SourceSafe (menú Herramientas).

Establecer hora de archivo

Cambia la hora asignada a la operación de obtención. Seleccione una de las posibilidades siguientes en el cuadro de lista: hora actual, hora de la última modificación del archivo, hora de la última protección del archivo o la hora predeterminada (establecida en la ficha Archivos locales).

Reemplazar modificable

Determina cómo se comporta VSS cuando intenta obtener un archivo que ya está marcado como editable en su carpeta de trabajo. Seleccione una de las posibilidades siguientes en el cuadro de lista:

  • Preguntar. Le pregunta qué hacer cuando se encuentre una versión editable de un archivo.

  • Reemplazar. Reemplaza el archivo editable con una versión de sólo lectura.

  • Saltar. Salta la operación de obtención para el archivo editable. Se muestra un error en la ventana Resultados, si está abierta.

  • Combinar. Combina los cambios entre el archivo desprotegido y el que está obteniendo. Si el archivo no puede combinarse (por ejemplo, si es un archivo binario), la operación de obtención se salta para ese archivo y se muestra un error en la ventana Resultados, si está abierta.

  • Predeterminado. Utiliza los valores predeterminados de la ficha Archivos locales o los heredados de un proyecto primario.

Mostrar sólo cuando se presiona Máyus

Salta este cuadro de diálogo durante futuras operaciones de obtención y utiliza la configuración que ha introducido como predeterminada. Para restaurar el cuadro de diálogo, desactive la casilla de verificación correspondiente en la ficha Diálogos de comandos del cuadro de diálogo Opciones de SourceSafe. Si presiona la tecla MAYÚSCULAS al hacer clic en el comando Obtener la última versión se muestra este cuadro de diálogo, sin tener en cuenta la configuración de la ficha Cuadros de diálogo de comandos.


Ir a (Cuadro de diálogo)

Salta a una posición especificada de un archivo.

Para ver el cuadro de diálogo Ir a:

  1. Haga clic en un archivo del panel de archivos del Explorador de VSS.

  2. En el menú Herramientas, haga clic en Mostrar diferencias y, en el cuadro de diálogo Opciones de diferencias, haga clic en Aceptar.

    Nota Active la presentación del cuadro de diálogo Opciones de diferencia en la ficha Diálogos de comandos del cuadro de diálogo Opciones de SourceSafe (menú Herramientas).

  3. En el cuadro de diálogo Diferencias de archivo, haga clic en Informe.

  4. En el cuadro de diálogo Informe de diferencias de archivo, haga clic en Vista previa.

  5. Presione Alt-G.

Opciones del cuadro de diálogo

Ir a

Seleccione el tipo de elemento al que desea ir. Habrá diferentes opciones disponibles dependiendo de la operación que vaya a realizar, por ejemplo, puede ir a un marcador, conflicto, diferencia, línea o desplazamiento (el número de bytes totales contados desde el principio del archivo). Quizá desee utilizar Desplazamiento si está recibiendo un error durante la carga a partir de un cierto byte o si tiene un archivo con una longitud de bytes fija y necesita encontrar un determinado byte dentro del archivo.

Número de línea

Escriba la posición a la que desea ir. (La posición es relativa al tipo especificado en el cuadro Ir a.)

Ir a

Se dirige a la ubicación especificada.

Anterior

Se dirige al elemento anterior del tipo especificado en el campo Ir a.

Cerrar

Cancela el comando Ir a.


Opciones de historial de archivos/proyectos (Cuadro de diálogo)

Le permite especificar opciones para presentar el historial del proyecto.

Opciones del cuadro de diálogo

Incluir historiales de archivos (sólo para historiales de proyectos)

Incluye archivos en el historial del proyecto.

Recursivo (sólo para historiales de proyectos)

Incluye subproyectos y todos los archivos que contienen.

Sólo etiquetas

Sólo incluye etiquetas en el historial del proyecto si ha seleccionado la opción Incluir etiquetas. Puede utilizar esta casilla de verificación con los campos Desde y En para buscar todos los proyectos que tienen la etiqueta designada, pero no buscará los archivos de esos proyectos que tengan las etiquetas designadas.

Desde

Restringe el informe de historial al principio de la fecha especificada. Escriba una fecha, fecha y hora, versión o etiqueta. Utilice el prefijo D para indicar una fecha o fecha y hora, y el prefijo L para indicar una etiqueta. Por ejemplo "D02/29/95;12:15" o "Lbeta1". Las fechas pueden especificarse en el formato 08.15.95, 08-15-95 u 08/15/95, pero no como 15 de agosto de 1995.

En

Restringe el informe de historial al final de la fecha especificada. Escriba una fecha, fecha y hora, versión o etiqueta. Utilice el prefijo D para indicar una fecha o fecha y hora, y el prefijo L para indicar una etiqueta. Por ejemplo "D02/29/95;12:15" o "Lbeta1". Las fechas pueden especificarse en el formato 08.15.95, 08-15-95 u 08/15/95, pero no como 15 de agosto de 1995.

Usuario

Muestra un historial de los archivos en los que ha trabajado el usuario especificado.

Aceptar

Muestra el cuadro de diálogo Historial de proyecto. En este cuadro de diálogo, haga clic en cualquiera de los elementos de la lista y, después, haga clic en Detalles para mostrar el cuadro de diálogo Detalles de historial. Desde el cuadro de diálogo Detalles de historial, puede hacer clic en los botones Siguiente y Anterior para desplazarse hacia arriba y hacia abajo por la pantalla del historial. También puede modificar el comentario y la etiqueta asociados con la versión que está viendo.

Mostrar sólo cuando se presiona Mayús

Salta este cuadro de diálogo en las futuras operaciones de Mostrar historial y utiliza los valores especificados como predeterminados. Para restaurar el cuadro de diálogo, haga clic en la casilla de verificación apropiada de la ficha Diálogos de comandos del cuadro de diálogo Opciones de SourceSafe.


Informe de historial (Cuadro de diálogo)

Vea también

Envía un informe con la información del historial de un archivo o de un proyecto a una impresora, a un archivo o al Portapapeles.

Para mostrar el cuadro de diálogo Informe de historial:

  1. Seleccione un archivo o un proyecto en el Explorador de VSS y, en el menú Herramientas, haga clic en Mostrar historial.

  2. Si está habilitado, haga selecciones en el cuadro de diálogo Opciones del historial de archivo u Opciones del historial del proyecto y haga clic en Aceptar.

    Nota Active la presentación del cuadro de diálogo Opciones de historial en la ficha Diálogos de comandos del cuadro de diálogo Opciones de SourceSafe (menú Herramientas).

  3. En el cuadro de diálogo Historial de archivo o Historial de proyecto, haga clic en Informe.

Opciones del cuadro de diálogo

Incluir detalles

Incluye todos los detalles del historial de los archivos seleccionados en el informe. Los detalles incluyen la fecha de creación, el usuario que modificó el archivo en cada protección, los comentarios adjuntos al archivo y la información de hora y fecha de cada evento.

Incluir diferencias

Utilice esta opción cuando compara dos versiones diferentes de un archivo o de un proyecto. El informe incluye las diferencias entre los archivos o los proyectos seleccionados.

Imprimir en

Envía el informe de historial a una impresora, a un archivo o al Portapapeles.

Aceptar

Prepara el informe especificado.

Cancelar

Cancela el informe.

Vista previa

Muestra una vista previa del informe especificado, de forma que pueda determinar si es lo que deseaba antes de realizarlo y enviarlo a la cola de impresión o a un archivo.


Etiqueta (Comando, menú Archivo)

Vea también

Asigna una etiqueta a la versión especificada o a la versión actual de un archivo o un proyecto.

Derechos de acceso

Debe disponer del derecho de acceso Agregar para utilizar este comando.

Comentarios

Cada versión de un archivo tiene un número de versión y una fecha y hora, y puede recuperarse por referencia a cualquiera de ellas. Para facilitar la identificación de una versión, puede asignarle una etiqueta (cualquier cadena de hasta 31 caracteres de longitud) y referirse a la versión por su etiqueta.

Con el comando Etiqueta se crea la nueva versión del archivo o proyecto seleccionado y la etiqueta se asocia a esa versión.

Nota Para cambiar la etiqueta de una versión anterior, cuando un archivo se selecciona en el panel de archivos del Explorador de VSS, en el menú Herramientas, haga clic en Mostrar historial y después haga clic en Detalles.

Al modificar una etiqueta en el cuadro de diálogo Detalles de historial, está asignando una etiqueta a una versión ya existente del elemento especificado.

Si desea identificar una determinada versión de un proyecto de forma que pueda volver a ella, no asigne una etiqueta a cada archivo del proyecto; mejor asigne la etiqueta al propio proyecto. Incluso si agrega, elimina y cambia el nombre de los archivos en el futuro, VSS puede restaurar exactamente esa versión del proyecto basándose en la etiqueta del proyecto.

Opciones del cuadro de diálogo

Elemento

Nombre del archivo o el proyecto.

Etiqueta

Escriba una etiqueta de hasta 31 caracteres de longitud.

Comentario

Escriba un comentario opcional.


Combinar bifurcaciones (Comando, menú SourceSafe)

Vea también

Copia todos los cambios realizados en una bifurcación de un archivo a otra bifurcación. Sólo funciona con archivos, no con proyectos.

Derechos de acceso

Debe disponer del derecho de acceso Desproteger en el proyecto en el que está combinando y el derecho de acceso Leer en el proyecto desde el que está combinado para utilizar este comando. Debe tener una carpeta de trabajo establecida antes de utilizar este comando.

Comentarios

La combinación copia los cambios realizados en un archivo a otro archivo diferente (en otra ruta de desarrollo distinta) en VSS. Si la combinación genera conflictos, VSS desprotege el archivo en su carpeta de trabajo si no está ya desprotegido. Entonces puede modificar el archivo y resolver cualquier conflicto antes de volver a proteger el archivo en VSS.

Por ejemplo, el proyecto $/Newapp actualmente está funcionando con la versión 5. El equipo de desarrollo ha empezado a trabajar con la versión 6, cuando de repente un cliente muy importante informa de un error muy grave en la versión 5. El proyecto Newapp se bifurcará a partir de ese punto para que el equipo de desarrollo pueda continuar trabajando en la versión 6 mientras un equipo de emergencia trabaja en la reparación del error de la versión 5 (quizás su proyecto se llame $/Solucerror). Antes del punto de bifurcación, los proyectos son idénticos, pero a partir del punto de bifurcación, el código de cada proyecto es distinto.

Justo antes de que se publique la versión 6, el equipo que está resolviendo el error anuncia que ya lo ha arreglado. Usted decide combinar su código en el proyecto Newapp, con lo que la versión 6 de su producto tendrá el fallo resuelto. Para ello, seleccione un archivo cada vez en el proyecto Newapp y elija el comando Combinar bifurcaciones.

Después de la operación de combinación, todavía tiene dos rutas de desarrollo independientes, pero los cambios realizados en $/Solucerror se han copiado a $/Newapp. Antes de elegir el comando Combinar bifurcaciones, compruebe que ha seleccionado el archivo al cual desea combinar los cambios. (El archivo a partir del cual está combinando los cambios permanecerá inalterado.)

Nota No puede combinar archivos binarios.

Opciones del cuadro de diálogo

Proyectos

Seleccione el proyecto en el cual desee combinar su archivo. La columna Versiones muestra los números de las versiones que va a combinar.

Combinar

Combina la bifurcaciones.

Cancelar

Cancela la combinación de bifurcaciones.

Vínculos

Muestra todos los proyectos con los cuales el archivo posee vínculos compartidos.


Mover proyecto (Comando, menú Archivo)

Vea también

Coloca un subproyecto de un proyecto primario en otro.

Derechos de acceso

Debe disponer del derecho de acceso Agregar en el proyecto primario al cual se va a mover y el derecho de acceso Destruir en el proyecto primario desde el que se va a mover para utilizar este comando.

Comentarios

El comando Mover proyecto vuelve a definir la ruta de un subproyecto. Por ejemplo, si el proyecto toolmanager existe bajo $/Joe y lo mueve a $/apps, su nuevo nombre completo será $/apps/toolmanager.

Este comando no cambia el nombre de un proyecto y no cambia su contenido ni su historial. Afecta a los historiales de los proyectos primarios antiguos y nuevos.

Tras mover un proyecto, no puede reconstruir una versión anterior de su proyecto primario original. En el ejemplo anterior, cualquier intento de utilizar el comando Obtener la última versión de forma recursiva para recuperar una versión de $/Joe que existía antes de que moviera el proyecto Toolmanager genera una advertencia de que Toolmanager se ha movido y no está disponible.

Nota No puede mover archivos individuales con el comando Mover proyecto. En cambio, para mover un archivo, comparta el archivo con el nuevo proyecto primario y después elimine o destruya el archivo en el proyecto original. El historial del archivo se conserva.

Opciones del cuadro de diálogo

Para mover un proyecto, seleccione primero dicho proyecto en el Explorador de VSS. Después, seleccione la nueva ubicación del proyecto desde este cuadro de diálogo y haga clic en Aceptar.

A

Seleccione la ruta de acceso de un proyecto al que va a mover el subproyecto.

Aceptar

Mueve el proyecto seleccionado a la nueva ubicación.

Cancelar

Cancela la operación de traslado.


Diferencias de archivo (Cuadro de diálogo)

Vea también

Muestra las diferencias existentes entre la versión de la carpeta de trabajo del archivo seleccionado y la versión de la base de datos de VSS de dicho archivo.

Para mostrar el cuadro de diálogo Diferencias de archivo

  1. Asegúrese que el botón SourceSafe o Unix está seleccionado en el cuadro de diálogo Opciones de Diferencias.

  2. Haga clic en un archivo del panel de archivos del Explorador de VSS.

  3. En el menú Herramientas, haga clic en Mostrar diferencias.

  4. Si los archivos comparados son iguales, se mostrará un mensaje para indicar que los archivos son idénticos. VSS no puede mostrar las diferencias de los archivos binarios; sólo puede indicar si los archivos binarios son distintos o no. Si los archivos de texto difieren, VSS mostrará el cuadro de diálogo Diferencias de archivo.

  5. Haga las selecciones deseadas en el cuadro de diálogo Diferencias de archivo, si está activado, y haga clic en Aceptar.

Nota Active la presentación del cuadro de diálogo Opciones de diferencia en la ficha Diálogos de comandos del cuadro de diálogo Opciones de SourceSafe (menú Herramientas).

Comentarios

Este cuadro de diálogo sólo se utiliza cuando no ha seleccionado la comparación visual de diferencias. (En el caso de las diferencias visuales, asegúrese de seleccionar la opción Visual en el cuadro de diálogo Opciones de diferencia.) De manera predeterminada, VSS utiliza el cuadro de diálogo Diferencia visual. La diferencia Visual muestra los archivos uno al lado del otro y le permite hacer fácilmente cambios a uno de ellos. La diferencia de tipo SourceSafe muestra una simple lista de líneas que se han agregado, eliminado y cambiado, optimizada para facilitar su lectura. La opción Unix muestra las diferencias en el formato utilizado por el programa Diff de UNIX.

Si especifica la presentación UNIX, VSS usará las opciones de presentación de SourceSafe para Pasar por alto MAY/min e Ignorar espacios en blanco. La opción de presentación SourceSafe calcula los anchos de línea para que quepan en la pantalla y no muestra líneas de contexto.

Nota Para comparar un archivo actual de VSS con una versión anterior del mismo archivo, haga clic en el archivo en el panel de archivos del Explorador de VSS y, en el menú Herramientas, haga clic en Mostrar historial. Después, haga clic en Diferencias.


Abrir base de datos de SourceSafe (Cuadro de diálogo)

Vea también

Le permite abrir diferentes bases de datos de VSSy almacenar sus ubicaciones.

Opciones del cuadro de diálogo

Bases de datos disponibles

Especifica las bases de datos que visitó, proporcionando un nombre descriptivo e información de la ruta de acceso para cada una de ellas. Si la base de datos que desea no está en la lista, puede hacer clic en el botón Examinar para buscarla. Cuando la encuentre y haga clic en el botón Aceptar del cuadro de diálogo Examinar con un determinado archivo SRCSAFE.INI seleccionado, tendrá la oportunidad de proporcionar a la base de datos un nombre descriptivo fácil de recordar cuando vuelva a conectarse más tarde.

Nombre de usuario

Especifica el nombre de usuario con el que desea conectarse a la nueva base de datos. Si lo cambia a un nuevo nombre de usuario con una contraseña diferente, se le pedirá que escriba la nueva contraseña. No puede cambiar esta opción en el programa Administrador.

Abrir esta base de datos la próxima vez que ejecute Visual SourceSafe

Active esta casilla de verificación para designar esta base de datos como la base de datos de inicio.

Quitar

Quita de la lista una base de datos seleccionada. No puede quitar de la lista la base de datos actual.

Aceptar

Confirma sus selecciones.

Cancelar

Cancela sus selecciones.


Cambiar contraseña (Comando, menú Herramientas)

Vea también

Establece la contraseña del usuario actual.

Derechos de acceso

Cualquier usuario de VSS puede utilizar este comando.

Comentarios

Utilice el comando Cambiar contraseña para establecer su contraseña. Tras cambiarla, la contraseña anterior dejará de funcionar y deberá escribir la nueva cada vez que inicie una sesión de VSS.

Para cambiar su contraseña, primero debe saber cuál es. Si olvida su contraseña, pida al administrador de VSS que la cambie.

Nota Tenga en cuenta que la contraseña de VSS no implica que reemplace o aumente la contraseña del sistema operativo o de la red. Sólo cuando el sistema operativo no permite a VSS determinar la identificación del usuario, SourceSafe pide la contraseña de SourceSafe al iniciar la sesión. Su contraseña de VSS puede ser la misma o bien otra diferente de la del sistema operativo.

Opciones del cuadro de diálogo

Contraseña anterior

Escriba la contraseña actual o deje este cuadro en blanco si la contraseña está en blanco (una cadena de longitud cero).

Contraseña nueva

Escriba la contraseña nueva.

Una contraseña puede consistir en cualquier combinación de 1 a 15 caracteres válidos. A medida que los escribe, los caracteres se muestran como asteriscos. Las contraseñas de Microsoft VSS no distinguen entre mayúsculas y minúsculas.

Comprobar

Vuelva a escribir la nueva contraseña para comprobarla.


Rutas de acceso (Ficha, cuadro de diálogo Propiedades)

Vea también

Muestra todas las bifurcaciones del archivo especificado.

Para ver la ficha Rutas de acceso:

  1. Haga clic en un archivo del panel de archivos del Explorador de VSS.

  2. En el menú Archivo, haga clic en Propiedades y después haga clic en la ficha Rutas de acceso.

    Nota Para ver esta ficha desde dentro de Visual Basic, después de agregar un proyecto de Visual Basic a VSS, en el menú Complementos de Visual Basic haga clic en SourceSafe y después haga clic en Propiedades de SourceSafe.

Derechos de acceso

Debe disponer del derecho de acceso Leer para utilizar esta ficha.

Comentarios

Cuando utilice el comando Bifurcar para bifurcar un archivo, el vínculo compartido se rompe y se crea una bifurcación de archivo independiente. Una vez bifurcado un archivo, las modificaciones realizadas a dicho archivo en un proyecto no se reflejan en los demás proyectos. Sin embargo, algunas veces es valioso para hacer un seguimiento de estas relaciones.

Por ejemplo, suponga que encuentra un error en un archivo y lo corrige. Todos los proyectos que comparten el archivo se actualizan inmediatamente con la nueva versión. Sin embargo, los proyectos que compartían ese archivo y después se bifurcaron de él, no se actualizan; utilice la ficha Rutas de acceso para encontrar esos proyectos y después actualícelos manualmente.

Cuando examina las rutas de acceso, ve el historial de bifurcaciones completo de un archivo, incluyendo todas las veces que se utilizó el comando Bifurcar para moverlo a diferentes proyectos de distintas rutas de desarrollo. Sin embargo, no se muestran los cambios realizados al archivo; utilice el comando Mostrar historial para verlos.

Utilizar el comando Rutas de acceso podría dar lugar a algo parecido a lo siguiente.

Proyectos con ramificaciones independientes
$/A         1->5
--$/B         6->7
--$/D         4->4

Esta pantalla quiere decir que hay 3 bifurcaciones de este archivo (porque hay 3 líneas); la primera procede de la versión 1 del archivo y se ha trasladado a la versión 5, la segunda bifurcación considera la primera como su primaria (lo que significa que las versiones 1 a 5 del archivo son la misma en esta bifurcación), comenzó su vida en la versión 6 y se protegió una vez a partir de entonces, trasladándose a la versión 7, que es su estado actual. La tercera bifurcación comenzó en la versión 4 y, desde ese momento, ha permanecido inalterada.

Puede seleccionar cada bifurcación y hacer clic en el botón Vínculos para ver dónde está compartido ese archivo en concreto. ¿Cómo utilizará dicha información? Suponga que se introdujo un error en este archivo en la versión 5 de la primera ramificación. Gracias a la información que aparece en pantalla, sabe que la tercera bifurcación no se ha visto afectada por dicho error (porque todavía se encuentra en la versión 4) pero que, en la segunda bifurcación, es necesario insertar la solución manualmente, ya que esta bifurcación procede de la primera (su primaria), pero comenzó en la versión 6. Por supuesto, en cuanto haya arreglado el archivo en cada una de estas bifurcaciones, cualquier otro proyecto que comparta el archivo incluirá la solución al error automáticamente.

Opciones de la ficha

Proyectos con ramas independientes

Enumera los proyectos en los que se ha compartido el archivo seleccionado.

Versiones

Muestra el número de versión del archivo que se bifurcó en el correspondiente proyecto.

Vínculos

Muestra la ficha Vínculos del cuadro de diálogo Propiedades de archivos.

Cerrar

Cierra el cuadro de diálogo Propiedades y vuelve al Explorador de VSS.

Informe

Envía un informe al Portapapeles, a un archivo de texto o a una impresora.


Vista previa (Cuadro de diálogo)

Muestra una vista previa del informe especificado, de forma que pueda determinar si es lo que deseaba antes de realizarlo y enviarlo a la cola de impresión o a un archivo. Puede utilizar las teclas aceleradoras del visor en este cuadro de diálogo para desplazarse por el archivo.

Opciones del cuadro de diálogo

Cerrar

Cierra la vista previa del informe.


Imprimir (Cuadro de diálogo)

Vea también

Establece las opciones de impresión.

Para ver el cuadro de diálogo Imprimir:

  1. Seleccione un archivo o un proyecto en el Explorador de VSS y, en el menú Herramientas, haga clic en Mostrar historial.

  2. Realice las selecciones deseadas en el cuadro de diálogo Opciones de historial u Opciones de historial de proyectos, si está activado, y haga clic en Aceptar.

    Nota Active la presentación de los cuadros de diálogo Opciones de historial en la ficha Diálogos de comandos del cuadro de diálogo Opciones de SourceSafe (menú Herramientas).

  3. En el cuadro de diálogo Historial de archivo o Historial de proyecto, haga clic en Informe.

  4. Bajo Imprimir en, haga clic en Impresora y después haga clic en Aceptar.

Opciones del cuadro de diálogo

Impresora

Impresora seleccionada en el cuadro de diálogo Configurar impresión. Para ver el cuadro de diálogo Propiedades de impresora, haga clic en Propiedades.

Copias

Escriba el número de copias del informe que desea imprimir.

Imprimir en archivo

Envía el informe a un archivo PostScript e imprime el informe.

Propiedades

Muestra el cuadro de diálogo Propiedades de impresora de Windows.


Diferencias de proyecto (Cuadro de diálogo)

Muestra las diferencias entre los archivos del proyecto seleccionado de la base de datos de VSS y los de la carpeta de trabajo establecida para ese proyecto. También puede ver qué hay de diferente dentro del archivo y sincronizar las diferencias, si lo desea.

Para ver el cuadro de diálogo Diferencias de proyecto

  1. Haga clic en un proyecto del panel de proyectos del Explorador de VSS.

  2. En el menú Herramientas, haga clic en Mostrar diferencias. Realice las selecciones deseadas en el cuadro de diálogo Diferencias de proyecto si está activado y haga clic en Aceptar.

Nota Active la presentación del cuadro de diálogo Diferencias de proyecto en la ficha Diálogos de comandos del cuadro de diálogo Opciones de SourceSafe (menú Herramientas).

Opciones del cuadro de diálogo

Este importante cuadro de diálogo se compone de dos paneles: en uno se muestran los archivos que hay en su proyecto actual (a la izquierda) y en el otro los archivos que se encuentran en la carpeta de trabajo asignada al proyecto actual (a la derecha). Este cuadro de diálogo también tiene su propia barra de herramientas, con botones para agregar, eliminar, obtener, proteger y desproteger archivos, deshacer desprotecciones, ver archivos, sincronizar las diferencias entre el proyecto y la carpeta de trabajo, etc.

En ambos paneles, los archivos están ordenados alfabéticamente por nombre de archivo o de carpeta (si hay subcarpetas). Recuerde que la lista de archivos en los paneles derecho e izquierdo se ha filtrado de acuerdo con las opciones elegidas en el diálogo del comando Mostrar diferencias. Por ejemplo, si ha elegido mostrar sólo los archivos que sean diferentes en ambos sitios, no verá los archivos que sean iguales en la carpeta de trabajo y en el proyecto actual. Puede cambiar el tamaño de las columnas en el panel izquierdo si arrastra la barra de la columna con el botón primario del mouse. Si presiona F5 se actualizará la información del cuadro de diálogo (pero es posible que sea lento para proyectos de gran tamaño).

En las listas pueden aparecer cuatro tipos de archivo.

  • De forma predeterminada, los archivos que son iguales en el proyecto y en la carpeta de trabajo aparecen con letras negras sobre un fondo blanco. No es necesario que haga nada con estos archivos.

  • De forma predeterminada, los archivos que están en el proyecto, pero no en la carpeta de trabajo, aparecen de color azul sobre un fondo gris. Un archivo así normalmente representa un archivo agregado al proyecto por otro usuario (en cuyo caso es posible que desee obtenerlo) o un archivo que eliminó de su carpeta de trabajo (en cuyo caso es posible que desee eliminarlo de VSS).

  • De forma predeterminada, los archivos que se encuentran en la carpeta de trabajo, pero no en el proyecto, aparecen de color verde sobre un fondo gris. Un archivo así suele representar un archivo creado por usted (en cuyo caso es posible que desee agregarlo a VSS) o que otro usuario ha eliminado del proyecto (en cuyo caso puede que desee eliminar su copia local).

  • De forma predeterminada, los archivos que están en ambos sitios, pero que son diferentes, aparecen de color rojo sobre un fondo gris. Un archivo así generalmente representa un archivo que usted ha protegido (puede que desee protegerlo) o un archivo protegido por otro usuario (y que es posible que desee obtener).

Nota Puede establecer los colores predeterminados para texto agregado, modificado y eliminado mediante la ficha Diferencias del cuadro de diálogo Opciones del menú Herramientas.

Anteriormente se ha ofrecido una lista completa de los cuatro tipos de archivo, aunque no se describen todas sus posibilidades. Por ejemplo, si otro usuario cambia el nombre de un archivo en VSS verá un archivo que no tiene realmente, en la lista de archivos para ese proyecto en el Explorador de VSS; en la carpeta de trabajo para el proyecto habrá un archivo que no está presente en la base de datos de VSS. Por tanto, es posible que desee obtener el archivo de VSS y eliminar el suyo local para sincronizar las diferencias.

Los iconos de archivo del panel izquierdo del cuadro de diálogo representan las mismas cosas que en la ventana principal del Explorador, una marca de verificación situada junto a un archivo indica que el archivo está desprotegido, etc. Los iconos de archivo del panel derecho representan condiciones específicas del usuario, por ejemplo, una marca de verificación en el panel derecho indica que el archivo está desprotegido concretamente para usted en su directorio de trabajo. Al hacer doble clic sobre un archivo puede verlo. Si hace doble clic en una carpeta no sucede nada.

Los comandos de la barra de herramientas de este cuadro de diálogo suelen funcionar igual que los comandos estándar de VSS, con las siguientes diferencias:

  • El comando Agregar mueve un archivo o una carpeta del panel derecho al panel izquierdo. Es decir, agrega un archivo de su carpeta de trabajo al proyecto de VSS. La tecla de método abreviado para este comando es la tecla de aplicación de Windows 95 + A.

  • El comando Eliminar funciona normalmente si hay un archivo seleccionado en el panel izquierdo. Si se selecciona un archivo en el panel derecho, puede utilizar el comando Eliminar para eliminar la carpeta o el archivo local de su carpeta de trabajo. La tecla de método abreviado para este comando es la tecla SUPR.

  • El comando Obtener la última versión funciona como siempre, obteniendo un archivo o un proyecto del panel izquierdo al panel derecho. La tecla de método abreviado para este comando es la tecla de aplicación de Windows 95 + G.

  • El comando Desproteger funciona como siempre, sincronizando las diferencias entre un archivo que es distinto en los dos paneles y que no está desprotegido en el panel derecho, desprotegiendo el archivo y sobrescribiendo el archivo en su carpeta de trabajo local. La tecla de método abreviado para este comando es la tecla de aplicación de Windows 95 + O.

  • El comando Proteger funciona normalmente, sincronizando un archivo que se encuentra en ambos paneles, aunque sea distinto, y que está desprotegido en los dos paneles. Con este comando guardará las últimas modificaciones realizadas al archivo en la carpeta de trabajo. La tecla de método abreviado para este comando es la tecla de aplicación de Windows 95 + I.

  • El comando Deshacer desprotección funciona como siempre, sincronizando un archivo que es distinto en ambos paneles y que está desprotegido en ambos mediante la desprotección del archivo. Con este comando se pierden las últimas modificaciones del archivo en la carpeta de trabajo. La tecla de método abreviado para este comando es la tecla de aplicación de Windows 95 + U.

  • El comando Ver funciona sobre un archivo seleccionado en el panel izquierdo igual que el comando Ver del Explorador; muestra el archivo en la base de datos de VSS. El comando Ver funciona sobre un archivo seleccionado en el panel derecho abriendo directamente el visor adecuado en el archivo en la carpeta. La tecla de método abreviado para este comando es la tecla de aplicación de Windows95 + V.

  • El comando Diferencias compara dos archivos seleccionados. Si sólo hay un archivo seleccionado, Diferencias lo compara entre el proyecto y la carpeta de VSS. La tecla de método abreviado para este comando es la tecla de aplicación de Windows 95 + S.

  • El comando Actualizar lista de archivos pone al día la lista de archivos.

  • El comando Sincronizar todo sincroniza las diferencias encontradas entre los proyectos comparados. La sincronización puede hacer referencia a varias cosas distintas, dependiendo de las opciones elegidas en los cuadros de diálogo que se presentan después de elegir este comando.

  • El comando Informe genera el cuadro de diálogo estándar Informe. La tecla de método abreviado para este comando es la tecla F5.

Nota Si utiliza un mouse, puede acceder a muchos de los comandos anteriores con el botón secundario del mouse.


Historial de proyecto (Cuadro de diálogo)

Vea también

Muestra información histórica sobre el proyecto seleccionado.

Para ver el cuadro de diálogo Historial de proyecto:

  1. Haga clic en un proyecto del panel de proyectos del Explorador de VSS.

  2. En el menú Herramientas, haga clic en Mostrar historial.

    Realice las selecciones deseadas en el cuadro de diálogo Opciones de historial de proyectos si está activado y haga clic en Aceptar.

    Nota Active la presentación del cuadro de diálogo Opciones de historial de proyectos en la ficha Diálogos de comandos del cuadro de diálogo Opciones de SourceSafe (menú Herramientas). El cuadro de diálogo le ofrece la opción de restringir el historial sólo a la etiquetas, incluir archivos en la lista de historial del proyecto, hacer que la lista del historial sea recursiva hacia abajo en la jerarquía del proyecto o restringir la lista del historial a un usuario especificado o a un intervalo de fechas.

  3. Haga clic en Aceptar.

Derechos de acceso

Debe disponer del derecho de acceso Leer para utilizar este cuadro de diálogo.

Comentarios

El cuadro de diálogo Historial de proyecto muestra el historial de un proyecto seleccionado, incluyendo todos sus eventos significativos, como la eliminación de archivos o subproyectos, la adición de archivos o subproyectos, el etiquetado y cambio de nombre de elementos, y las protecciones. Para cada evento significativo, el cuadro de diálogo muestra el archivo o subproyecto afectado, el usuario que realizó la acción, la fecha y hora del evento, y la descripción del mismo. Los eventos se muestran con el más reciente en la parte superior de la pantalla.

Desde este cuadro de diálogo están disponibles varios comandos. Puede realizar un comando sobre un archivo o un subproyecto si selecciona primero un evento y después hace clic en un botón de comando.

Opciones del cuadro de diálogo

Cerrar

Cierra el cuadro de diálogo y vuelve al Explorador de VSS.

Ver

Muestra un cuadro de diálogo que contiene una lista de todos los archivos (con sus números de versión), así como el proyecto que existía en el punto seleccionado del historial del proyecto.

Detalles

Muestra los comentarios asociados con un evento, junto con información de eventos más detallada, como información de etiqueta, información de versión, etc.

Obtener

Realiza el comando Obtener sobre la versión del archivo o el subproyecto seleccionado. Si selecciona un archivo, VSS mostrará un cuadro de diálogo para pedirle que aclare si desea obtener sólo el archivo seleccionado u obtener (es decir, volver a crear) el proyecto completo tal y como existía en el momento en que existía la versión del archivo seleccionado.

Desproteger

Ejecuta el comando Desproteger sobre la versión del archivo o del proyecto secundario seleccionado. Si selecciona un archivo, VSS muestra un cuadro de diálogo dónde le pregunta que aclare si desea desproteger tan sólo el archivo seleccionado o desproteger (es decir: volver a crear) el proyecto completo tal y como existía en el mismo punto de versión que el archivo seleccionado. Puede aparecer un mensaje de error si el archivo ha sido destruido en el punto de historial en el que intenta desprotegerlo.

Compartir

Realiza el comando Compartir sobre el archivo o el proyecto seleccionado. Con este comando podrá compartir la versión actual u otra anterior de archivos del proyecto con otro proyecto. Esto le permite crear una bifurcación de una versión anterior del proyecto. Puede que desee hacerlo si necesita reparar algunos errores para un cliente mientras sigue desarrollando la próxima versión del producto.

Informe

Envía un informe al Portapapeles, a un archivo o a una impresora.


Compartir (Cuadro de diálogo)

Vea también

Permite especificar un proyecto para compartir con el proyecto actual.

Para ver el cuadro de diálogo Compartir:

  1. En el panel de proyectos del Explorador de VSS, haga clic en un proyecto en el cual desee compartir otro proyecto.

  2. En el menú SourceSafe, haga clic en Compartir.

  3. En el cuadro de diálogo Compartir con proyecto, seleccione un proyecto para compartir y haga clic en Compartir.

Opciones del cuadro de diálogo

Nuevo nombre

Escriba el nombre del proyecto que desea compartir con el proyecto actual.

Recursivo

Active esta casilla de verificación para que la operación de compartir sea recursiva (que incluya todos los subproyectos y sus archivos).

Comentario

Escriba un comentario para esta operación.

Aceptar

Vuelve al cuadro de diálogo Compartir con proyecto, que muestra el proyecto seleccionado para compartir con los archivos elegidos.

Cancelar

Cancela el comando Compartir.


Examinar la carpeta (Cuadro de diálogo)

Para obtener más información acerca del cuadro de diálogo Establecer la carpeta de trabajo, vea el tema Establecer la carpeta de trabajo (Comando, menú Archivo).

Opciones del cuadro de diálogo

Nombre

Nombre y ruta de acceso de la carpeta.

Carpeta

La carpeta actual.

Carpetas

Especifica una carpeta.

Unidades

Selecciona la unidad que contiene la carpeta.

Aceptar

Confirma la selección de la carpeta.

Cancelar

Cancela la selección, cierra el cuadro de diálogo y devuelve el control al Administrador de VSS.

Crear carpeta

Crea una nueva carpeta especificada. Escriba un nuevo nombre de carpeta en el cuadro Nombre y haga clic en Crear carpeta para crear la carpeta.


Eliminar (Comando, menú Archivo)

Vea también

Elimina un archivo o un proyecto.

Nota En versiones anteriores de VSS, este comando se llamaba Quitar.

Derechos de acceso

Debe disponer del derecho de acceso Agregar para utilizar este comando.

Comentarios

Si no activa la casilla de verificación Destruir definitivamente del cuadro de diálogo Eliminar, el comando Eliminar es reversible; para hacer posible la recuperación, VSS almacena todo archivo o subproyecto eliminado.

Para recuperar el archivo, utilice el comando Recuperar. Otra forma de recuperar el archivo (si no se ha purgado o destruido) es volver a una versión anterior del proyecto que contiene el archivo.

Nota Al eliminar un proyecto, todos sus subproyectos y los archivos contenidos en ellos se eliminan también. Al recuperar el proyecto, se recuperan sus subproyectos (y los archivos que contienen).

Un archivo o un subproyecto eliminado se puede purgar o destruir, lo cual lo quita de forma permanente.

Opciones del cuadro de diálogo

Elemento

Nombre del archivo o subproyecto que desea eliminar.

Destruir definitivamente

Si hace clic en esta casilla de verificación se quita el archivo o el subproyecto de forma que no pueda recuperarse posteriormente. Es lo mismo que ejecutar el comando Purgar sobre los elementos. Debe disponer del derecho de acceso Destruir para activar esta casilla de verificación.

Precaución El comando Destruir debe utilizarse con extrema precaución. Antes de utilizarlo, debe asegurarse de que jamás necesitará el archivo o el proyecto, o ninguna de sus versiones anteriores, por ninguna razón.

Si hay alguna razón por la cual podría desear recuperar versiones anteriores del proyecto que contenía el archivo, elimine el archivo sin destruirlo; en este caso puede recuperar el archivo más tarde con el comando Recuperar.


Elementos eliminados (Ficha, cuadro de diálogo Propiedades)

Vea también

Muestra una lista de los archivos y subproyectos que se han quitado del proyecto actual.

Para ver la ficha Elementos eliminados

  1. Haga clic en un proyecto del panel de proyectos del Explorador de VSS.

  2. En el menú Archivo, haga clic en Propiedades y después haga clic en la ficha Elementos eliminados.

Derechos de acceso

Debe disponer del derecho de acceso Leer para utilizar esta ficha.

Comentarios

Cuando utilice el comando Eliminar para eliminar un archivo o un proyecto de VSS, el elemento eliminado se quita del Explorador de VSS. Sin embargo, VSS continúa almacenando el elemento, de forma que puede recuperarlo si desea generar una versión anterior del proyecto. No obstante, después de recuperar o purgar un elemento, deja de aparecer en la lista de la ficha Elementos eliminados.

Opciones de la ficha

Elementos

Lista de todos los archivos y subproyectos eliminados del proyecto actual.

Recover

Recupera (deshace la eliminación) un elemento y lo coloca en la lista de archivos o lista de proyectos.

Purgar

Elimina de forma permanente un elemento, de forma que no puede recuperarse.

Cerrar

Cierra la ficha Elementos eliminados y vuelve al Explorador de VSS.

Informe

Envía un informe al Portapapeles, a un archivo de texto o a una impresora.


Cambiar nombre (Comando, menú Archivo)

Vea también

Cambia el nombre de un archivo o un proyecto.

Derechos de acceso

Debe disponer del derecho de acceso Agregar para utilizar este comando.

Comentarios

Para utilizar el comando Cambiar nombre, seleccione el archivo o el proyecto cuyo nombre desee modificar y después elija el comando. Posteriormente, tendrá la posibilidad de modificar el nombre del elemento directamente en la ventana del Explorador de VSS.

Al utilizar el comando Cambiar nombre sobre un archivo o un proyecto, el historial de archivo del elemento se mantiene. Si múltiples proyectos comparten un archivo y el archivo se cambia de nombre, se cambiará de nombre en todos los proyectos que lo comparten. Sin embargo, si se han roto algunos vínculos compartidos mediante el comando Bifurcar, los archivos bifurcados no se cambiarán de nombre. La ficha Rutas de acceso del cuadro de diálogo Propiedades muestra cómo ha cambiado el nombre en diferentes bifurcaciones del archivo.


Buscar en archivos (Comando, menú Herramientas)

Vea también

Busca todas las instancias de una cadena de caracteres especificada dentro de uno o más archivos.

Derechos de acceso

Debe disponer del derecho de acceso Leer para utilizar este comando.

Comentarios

Utilice el comando Buscar en archivos para mostrar una lista de todas las ocurrencias de una cadena de caracteres en los archivos de VSS que especifique. Puede utilizar el comando en un único archivo o en un proyecto completo.

Hay tres caracteres comodín que puede utilizar en una cadena de búsqueda, a menos que se active Coincidencias exactas:

  • Un signo de interrogación coincide con cualquier carácter.

  • Un asterisco coincide con cualquier cadena.

  • Una barra inversa hace literal el carácter que hay a continuación de ella: y \\. Esto es necesario si desea buscar asteriscos, signos de interrogación o barras inversas.

Normalmente, VSS distingue entre mayúsculas y minúsculas; es decir, "A" no es igual que "a". Para hacer que el comando Buscar en archivos distinga entre mayúsculas y minúsculas, haga clic en Coincidir mayúsculas y minúsculas.

El resultado de la búsqueda se muestra en una ventana Resultados. En la parte superior de esta ventana, VSS muestra una lista de todos los archivos que contienen coincidencias. En la parte inferior, VSS muestra las cadenas que coincide en archivo seleccionado actualmente. A medida que se desplaza por la lista de la parte superior, la parte inferior muestra los cambios para reflejar el cambio de selección de archivo.

Opciones del cuadro de diálogo

Elemento

Escriba el nombre del archivo o archivos en los que desea que VSS busque.

Cadena

Escriba la cadena de caracteres que desea que encuentre VSS.

Coincidir mayúsculas y minúsculas

Buscar sólo coincidencias exactas. La cadena que introduzca no puede contener caracteres comodín.

Usar expresiones normales

Active la casilla si utiliza un signo asterisco como parte de una búsqueda por comodines dentro del texto. Desactívela si utiliza el signo asterisco como un carácter de texto normal.

Recursivo (sólo a nivel de proyecto)

Busca en todos los archivos del proyecto y los de sus subproyectos.

Mostrar por separado todos los archivos compartidos (sólo a nivel de proyecto)

En búsquedas de proyecto, anota cada coincidencia encontrada en un archivo compartido como un elemento separado. (De forma predeterminada, una coincidencia en un archivo compartido se cita sólo para uno de los proyectos en los que existe el archivo.)


Resultados de la búsqueda en archivos (Cuadro de diálogo)

Este cuadro de diálogo muestra el resultado del comando Buscar en archivos ejecutado

Opciones del cuadro de diálogo

Archivo

Muestra el nombre del archivo o los archivos que contienen cadenas coincidentes con la buscada.

Coincidencias

Muestra el número de coincidencias encontradas en el archivo.

Coincidencias

Muestra una lista den las coincidencias encontradas en el contexto.

Cerrar

Cierra el cuadro de diálogo Resultados de la búsqueda en archivos.

Informe

Permite imprimir un informe con la información obtenida, ya sea en la impresora, en el Portapapeles o en un archivo.

Vínculos

Muestra cualquier vínculo que tenga el archivo a otros proyectos.


Desproteger archivos desde (Cuadro de diálogo)

Desprotege uno o varios archivos seleccionados en su proveedor de control de código fuente y coloca una copia modificable en el directorio de trabajo del entorno de desarrollo correspondiente.

Para utilizar el comando Desproteger:

  • En el menú Herramientas de Visual Basic haga clic en Desproteger.

Opciones del cuadro de diálogo

Archivos para desproteger

Enumera los archivos disponibles para la desprotección. Haga clic en los archivos que desea desproteger o haga clic en Seleccionar todo para seleccionar todos los archivos de la lista.

Comentario

Describa brevemente la razón por la que desprotege el archivo.

Avanzadas

Muestra el cuadro de diálogo Desprotección avanzada.

Aceptar

Confirmar Desproteger.

Cancelar

Cancela el comando Desproteger.

Seleccionar todo

Selecciona todos los archivos que se enumeran.


Obtener desde <Nombre de proyecto> (Cuadro de diálogo)

Obtiene los archivos seleccionados de su proveedor de control de código fuente y coloca un archivo de sólo lectura en el proyecto de entorno de desarrollo.

Para usar el comando Obtener:

  • En el menú Herramientas de Visual Basic haga clic en Obtener.

Opciones del cuadro de diálogo

Archivos para obtener o proteger

Selecciona el archivo o los archivos que desea obtener o proteger.

Avanzadas

Muestra el cuadro de diálogo Opciones avanzadas.

Aceptar

Confirma sus selecciones.

Cancelar

Cancela sus selecciones.

Seleccionar todos

Selecciona todos los archivos que se enumeran.


Deshacer desprotección <Nombre de proyecto> (Cuadro de diálogo)

Sobrescribe sus cambios en un archivo y copia la última versión desprotegida en el directorio de trabajo de su entorno de desarrollo.

Para utilizar el comando Deshacer desproteger:

  • En el menú Herramientas de Visual Basic, haga clic en Deshacer desproteger.

Opciones del cuadro de diálogo

Archivos para desproteger

Enumera los archivos desprotegidos actualmente. Haga clic en los archivos cuya desprotección desee deshacer, o haga clic en Seleccionar todos para seleccionar todos los archivos que se enumeran.

Avanzadas

Muestra las Opciones avanzadas de deshacer desproteger.

Aceptar

Confirma la selección.

Cancelar

Cancela la selección.

Seleccionar todos

Selecciona todos los archivos que se enumeran.


Buscar (Cuadro de diálogo)

Le permite especificar una cadena a buscar en el archivo actual.

Para ver el cuadro de diálogo Buscar

  • En el visor de archivos de SourceSafe, haga clic en el botón Buscar de la barra de herramientas. (Utilice el visor de archivos de SourceSafe cuando vea un archivo para el cual no haya establecido otra asociación de archivo.)

Opciones del cuadro de diálogo

Buscar

Escriba la cadena que desee buscar.

Sólo palabras completas

Active esta casilla para encontrar la cadena especificada tan sólo si ésta corresponde a una palabra completa y no a una parte de palabra solamente.

Coincidir mayúsculas y minúsculas

Active esta casilla de verificación para que la búsqueda distinga entre mayúsculas y minúsculas.

Usar expresiones normales

Si esta casilla está desactivada, los caracteres * y ? se interpretarán literalmente. Por tanto, A*B sólo coincidirá con una cadena, A*B.

Si esta casilla está activada, los caracteres * y ? se interpretarán como comodines. Por tanto, A?B servirá tanto para ABB como AQB, y A*B coincidirá con ADSFFDFDSB, dentro de una línea.

Establecer marcadores en todo

Establece marcadores en todas las coincidencias del archivo.

Dirección

Especifica si la búsqueda debe proseguir hacia delante o hacia atrás en el archivo.

Buscar siguiente

Confirma la selección de búsqueda.

Cancelar

Cancela la búsqueda.


Bifurcar (Comando, menú SourceSafe)

Vea también

Rompe un vínculo compartido mientras conserva una copia del archivo.

Nota En versiones anteriores de VSS, este comando se llamaba Separar.

Derechos de acceso

Debe disponer del derecho de acceso Agregar para utilizar este comando.

Comentarios

Un único archivo puede estar compartido por múltiples proyectos. Cualquier cambio realizado en ese archivo se refleja en todos los proyectos que lo comparte de forma que, por ejemplo, la propagación de solución de errores la controla VSS.

Tras aplicar el comando Bifurcar al archivo, existen dos bifurcaciones distintas del archivo en diferentes proyectos. Puede hacer un seguimiento de las diferentes bifurcaciones en la ficha Rutas de acceso del cuadro de diálogo Propiedades y agruparlas de nuevo con el comando Combinar bifurcaciones.

Opciones del cuadro de diálogo

Comentario

Escriba un comentario que describa la bifurcación.

Aceptar

Confirma el comando Bifurcar.

Cancelar

Cancela el comando Bifurcar.


Compartir (Comando, menú SourceSafe)

Vea también

Convierte un archivo en miembro del proyecto actual o crea un nuevo proyecto bifurcado.

Para compartir una versión específica de un archivo en su proyecto actual, utilice el cuadro de diálogo Mostrar historial (menú Herramientas) y haga clic en Compartir. En el cuadro de diálogo Compartir desde el proyecto, seleccione el archivo que desea compartir en el proyecto actual.

Derechos de acceso

Debe disponer del derecho de acceso Desproteger en el proyecto desde el que está compartiendo y el derecho de acceso Agregar en el proyecto al cual está compartiendo para utilizar este comando.

Comentarios

Para compartir un archivo, cree un vínculo compartido entre dos proyectos. El archivo está entonces en dos (o más) proyectos al mismo tiempo. Al proteger el archivo en cualquiera de los proyectos, sus cambios se protegen automáticamente en todos ellos. Para mostrar una lista de todos los proyectos que comparten un determinado archivo, utilice la ficha Vínculos del cuadro de diálogo Propiedades.

Si crea una bifurcación, los cambios realizados en el archivo bifurcado no se propagarán más allá del proyecto original y viceversa. El comando Vínculos ya no muestra una relación, pero puede utilizar la ficha Rutas de acceso del cuadro de diálogo Propiedades para ver la ruta de la bifurcación de archivo que creó.

Al compartir un proyecto, crea un proyecto completamente nuevo bajo el proyecto actual que es un duplicado exacto del proyecto que especificó. Todos los archivos del nuevo proyecto se comparten con los archivos correspondientes del proyecto original y los cambios de unos se reflejan en los otros durante la protección.

Opciones del cuadro de diálogo

Compartir archivo

Escriba el nombre del archivo o archivos que desea compartir o haga clic en un nombre de archivo ya mostrado. Los archivos mostrados son aquellos que pueden compartirse con su proyecto actual: algunos archivos no se pueden compartir, como los archivos que tienen el mismo nombre que archivos que ya existen en su proyecto.

Proyectos

El nombre del proyecto desde el cual se está compartiendo.

Mostrar archivos de tipo

Muestra el tipo de archivo o indica a VSS cómo clasificar un archivo.

La lista de tipos de archivo disponibles se determina en el filtro Tipos de archivo incluidos en grupo de archivos y en el filtro Grupos de archivo establecidos en la ficha Tipos de archivo del cuadro de diálogo Opciones de SourceSafe. Todos los archivos (*.*) muestra una lista de todos los archivos de la carpeta actual.

Cerrar

Cierra el cuadro de diálogo.

Compartir

Comparte el archivo o el proyecto seleccionado.

Ver

Muestra el archivo con el editor de textos asociado a la extensión del archivo. El editor se configura con la opción Visor de archivos de la ficha General del cuadro de diálogo Opciones de SourceSafe.

Bifurcar después de compartir

Comparte el archivo y después lo bifurca inmediatamente para crear copias distintas del archivo.


Personalizar barra de herramientas (Comando, menú Herramientas)

Vea también

Agrega o elimina botones en la barra de herramientas de VSS.

Derechos

Cualquier usuario de VSS puede utilizar este comando.

Comentarios

Para agregar un botón a la barra de herramientas, en el menú Herramientas, elija Personalizar la barra de herramientas. En el cuadro de diálogo Personalizar la barra de herramientas, seleccione el botón de la barra de herramientas que desee en el área de Botones disponibles y después haga clic en Agregar para moverlo al área Botones de la barra de herramientas. Para eliminar un botón, seleccione el botón de la barra de herramientas que desee dentro del área Botones de la barra de herramientas y después haga clic en Quitar para desplazarlo al área de Botones disponibles.

Después de que un botón esté en la barra de herramientas, puede arrastrarlo a una nueva ubicación del cuadro de diálogo para moverlo a una nueva posición en la barra de herramientas.

Opciones del cuadro de diálogo

Agregar

Mueve un botón seleccionado desde la lista Botones disponibles a la lista Botones de la barra de herramientas (es decir, lo agrega a la barra de herramientas).

Quitar

Mueve un botón seleccionado desde la lista Botones de la barra de herramientas a la lista Botones disponibles (es decir, lo quita de la barra de herramientas).

Restablecer

Restablece la barra de herramientas a su configuración predeterminada.

Cerrar

Cierra el cuadro de diálogo Personalizar barra de herramientas.

Subir

Mueve un botón hacia arriba dentro de la lista Botones de la barra de herramientas y lo desplaza hacia la izquierda dentro de la barra de herramientas del Explorador de VSS.

Bajar

Mueve un botón hacia abajo dentro de la lista Botones de la barra de herramientas y lo desplaza hacia la derecha en la barra de herramientas del Explorador de VSS.


Proteger (Comando, menú SourceSafe)

Vea también

Actualiza VSS con los cambios realizados a un archivo desprotegido y desbloquea la copia maestra de VSS.

Nota En versiones anteriores de VSS, este comando se llamaba Actualizar.

Derechos de acceso

Debe disponer del derecho de acceso Desproteger para utilizar este comando.

Comentarios

Hay dos comandos que puede utilizar para terminar la desprotección de un archivo:

  • El comando Proteger copia los cambios a la base de datos de VSS, creando una versión nueva del archivo. Cuando otros usuarios utilicen el comando Obtener la última versión o desprotejan el archivo, recibirán todas las modificaciones que haya realizado.

  • El comando Deshacer desprotección permite anular todos los cambios y deshace la desprotección del archivo.

Al proteger un archivo, VSS proporciona un cuadro en el cual puede especificar un comentario.

Nota Para actualizar la copia maestra de un archivo mientras se conserva el archivo desprotegido, haga clic en la casilla de verificación Mantener desprotegido. Puede convertirlo en el comportamiento predeterminado si activa la casilla de verificación Mantener los archivos desprotegidos siempre de la ficha General en el cuadro de diálogo Opciones de SourceSafe.

Puede proteger un archivo que no haya cambiado, pero aún así agrega el archivo no cambiado como una nueva versión al historial de archivo. VSS le pregunta en este caso si desea realizar una operación de protección. Si hace clic en No, VSS ejecutará el comando Deshacer desprotección y no se agregará ninguna versión nueva a la lista de archivos.

Nota Para evitar este mensaje en futuras ocasiones, puede desactivar esta notificación en la ficha General del cuadro de diálogo Opciones de SourceSafe en el menú Herramientas.

Proteger desde múltiples desprotecciones

En una situación de desprotección múltiple, cuando es el primer usuario que protege el archivo en VSS, su versión del archivo se convierte en la versión más reciente. Sin embargo, si usted es el siguiente usuario que protege el archivo, VSS realizará una combinación automática, creando un nuevo archivo como versión más reciente en VSS.

VSS le informa que tuvo lugar una combinación. Puede proteger inmediatamente el archivo o conservar el archivo combinado en su carpeta de trabajo y revisarlo antes de devolverlo a VSS. Si hay conflictos de combinación no puede proteger el archivo hasta que resuelva los conflictos.

Opciones del cuadro de diálogo

Comentario

Escriba un comentario opcional. Los comentarios están limitados a 4095 caracteres.

Mantener desprotegido

Actualiza la copia maestra con sus cambios pero deja el archivo desprotegido.

Quitar copia local

Quita la copia local de su carpeta de trabajo.

Aceptar

Confirma la selección.

Cancelar

Cancela la selección.

Diferencias

Compara el archivo que desea proteger con la copia maestra de VSS y muestra las diferencias. Esta característica es útil si desea especificar un comentario adecuado al proteger el archivo.

Recursivo (sólo al proteger a nivel de proyecto)

Indica que desea proteger los archivos de todas las subcarpetas agregadas cuando seleccione proteger un proyecto completo.

Ignorar carpetas de trabajo (sólo al proteger a nivel de proyecto)

Modifica el conjunto de carpetas de trabajo a las que se aplica una operación recursiva. Esto es útil si tiene algunos archivos compartidos desprotegidos en más de un proyecto y desea protegerlos todos a la vez. Está disponible sólo cuando hace clic en la casilla de verificación Recursivo.


Diferencias de archivo (Cuadro de diálogo)

Vea también

Muestra las diferencias existentes entre la versión de la carpeta de trabajo del archivo seleccionado y la versión de la base de datos de VSS de dicho archivo.

Para mostrar el cuadro de diálogo Diferencias de archivo

  1. Haga clic en un archivo del panel de archivos del Explorador de VSS.

  2. En el menú Herramientas, haga clic en Mostrar diferencias.

  3. Si los archivos comparados son iguales, se mostrará un mensaje para indicar que los archivos son idénticos. VSS no puede mostrar las diferencias de los archivos binarios; sólo puede indicar si los archivos binarios son distintos o no. Si los archivos de texto difieren, VSS mostrará el cuadro de diálogo Diferencias de archivo.

  4. Haga las selecciones deseadas en el cuadro de diálogo Diferencias de archivo, si está activado, y haga clic en Aceptar.

Nota Active la presentación del cuadro de diálogo Opciones de diferencia en la ficha Diálogos de comandos del cuadro de diálogo Opciones de SourceSafe (menú Herramientas).

Comentarios

El cuadro de diálogo Diferencias de archivo muestra dos archivos puestos lado a lado. Utiliza tres colores con el fin de señalar la líneas eliminadas, modificadas o agregadas. Puede cambiar los colores al establecer las opciones de la ficha Diferencias del cuadro de diálogo Opciones de Herramientas. No puede hacer cambios a los archivos en este cuadro de diálogo: sólo permite mostrar las diferencias.

Nota Para comparar un archivo actual de VSS con una versión anterior del mismo archivo, haga clic en el archivo en el panel de archivos del Explorador de VSS y, en el menú Herramientas, haga clic en Mostrar historial. Después, haga clic en Diferencias.

Opciones del cuadro de diálogo

Dicho cuadro dispone de una barra de herramientas que contiene todos los comandos que necesita para buscar y marcar diferencias:

Buscar

Permite buscar una cadena en el archivo. La tecla de método abreviado es Alt-F3.

Buscar siguiente

Permite buscar la aparición siguiente de una cadena en el archivo. La tecla de método abreviado es F3.

Buscar anterior

Permite buscar la aparición anterior de una cadena en el archivo. La tecla de método abreviado es Mayús-F3.

Alternar marcador

Permite activar o desactivar un marcador en un archivo. La tecla de método abreviado es Ctrl-F2.

Marcador siguiente

Permite ir al marcador siguiente en el archivo. La tecla de método abreviado es F2.

Marcador anterior

Permite ir al marcador anterior en el archivo. La tecla de método abreviado es Mayús-F2.

Borrar todos los marcadores

Permite borrar todos los marcadores en el archivo.

Diferencia anterior

Permite encontrar la diferencia anterior en el archivo. La tecla de método abreviado es Mayús-F7.

Diferencia siguiente

Permite buscar la diferencia siguiente en el archivo. La tecla de método abreviado es F7.


Visor de VSS (Cuadro de diálogo)

Permite modificar o mostrar un archivo que no está asociado con ningún programa.

Opciones del cuadro de diálogo

Este cuadro de diálogo incluye una de herramientas con los botones siguientes:

Guardar

Guarda su archivo modificado a disco.

Cortar

Corta la selección en el archivo y la coloca en el Portapapeles. La tecla de método abreviado es Ctrl-X.

Copiar

Copia la selección en el Portapapeles. La tecla de método abreviado es Ctrl-C.

Pegar

Pega el contenido del Portapapeles en la posición del cursor. La tecla de método abreviado es Ctrl-V.

Deshacer

Deshace su última acción de edición. La tecla de método abreviado es Ctrl-Z.

Rehacer

Vuelve a realizar la última acción de edición deshecha. La tecla de método abreviado es Ctrl-A.

Buscar

Permite buscar una cadena en el archivo. La tecla de método abreviado es Alt-F3.

Buscar siguiente

Permite buscar la aparición siguiente de una cadena en el archivo. La tecla de método abreviado es F3.

Buscar anterior

Permite buscar la aparición anterior de una cadena en el archivo. La tecla de método abreviado es Mayús-F3.

Alternar marcador

Permite activar o desactivar un marcador en un archivo. La tecla de método abreviado es Ctrl-F2.

Marcador siguiente

Permite ir al marcador siguiente en el archivo. La tecla de método abreviado es F2.

Marcador anterior

Permite ir al marcador anterior en el archivo. La tecla de método abreviado es Mayús-F2.

Borrar todos los marcadores

Permite borrar todos los marcadores en el archivo.


Distribuir (Cuadro de diálogo)

Le permite establecer opciones para la distribución de su proyecto de sitio Web.

Opciones del cuadro de diálogo

Si activa el cuadro de diálogo del comando Distribuir en la ficha Diálogos de comandos del cuadro de diálogo Opciones de SourceSafe (menú Herramientas), o si mantiene presionada la tecla MAYÚSCULAS mientras hace clic en el comando Distribuir, tendrá las opciones siguientes:

En

Escriba la ruta de acceso en la que desea que VSS coloque los archivos. Puede examinar la ubicación apropiada.

Permitir escritura

Establece el indicador de lectura y escritura de forma que el archivo sea modificable. No es el comportamiento predeterminado, pero puede resultar útil si desea probar un cambio temporal en el archivo o desea cambiar el nombre del archivo después de obtenerlo.


Si tienen otras necesidades de soporte

Si no tienen acceso a Internet

Las FastTip son un servicio de respuesta por fax gratuito y automatizado que proporciona artículos de la popular Knowledge Base y respuestas rápidas a las cuestiones técnicas más comunes. Para obtener acceso, marque el (800) 936-4300.

Si necesita servicios de soporte para un negocio pequeño, mediano o grande

Las opciones Priority Annual Support, Priority Plus y Premier Support proporcionan una selección de paquetes de soporte anual que se ajustan a las empresas. Para determinar qué cuenta se adapta mejor a sus necesidades de negocio, vaya a http://www.microsoft.com/spanish/soporte. O llame al (800) 936-3500 si desea información sobre las opciones de soporte para negocios pequeños y medios, o al (800) 936-3200 para grandes empresas.

Si necesita soporte técnico a domicilio, de varios proveedores o de productos propietarios

Los Microsoft Certified Solution Providers y los Authorized Support Centers se especializan en proporcionar paquetes de soporte para productos hardware, software y de red tanto de Microsoft como de otros fabricantes. Si desea más información o una referencia a un Microsoft Certified Solution Provider, llame al (800) 765-7768 entre las 6:30 A.M. y las 5:30 P.M., de lunes a viernes, excepto festivos, o visite http://www.microsoft.com/spain/mcsp. Si desea más información sobre los Authorized Support Centers, póngase en contacto con su proveedor de Microsoft, o visite http://www.microsoft.com/enterprise/asc.htm.

Si necesita servicios de teléfono-texto (TTY/TDD)

En EE.UU, llame al (425) 635-4948, o en Canadá, llame al (905) 568-9641.

Los servicios de soporte de Microsoft están sujetos a los precios, términos y condiciones de Microsoft en el lugar y hora en que se utiliza el servicio y están sujetos a cambios sin previo aviso.


Si tiene una pregunta sencilla y necesita una rápida respuesta

Encontrar sus respuestas en línea rápidamente

Use el Soporte en línea para buscar en la Microsoft Knowledge Base y otros recursos de información técnica las respuestas rápidas y certeras. También puede personalizar el sitio para controlar su búsqueda. Para comenzar su búsqueda, vaya a http://www.microsoft.com/spanish/soporte.

Si desea recursos e información técnica adicional sobre el desarrollo con productos y tecnologías de Microsoft, visite MSDN en línea en http://www.microsoft.com/spain/msdn.


Si necesita soporte fuera de Estados Unidos y Canadá

Soporte técnico de Microsoft en el mundo

Si está fuera de los EE.UU. y tiene una pregunta sobre un producto Microsoft, primero:

  • Compruebe la información de su archivo de Ayuda o el manual del producto.

  • Compruebe los archivos Léame que vienen con los discos o disquetes del producto. Esos archivos proporcionan información general de la que se dispone justo antes que se libere el producto.

  • Vaya al Soporte en línea del Soporte técnico de Microsoft en http://www.microsoft.com/spanish/soporte.

Si no puede encontrar una solución, puede recibir información sobre cómo obtener soporte técnico contactando con el distribuidor de Microsoft de su área.

Importante Los números de teléfono de los distribuidores de Microsoft están sujetos a cambios. Para obtener la lista más reciente, consulte la sección de opciones y números de teléfono en el sitio Web de Soporte en línea en http://www.microsoft.com/spanish/soporte. Si no hay distribuidor de Microsoft en su país/región, póngase en contacto con el establecimiento en el que ha obtenido su producto Microsoft.

  • Acerbaiyán

    Consulte Rusia

  • Alemania

    Microsoft GmbH
    Teléfono: 089/3176-0
    Fax: 089/3176-1000
    Telex: (17) 89/83 28 MS GMBH D
    Información: 089/3176-1199
    Precios, actualizaciones, etc.: 8105-25-1199
    Internet: www.microsoft.com/germany
    Soporte estándar:
    Instalación y control: 01805/67 22 55
    Información general sobre soporte Microsoft en Europa central: Fax: 1805-25-1191

  • América central

    Consulte Latinoamérica

  • Arabia Saudí

    Microsoft Saudi Arabia
    Teléfono: +966-1-488-1165
    Fax: +966-1-488-1576
    Soporte técnico:
    (Sólo para Sistema operativo personal y aplicaciones de escritorio):
    Teléfono: 800 124 0500
    (gratuito dentro de Arabia Saudí)
    Fax: 966-1-4740576

  • Argentina

    Microsoft de Argentina S.A.
    Servicio al cliente: (54) (1) 316-4600
    Fax: (54) (1) 316-4698
    Soporte técnico: (54) (1) 316-4664

  • Armenia

    Consulte Rusia

  • Australia

    Microsoft Pty. Ltd.
    Fax: (61) (02) 9805 1108
    Centro de información de ventas: (61) (02) 9870 -2100
    Internet: //www.microsoft.com.au/
    Soporte técnico: (61) (02) 9870 -2131
    Fax: (61) (02) 9805 0519

  • Austria

    Microsoft Ges.m.b.H.
    Teléfono: (+43) 1 610 64 -0
    Fax: (+43) 1 610 64 -200
    Información: 0660-6520
    Precios, actualizaciones, etc.: 0660-6520
    Soporte estándar:
    Instalación y control: 01 50222-2255
    Información general sobre Support Network en Europa central:
    Fax: 01805-251191

  • Bélgica

    Microsoft NV
    Teléfono: +32-2-730 39 11
    Fax: +32-2-726 96 09
    Centro de Información de Microsoft: +32-2-481 52 52
    Boletín electrónico: +32-2-726 85 45 (14400/1200/2400/9600 bd, 8N1, ANSI)
    Soporte técnico:+32-2-513 32 74 (en holandés)
    +32-2-502 34 32 (en inglés)
    +32-2-513 22 68 (en francés)

  • Bielorrusia

    Consulte Rusia

  • Bolivia

    Consulte Argentina

  • Brasil

    Microsoft Informatica Ltda.
    Teléfono: (55) (11) 5514 -7100
    Fax: (55) (11) 5514 - 7106/5514-7107
    Soporte técnico: (55) (11) 5506 -8087
    Fax: (55) (11) 5506 -7621
    Fax automático: (55) (11) 5506 -8506
    Boletín electrónico de soporte técnico: (55) (11) 5506 -1234
    Soporte al cliente: (55) (11) 822-5764

  • Canadá

    Microsoft Canada Inc.
    Teléfono de la oficina principal: 1 (905) 568-0434
    Centro de información al cliente: 1 (800) 563-9048
    Soporte técnico: Sistemas de escritorio incluyendo Microsoft Windows 95: (905) 568-4494
    Microsoft Office y componentes de Office: (905) 568-2294
    Resto de soporte técnico estándar: (905) 568-3503
    Información de soporte prioritaria: (800) 668-7975
    Teléfono-texto (TTY/TDD) (905) 568-9641
    Boletín electrónico de soporte técnico: (905) 507-3022

  • Caribe

    Microsoft Caribbean, Inc.
    Teléfono: (809) 273-3600
    Fax: (809) 273-3636
    Soporte técnico: (214) 714-9100

  • Chile

    Microsoft Chile S.A.
    Teléfono: 56-2-330-6000
    Fax: 56-2-330-6190
    Servicio al cliente: 56-2-800-213121
    Sistema Operativo personal y aplicaciones de escritorio:
    Teléfono: 56-2-330-6222
    Fax: 56-2-341-1439

  • China

    Microsoft (China) Co. Ltd
    4/F Kai Yuen Commercial Building
    No.28 Zhichunli, Hai Dian District
    Beijing 100086, PRC
    Teléfono: 011-86-10-6261-7711
    Fax: 011-86-10-6253-6630

  • Colombia

    Microsoft Colombia
    Teléfono: (571) 618 2245
    Fax: (571) 618 2269
    Soporte técnico:
    Línea de Respuesta Microsoft
    Teléfono: (571) 5230022
    Fax: (571) 5231220
    Teléfono de voz: (571) 5034216

  • Corea

    Microsoft CH
    Teléfono: (82) (2) 531-4500
    Fax: (82) (2) 531-1724
    Servicio al cliente: 080-022-7337 (gratuito, sólo para particulares)
    Soporte técnico: Soporte técnico para Office: (82) (2) 508-0040
    Soporte técnico de Windows: (82) (2) 563-54
    Soporte técnico al programador: (82) (2) 566-71
    Microsoft FastTips: (82) (2) 3453-7555
    Soporte de ventas: (82) (2) 531-4544

  • Croatia

    Microsoft Hrvatska d.o.o.
    Teléfono: (+385) (1) 304 555
    Fax: (+385) (1) 335 051
    Soporte técnico: (Póngase en contacto con el distribuidor.)

  • Dinamarca

    Microsoft Denmark
    Teléfono: (45) 44 89 01 00
    Fax: (45) 44 68 55 10
    Soporte técnico:Teléfono: (45) 44 89 01 11
    Soporte de ventas de Microsoft (45) 44 89 01 90
    Microsoft FastTips: (45) 44 89 01 44
    (El documento 769.696,20 cm de las FasTips contiene instrucciones detalladas) Microsoft MSDL (BBS): (45) 44 66 90 46

  • Dubai

    Microsoft Middle East
    Teléfono: (971) 4 513 888
    Fax: (971) 4 527 444
    Soporte técnico:SÓLO para sistemas personales y aplicaciones de escritorio:
    Teléfono: (971) (4) 524 488
    Fax: (971) 4 -524 495
    correo electrónico: mts@emirates.net.ae
    Información de soporte prioritaria: (971) (4) 555 752
    Centro de servicio al cliente:
    (Version upgrade / TechNet and MSDN subscription)
    Teléfono: (971) (4) 655 082
    Fax: (971) (4) 655 097

  • Ecuador

    Corporation Microsoft del Ecuador S.A.
    Teléfono: (593) 2 460-447, (593) (2) 460-451
    Servicio al cliente: (593) (2) 460-453, (593) (2) 460-458
    Soporte técnico: (593) (2) 463-094

  • Egipto

    Microsoft Egypt
    Teléfono: +202-418-6101
    Fax: +-4174766
    Soporte técnico:SÓLO para sistemas personales y aplicaciones de escritorio:
    Teléfono: (202) 261 3991 / 6
    Fax: (971) 403 2718

  • Escocia

    Consulte Reino Unido

  • Eslovenia/Slovenija

    Microsoft d.o.o.
    Teléfono: (+386) (61) 1800 8-00
    Fax: (+386) (61) 1800 822
    Soporte técnico: (+386) (61) 185 3449

  • España

    Microsoft Iberica SRL
    Teléfono: (34) 1-807-9999
    Fax: (34) 1-803-8310
    Soporte técnico: (34) 1 -3754004
    Servicio al cliente: (34) 1 -3754004
    Teléfono de fax según demanda: (34) 1-3754004

  • Estonia

    Consulte Alemania
    Soporte técnico: (+372) 650 49 99

  • Filipinas (SP)

    Microsoft Philippines
    Teléfono: 632 811 0062
    Soporte técnico: Teléfono: 632 892 2295/2495
    Fax: 632 813 2493

  • Finlandia

    Microsoft OY
    Teléfono: +358-(0) 9-525 501
    Fax: +358-(0) 9-878 8770
    Soporte técnico:
    Teléfono: +358-(0) 9-525 502 500
    Soporte de ventas: +358-(0) 9-525 5026
    Microsoft MSDL: +358-(0) 9-878 77 99
    (Información en sueco e inglés)
    Microsoft FastTips: +358-(0) 9-525 550 500
    (Información en sueco e inglés)

  • Francia

    Microsoft France
    Teléfono: (33) 01 69-86-46-46
    Fax: (33) 01 64-46-6-60
    Telex: MSPARIS 604322
    Soporte técnico:
    Teléfono: (33) 01 -69-86-10-20
    Fax: (33) (01) 69-28-00-28

  • Gales

    Consulte Reino Unido

  • Georgia

    Consulte Rusia

  • Grecia

    Microsoft Hellas, S.A.
    Teléfono: (30)(1) 6806-775 hasta (30)(1) 6806-779
    Fax: (30)(1) 6806-780
    Soporte técnico: Teléfono: (30) (1) 9247-030
    Fax: (30) (1) 9215-363

  • Holanda

    Microsoft BV
    Teléfono: 023-5689189
    Servicio al cliente: 023-5677700
    Boletín electrónico: 023-5634221
    (1200/2400/9600/14400 bd, 8N1, ANSI)
    Soporte técnico:023-5677877 (en holandés)
    023-5677853 (en inglés)

  • Hong Kong SAR, RPC

    Microsoft Hong Kong Limited
    Fax: (852) 2560-2217
    Servicio de Fax bajo demanda de soporte al producto: (852) 2535-9293
    Microsoft Club Hotline: (852) 28044277
    Soporte técnico: (852) 2804-4222

  • Hungría

    Microsoft Hungary
    Teléfono: +36 (1) 327-2800
    Fax: +36 (1) 327-2899
    Soporte técnico: +36 (1) 267-4636 (2MSINFO)

  • India

    Microsoft India
    Teléfono: (011) (91) (80) 5092678, (011) (91) (11) 646 0767, 646 0813
    Fax: (011) (91) (80) 509-2601, (011) (91) (11) 647- 4714

  • Indonesia (SP)

    Microsoft Indonesia - Jakarta
    Soporte técnico: Teléfono: 62 21 5721060
    Fax: 62 21 5732077

  • Inglaterra

    Consulte Reino Unido

  • Irlanda

    Consulte Reino Unido

  • Irlanda del Norte

    Consulte Reino Unido

  • Islandia

    Consulte Dinamarca

  • Israel

    Microsoft Israel Ltd.
    Teléfono: 972-3-613-833
    Fax: 972-3-613-0834

  • Italia

    Microsoft SpA
    Teléfono: (39) (2) 7039-21
    Fax: (39) (2) 7039-2020
    Oficina de Microsoft en Roma: (39) (6) 5095-01 - Fax: (39) (6) 5095-0600
    Microsoft por fax (Servicio de fax bajo demanda): (39) (2) 70-398-888
    Servicio al cliente (Información sobre productos nuevos, bibliografía sobre productos): (39) (2) 70-398-398
    Soporte al comerciante (Servicio al cliente sólo para distribuidores): (39) (2) 70-398-388
    Soporte técnico: (39) (2) 70-398-398
    Servicio de consulta de Microsoft: (39) (2) 7039-21

  • Japón

    Microsoft Company Ltd.
    Soporte técnico (Soporte estándar): (81) (424) 41-8700
    (Opciones de soporte técnico/Contratos de soporte):
    Teléfono: 120-37-196 (gratuito, sólo para particulares)
    Centro de Información de Marketing del Canal:
    (Soporte al producto previo a ventas)
    Teléfono de Tokio: (81) (3) 5454-2300
    Teléfono de Osaka: (81) (6) 245-6995
    Teléfono de servicio al cliente:
    (Versión actualización/Registro)
    Teléfono: (81) (48) 226-5500
    Fax: (81) (48) 226-5511

  • Kazajistán

    Consulte Rusia

  • Kirgizia

    Consulte Rusia

  • Latinoamérica

    Microsoft
    Latin American Headquarters (U.S.A.)
    Teléfono: (305) 489-4800
    Fax: (305) 491-1616
    Servicio al cliente: (425) 936-8661
    Soporte técnico: (214) 714-9100
    http://www.microsoft.com/latam/soporte

  • Liechtenstein

    Consulte Suiza (en alemán)

  • Luxemburgo

    Microsoft NV
    Teléfono: +32-2-730 39 11
    Centro de Información de Microsoft: +32-2-481 52 52
    Boletín electrónico: +32-2-726 85 45
    (1200/2400/9600/14400 bd, 8N1, ANSI)
    Soporte técnico:+32-2-513 32 74 (en holandés)
    +32-2-502 34 32 (en inglés)
    +32-2-513 22 68 (en francés)

  • Malasia (SP)

    Microsoft (Malaysia) Sdn Bhd:
    Teléfono: (60-3) 793-9595
    Fax: (60-3) 791-6080

  • Marruecos

    Microsoft Afrique Du Nord
    Teléfono: (212) 2 47 10 72
    Fax: (212) 2 47 10 86

  • México

    Microsoft México, S.A. de C.V.
    267-2110 Atención a Distribuidores
    265-3380 Atención a Clientes
    265-3399 Soporte Sistemas Operativos y Applicaciones de Escritorio
    267-2190 Soporte de Servidores y Herramientas de Desarrollo
    Fast Tips: (52)(5) 2612199
    Microsoft BBS 628-6200/02 MSMEXICO sin password

  • Noruega

    Microsoft Norway AS
    Teléfono: +(47) 22 02 25 00
    Fax: +(47) 22 95 06 64
    Soporte técnico: +(47) 22 02 25 50
    Soporte de ventas de Microsoft +(47) 22 02 25 80
    Microsoft MSDL: +(47) 22 18 22 09
    Microsoft FastTips: +(47) 22 02 25 70
    (El documento 404040 de las FasTips contiene instrucciones detalladas)

  • Nueva Zelanda

    Microsoft New Zealand Ltd
    Teléfono: 64 (9) 357-5800
    Fax: 64 (9) 358-3726
    Soporte técnico:Teléfono: 64 (9) 357-5575
    Fax: 64 (9) 307-0516 y 357-5577

  • Papúa Nueva Guinea

    Consulte Australia

  • Paraguay

    Consulte Argentina

  • Perú

    Consulte Latinoamérica

  • Polinesia francesa

    Consulte Francia

  • Polonia

    Microsoft Sp. z o.o.
    Teléfono: +(48-22) 661-54-00
    Fax: +(48-22) 661-54-34
    Servicio de información: +(48-22) 865-99-33
    Soporte técnico: +(48-22) 865-99-66

  • Portugal

    Microsoft Portugal MSFT, Lda.
    Teléfono: (351) 1 4409200
    Fax: (351) 1 4412101
    Soporte técnico:Soporte estándar: (351) 1 4409280/1/2/3
    Fax: (351) 1 4411655
    República de Irlanda
    Consulte Reino Unido

  • Región de Taiwán

    Microsoft Taiwan Corp.
    Teléfono: (886) (2) 504-3122
    Fax: (886) (2) 504-3121
    Soporte técnico: (886) (2) 508-9501

  • República Checa

    Microsoft s.r.o.
    Teléfono (+42) (2) 611 97 111
    Fax: (+42) (2) 611 97 100
    Soporte técnico: (+420) (2) 2150 3222

  • República de Eslovaquia

    Microsoft Slovakia s.r.o.
    Teléfono (+421) (7) 37 63 02
    Fax: (+421) (7) 37 66 71
    Soporte técnico: (+421) (7) 531 20 83

  • República Dominicana

    Consulte América Central

  • Rumanía

    Microsoft s.r.l.
    Teléfono: (+40) (1) 222 90 16
    Fax: (+40) (1) 222 90 12
    Soporte técnico: (+40) (1) 312 09 48

  • Rusia

    Microsoft A/O
    Centro de Información de Microsoft: (095)-913-99-88

  • Singapur

    Microsoft Singapore Pte Ltd
    Teléfono: (65) 337-6088
    Fax: (65) 337-6788
    Servicio al cliente:
    Teléfono: (65) 433-5488
    Fax: (65) 339-9958
    Servicios de soporte al producto:
    Teléfono: (65) 337-9946
    Fax: (65) 337-6700

  • Sudáfrica

    Microsoft South Africa
    Teléfono: (27) 11 445 0000
    Fax: (27) 11 445 0046
    Soporte técnico:(Gratuito): 0 802 11 11 04
    (Gratuito): (27) 11 445 0000
    Fax: (+27) 11 445-0343

  • Sudeste de África e Islas del Océano Índico

    Consulte Sudáfrica

  • Suecia

    Microsoft AB
    Teléfono: +46-(0)8-752 56 00
    Fax: +46-(0)8-750 51 58
    Soporte técnico: +46-(0)8-752 09 29
    Soporte de ventas: +46-(0)8-752 56 30
    Microsoft MSDL: +46-(0)8-750 47 42
    Microsoft FastTips: +46-(0)8-752 29 00
    (El documento 202020 de las FasTips contiene instrucciones detalladas)

  • Suiza

    Microsoft AG
    Teléfono: 01-839 61 11
    Fax: 01-831 08 69
    Precios, actualizaciones, etc.: 01/839 61 11
    Mapa de la documentación
    Teléfono: 155 59 00
    Fax: 064-224294, Microsoft Info-Service, Postfach, 8099 Zürich
    Soporte técnico estándar: Instalación y control:
    0848 80 - 2255
    Soporte técnico (en francés): 022-738 96 88
    Información general sobre soporte Microsoft en Europa central:
    FAX: 0049/2622/167006

  • Tadzhikistán

    Consulte Rusia

  • Tailandia

    Microsoft (Thailand) Limited
    Teléfono: (662) 266-3300
    Fax: (662) 266-3310
    Soporte al producto:
    Teléfono: (662) 613-7208 hasta 11
    Fax: (662) 613-7198

  • Turkmenistán

    Consulte Rusia
    Reino Unido
    Microsoft Limited
    Fax: (0870) 60 20 100
    Teléfono: (0870) 60 10 100
    Microsoft KeyData:
    (Boletín electrónico)
    (0870) 50 30 200 (hasta 28,8Kbaud, n, 8, 1)
    Microsoft KeyFax:
    (Servicio de información por fax según demanda)
    (0870) 50 30 100
    Soporte técnico: Aplicaciones de escritorio, Productos para el hogar, Sistemas de escritorio y hardware:
    0870 50 10 100
    Productos de programación:
    0870 50 10 200
    Sistemas de empresa: 0870 50 10 300
    Los clientes que llaman desde Irlanda deben marcar el 706 5353 para soporte técnico.
    Minicom Line 0870 50 30 400
    Información previa a ventas: Microsoft Connection (0345) 00 2000

  • Turquía

    Microsoft Turkey
    Teléfono: 90 (212) 258 59 98
    Fax: 90 (212) 258 59 54
    Soporte Hotline:
    Teléfono: 90 (212) 258 96 66
    Fax: 90 (212) 258 95 99
    Boletín electrónico: 90 (212) 227 93 90

  • Uruguay

    Soporte técnico: (598) (2) 77-4934

  • Uzbekistán

    Consulte Rusia

  • Venezuela

    Corporation MS 90 de Venezuela S.A.
    Otra información: (582) 265-9922
    Fax: (582) 265-0863
    Soporte técnico: (582) 993-6755


Si su pregunta no es urgente

Enviar un mensaje de correo electrónico a un ingeniero del soporte técnico de Microsoft

Con la Respuesta Web, puede enviar cuestiones convenientemente a través de correo electrónico. Esta opción es ideal para cuestiones detalladas o cuestiones con archivos adjuntos. Puede enviar cuestiones las 24 horas del día y recibirá una respuesta de un ingeniero dentro del primer día laborable. Para enviar su pregunta, vaya a http://www.microsoft.com/spanish/soporte, busque la opción Respuesta de Web y elija una de las siguientes opciones.

Respuesta estándar sin cargo en el Web

La cantidad de soporte sin cargo a la que tiene derecho se describe en el apartado anterior titulado Soporte estándar sin cargo.

Respuesta en el Web de pago por incidente

Si ha gastado su Soporte estándar sin cargo que se describe anteriormente, puede enviar su pregunta por una cuota de $95 USA.


Si su pregunta es urgente y más complicada

Llamar a un ingeniero del Soporte Técnico de Microsoft

El Soporte técnico de Microsoft proporciona un soporte telefónico sin cargo y por cuota. La cantidad de soporte sin cargo variará dependiendo de la edición del producto que haya adquirido, tal como se describe más adelante.

Soporte estándar sin cargo durante las horas de trabajo normales

Nota El soporte sin cargo está disponible sólo para versiones actuales.

  • Si ha adquirido Visual Studio Edición profesional, Visual Basic Edición empresarial o Visual C++ Edición empresarial

    Recibirá soporte sin cargo para un total de dos incidencias. Puede aplicar esas dos incidencias sin cargo a cualquiera de los productos que se incluyen en la edición que ha adquirido. Si desea información adicional, consulte la nota más abajo.

  • Si ha adquirido Visual Studio Edición empresarial

    Recibirá soporte sin cargo para un total de cuatro incidencias. Puede aplicar esas cuatro incidencias sin cargo a cualquiera de los productos que se incluyen en Visual Studio Edición empresarial. Si desea información adicional, consulte la nota más abajo.

  • Si ha adquirido Visual Basic Edición profesional, Visual C++ Edición profesional, Visual J++, Visual InterDev, Visual FoxPro o Visual Source Safe

    Recibirá soporte sin cargo para un total de dos incidencias para el producto que ha adquirido.

Para recibir soporte estándar sin cargo para los productos descritos anteriormente

Puede recibir Soporte estándar sin cargo a través de correo electrónico o por teléfono llamando al (425) 635-7012 entre las 6:00 A.M. y las 6:00 P.M., hora del Pacífico, de lunes a viernes, excepto festivos.

Nota Microsoft Internet Explorer, Windows NT Option Pack y FrontPage puede que se hayan incluido con uno de los productos que ha adquirido, sin embargo las opciones de soporte disponibles están separadas de las que se mencionaron anteriormente. Si tiene alguna pregunta con respecto a alguno de estos productos, consulte la sección de soporte técnico del archivo de Ayuda del producto individual.

  • Si ha adquirido Visual Basic Edición de aprendizaje, Visual C++ Edición estándar, Visual J++ Edición estándar o MSDN Library Edition

    Sólo recibirá soporte sin cargo para incidencias relacionadas con la configuración y la instalación. Para todas las demás cuestiones necesitará adquirir Soporte de pago por incidente tal y como se describe más adelante. Puede recibir Soporte estándar sin cargo por teléfono llamando al (425) 635-7033 entre las 6:00 A.M. y las 6:00 P.M., hora del Pacífico, de lunes a viernes, excepto festivos.

Soporte con cargo, para ayudar fuera del horario normal o como suplemento al soporte estándar

Si necesita ayuda fuera de tiempo, o si ha utilizado sus incidencias del Soporte estándar sin cargo que se describieron anteriormente, puede adquirir el Soporte de pago por incidencia por una cuota de $95 USA por incidencia llamando al (800) 936-5800. Las cuotas de soporte se facturarán con cargo a su tarjeta VISA, MasterCard o American Express. En EE.UU, puede llamar también al (900) 555-2300 para hacer que se apliquen las cuotas a su factura de teléfono.


Archivar bases de datos

Vea también

Periódicamente, conviene hacer una copia de seguridad de la base de datos de VSS en totalidad o en parte. Ahora es posible archivar bases de datos desde el programa Administrador de VSS. En las versiones anteriores de VSS, los programas Archive y Restore estaban disponibles desde la línea de comandos tan sólo.

La operación de archivo le permite:

  • Ahorrar el espacio disco del servidor de la base de datos de VSS.

  • Hacer que el comando Mostrar historial funcione más rápidamente.

  • Transferir archivos y proyectos entre bases de datos de VSS, manteniendo la información de historial intacta.

  • Hacer una copia de seguridad de parte o de la totalidad de la base de datos de VSS en un archivo comprimido

Para archivar una base de datos:

  1. Abra la base de datos cuya información desea archivar. Vea Cómo abrir una base de datos para obtener más información.

  2. En el menú Archivar, haga clic en Archivar proyectos para mostrar el Asistente para archivar.

  3. Seleccione el proyecto que desea archivar.

  4. Haga clic en Aceptar.

  5. Si existen proyectos adicionales que desea agregar al archiva, hágalo en el paso 1 del asistente.

  6. Haga clic en Siguiente.

  7. En el paso 2 del asistente, especifique cómo desea archivar el proyecto.

  8. Si está activada la casilla Guardar datos en archivo o Guardar datos en archivo y después eliminar de la base de datos para ahorrar espacio, escriba el nombre del archivo en el que deben guardarse los proyectos en el cuadro Archivo de almacenamiento.

    -O bien-

    Haga clic en Examinar par buscar y seleccionar un archivo almacenado. Esto sobrescribirá los archivos existentes.

    -O bien-

    Si está activada la casilla Eliminar datos definitivamente, se deshabilitará el cuadro Archivo de almacenamiento.

  9. Haga clic en Siguiente.

  10. En el paso 3 del asistente, especifique la versión de los datos que desea archivar (intervalo de versión). Puede también agregar un comentario en el cuadro Comentario si lo desea.

Nota Para archivar por el número de versión, escriba tan sólo el número en el cuadro de versión, por ejemplo: 5. Para archivar por etiqueta, escriba L seguido de la cadena de la etiqueta, por ejemplo: "LmiEtiqueta". Para archivar por fechas, escriba D seguido de una cadena de fecha, por ejemplo: D26/11/98.

  11. Haga clic en Finalizar para completar la operación de archivo.


Limpiar la carpeta temporal

Vea también

Como administrador de VSS, tiene la responsabilidad de limpiar la carpeta Temp apuntada por la variable de inicialización Temp_Path en el archivo SRCSAFE.INI.

VSS coloca normalmente archivos en la carpeta Temp durante su ejecución y los elimina antes de salir. Algunas circunstancias, como la necesidad de reiniciar, pueden hacer que archivos permanezcan en la carpeta Temp, malgastando el espacio de disco.

Limpie la carpeta Temp cada pocas semanas, cuando no hay usuarios ejecutando VSS o el Administrador de VSS.

Para limpiar la carpeta temporal:

  1. En el menú Herramientas, haga clic en Limpiar directorio de temporales para mostrar el cuadro de diálogo Limpiar directorio local de archivos temporales.

  2. Haga clic en Aceptar.


Abrir una base de datos

Para abrir una base de datos de VSS:

  1. En el menú Usuarios del Administrador de VSS, haga clic en Abrir base de datos de SourceSafe para mostrar el cuadro de diálogo Abrir base de datos de SourceSafe.

  2. Seleccione una base de datos en la lista.

    Nota Si la base de datos no se encuentra en la lista de bases disponibles, haga clic en Examinar. Explore hasta el archivo SRCSAFE.INI de una base de datos de VSS existente y a continuación haga clic en el archivo. Haga clic en Abrir para agregar una base de datos a la lista.

  3. Haga clic en Abrir en el cuadro de diálogo Abrir base de datos de SourceSafe.


Restaurar bases de datos

Vea también

Puede ahora restaurar bases de datos mediante el programa Administrador de VSS. En las versiones anteriores de VSS, los programas Archive y Restore estaban disponibles desde la línea de comandos tan sólo.

Para restaurar una base de datos:

  1. Abra la base de datos en la que desea restaurar información. Vea Cómo abrir una base de datos para obtener más información.

  2. En el menú Archivar haga clic en Restaurar proyectos para mostrar el Asistente para restaurar.

  3. Haga clic en Examinar para seleccionar el archivo almacenado que desea restaurar.

  4. Haga clic en Abrir.

  5. En el paso 1 del asistente, haga clic en Siguiente.

  6. En el paso 2 del asistente, seleccione el proyecto o los proyectos que desea restaurar.

  7. Haga clic en Siguiente.

  8. En el paso 3 del asistente, especifique dónde desea restaurar los proyectos. Puede también agregar un comentario en cuadro Comentario si lo desea.

  9. Haga clic en Finalizar para completar la restauración.


Opciones de cuadros de diálogo de comandos (Ficha)

En esta ficha puede especificar si los cuadros de diálogo de comandos se muestran cuando se realizan comandos de VSS.

Si no usa las opciones que se proporcionan en el cuadro de diálogo Obtener la última versión, por ejemplo, puede desactivar el cuadro de diálogo. Cuando se realice el comando Obtener la última versión, no se mostrará el cuadro de diálogo.

Puede especificar si aparece un cuadro de diálogo en los siguientes comandos de archivo:

  • Obtener la última versión

  • Desproteger

  • Deshacer Desproteger

  • Mostrar diferencias

  • Historial

  • Modificar y Ver

Puede especificar si aparece un cuadro de diálogo en los siguientes comandos de proyecto:

  • Obtener la última versión

  • Desproteger

  • Deshacer Desproteger

  • Mostrar diferencias

  • Historial

  • Distribuir

  • Crear mapa del sitios

Para mostrar la ficha Cuadros de diálogo de comandos:

  1. En el menú Herramientas, haga clic en Opciones.

  2. Haga clic en la ficha Cuadros de diálogo de comandos.

Importante Haga caso omiso de cualquier configuración que realice en este cuadro de diálogo manteniendo presionada la tecla MÁYUS al realizar cualquiera de los comandos anteriores. El cuadro de diálogo del comando aparecerá incluso si la casilla de verificación correspondiente de Opciones no se ha seleccionado.


Opciones de línea de comandos (Ficha)

Vea también

En esta ficha puede especificar cómo se realizan las opciones de la línea de comandos de VSS. Estas opciones no afectan al comportamiento del Explorador de VSS.

Para mostrar la ficha Línea de comandos:

  1. En el menú Herramientas, haga clic en Opciones.

  2. Seleccione la ficha Opciones de línea de comandos

Las dos primeras opciones afectan a la forma en que VSS interactúa con su carpeta de trabajo durante las operaciones de la línea de comandos. De forma predeterminada, en el Explorador, VSS espera que se establezca una carpeta de trabajo para cada proyecto y desprotegerá los archivos sólo en esa carpeta. De forma predeterminada, en la línea de comandos, VSS presupone que su proyecto y carpeta actuales son con los que desea trabajar e ignora cualquier otra carpeta de trabajo establecida para un proyecto determinado. Puede modificar este comportamiento activando una de las opciones siguientes.

Las dos primeras opciones de la ficha determinan cómo se utiliza la carpeta de trabajo que tiene establecida.

Asumir que la carpeta de trabajo se basa en el proyecto actual

  • Si se selecciona esta opción, se coloca un archivo en la carpeta de trabajo del proyecto, incluso aunque no sea la carpeta actual cuando ejecuta un comando sobre un archivo desde la línea de comandos.

  • Si no se selecciona esta opción, los subproyectos tendrán sus propias carpetas de trabajo respectivas.

Asumir que el proyecto se basa en la carpeta de trabajo

  • Si se selecciona esta opción, VSS buscará en su carpeta actual siempre que se ejecute cualquier comando de VSS. Si ésta es la carpeta de trabajo para un proyecto de VSS, VSS cambia automáticamente a ese proyecto antes de ejecutar el comando. si establece esta opción, se recomienda encarecidamente que no asigne a dos proyectos la misma carpeta de trabajo; VSS no sabrá a qué proyecto cambiar.

  • Si no se selecciona esta opción, VSS no cambia a su proyecto actual cuando se ejecute cualquier comando de VSS.

Comentarios de desprotección

  • Sin comentarios al desproteger: seleccione esta opción si no desea que se le pida un comentario por desprotección.

  • Aplicar el mismo comentario a todos los archivos: seleccione esta opción si desea que VSS tome un comentario (hasta 64 caracteres) y lo aplique a todos los archivos implicados en la operación de desprotección.

  • Aplicar diferentes comentarios a cada archivo: seleccione esta opción si desea agregar un comentario separada para cada archivo implicado en la operación de desprotección.

Petición de comentario

  • Pedir comentarios en la línea de comandos: seleccione esta opción si desea que VSS le pida comentarios en la línea de comandos.

  • Utilizar editor para pedir comentarios: seleccione esta opción si desea usar un editor para escribir sus comentarios en la línea de comandos. Tras seleccionarlo, escriba la ruta de acceso del editor seleccionado en el cuadro Editor. Haga clic en Examinar para buscar en su sistema de archivos esta información.

  • Usar cadena de petición: seleccione esta opción si desea especificar que una cadena de caracteres solicitada (al pedir un comentario) se inserte en su editor cuando se abra. La cadena solicitada no se guarda con su comentario a menos que cambie la cadena en su editor.

  • Editor: escriba la ruta de acceso del editor seleccionado. Haga clic en Examinar para buscar un editor.

Nota Esta opción está desactivada cuando se selecciona Pedir comentarios en la línea de comandos.


Opciones de diferencia (Ficha)

Vea también

En esta ficha puede especificar opciones para ver diferencias entre archivos o proyectos. Estas opciones se utilizan en otros cuadros de diálogo de VSS como por ejemplo el cuadro de diálogo Diferencia de proyecto, el cuadro de diálogo Combinación visual, el editor de VSS predeterminado y el panel de resultados de VSS.

Para mostrar la ficha Opciones de diferencias

  1. En el menú Herramientas, haga clic en Opciones.

  2. Seleccione la ficha Diferencias

Opciones de la ficha

Puede especificar/modificar todas las opciones siguientes.

Colores

Seleccione los colores de línea que usará VSS. El color de línea seleccionado se muestra en el cuadro Ejemplo.

Primer plano

Seleccione el color del primer plano.

Fondo

Seleccione el color del fondo.

Fuente

Seleccione la fuente que se utiliza en el Explorador de VSS y en todos sus cuadros de diálogo. Para modificar la fuente, haga clic en el botón Modificar.

Ejemplo

Las opciones que haya seleccionado se muestran en este cuadro.

Restablecer

Haga clic aquí para restaurar todos los valores de esta ficha a sus valores predeterminados.

Ancho de tabulación

Especifique el número de espacios al que equivale cada tabulador.

Mostrar números de línea

Seleccione esta casilla para mostrar los números de línea en los visores de diferencias visuales.

Ignorar diferencias en espacios en blanco al combinar archivos

Seleccione esta casilla para ignorar las diferencias de espacios en blanco (tabuladores, caracteres de escape, etc.) al combinar dos archivos.


General (Ficha, cuadro de diálogo Opciones)

En esta ficha puede establecer las propiedades del proyecto seleccionado.

Para mostrar la ficha Opciones generales

  1. Seleccione un proyecto en el explorador de VSS.

  2. En el menú Herramientas, haga clic en Opciones.

  3. Haga clic en la ficha General, si no está ya seleccionada.

Nota Para mostrar esta ficha desde Visual Basic, tras agregar un proyecto Visual Basic a VSS, en el menú Complementos de Visual Basic, elija SourceSafe, y después elija Propiedades de SourceSafe.

Opciones de la ficha

Puede especificar/modificar todas las opciones siguientes.

Mantener los archivos desprotegidos siempre

Seleccione esta casilla para mantener un archivo desprotegido en su carpeta de trabajo, incluso si lo protege en la base de datos del proyecto. El archivo se copia en la base de datos de VSS, pero se deja desprotegido, por lo que puede actualizar la base de datos con sus cambios, pero continuar trabajando sobre el archivo.

Actuar recursivamente en los proyectos

Seleccione esta casilla para realizar todas las acciones sobre un proyecto seleccionado de manera recursiva, esto es, el comando se aplica a los subproyectos (y a sus subproyectos, y así sucesivamente) así como al proyecto seleccionado. Esto es útil si tiene un proyecto con muchos subproyectos que desea desproteger y proteger como una unidad.

Volver a usar el último comentario

Seleccione esta casilla para volver a usar el último comentario para el comando siguiente. Por ejemplo, si protege un archivo con el comentario "Agregados hipervínculos a nuestro menú Ayuda", y después protege otro archivo, se escribe el mismo comentario en el cuadro de comentario de ese archivo. Si modifica el comentario, VSS utilizará el comentario cambiado para el siguiente comando.

Proteger los archivos no modificados

Cuando protege un archivo, y no ha realizado cambios sobre el, VSS mira esta opción para determinar qué debe hacer.

Seleccione una opción de las siguientes:

  • Proteger: indica a VSS que registre la protección como una versión nueva, incluso si no se han detectado cambios en el archivo.

  • Deshacer desprotección: indica a VSS que deshaga la desprotección automáticamente sobre cualquier archivo no cambiado que se intente proteger.

  • Preguntar: indica a VSS que presente un cuadro de diálogo preguntando qué desea hacer para archivo no cambiado.

  • Predeterminado: indica a VSS que actúe dependiendo de los valores de configuración específicos del archivo de inicialización de cada proyecto. Así se indica a VSS cómo determinar lo que debe hacer con los archivos que no han cambiado.

La selección predeterminada es Deshacer desprotección.

Usar combinación visual

Especifique aquí cuándo desea que VSS use la característica de Combinación visual. VSS usa la Combinación visual al combinar archivos tras una bifurcación o una desprotección múltiple. Sus opciones incluyen la utilización de la Combinación visual sólo si hay conflictos, usarla siempre (sí) o no usarla nunca (no). El valor predeterminado es Usar sólo si hay conflictos. Cambie el valor a Sí para ver todos los cambios durante una combinación.

Doble clic en un archivo

Especifica qué comando debería ejecutar VSS al hacer doble clic sobre un archivo.

Sus opciones incluyen:

  • Preguntar: indica a VSS que presente un cuadro de diálogo preguntando qué le gustaría hacer en cada operación.

  • Ver archivo: indica a VSS que presente un cuadro de diálogo automáticamente para ver: no tiene la capacidad de modificar el archivo.

  • Modificar archivo: indica a VSS que desproteja el archivo automáticamente en su carpeta de trabajo, y lo abra para su modificación.

El valor predeterminado es Preguntar.

Editor para ver archivos

Si quiere usar un editor para ver archivos de texto, especifique la ruta de acceso del editor seleccionado en este cuadro, o haga clic en Examinar para buscar un editor.

Carpeta para archivos temporales

Especifique aquí dónde desea que VSS almacene los archivos temporales, o haga clic en Examinar para buscar y seleccionar una ubicación de archivo temporal. El valor predeterminado es la carpeta Temp que se encuentra bajo la carpeta en la que se almacena SRCSAFE.INI.

Nota La creación de su carpeta Temp localmente, en lugar de hacerlo en un servidor, puede aumentar el rendimiento de VSS.


Archivos locales (Ficha)

Vea también

En esta ficha puede establecer o cambiar la manera en que se controlan los archivos en la carpeta de trabajo.

Para ver la ficha Archivos locales:

  1. En el menú Herramientas, haga clic en Opciones.

  2. Seleccione la ficha Archivos locales:

Opciones de la ficha

Quitar copia local después de Agregar o Proteger

Esta opción hacer que VSS elimine automáticamente la copia local de los archivos después de agregarlos o protegerlos. Ayuda a reducir al mínimo la utilización del disco y asegura que siempre tendrá la versión más reciente cuando empiece a trabajar con un archivo. No utilice esta opción si utiliza VSS integrado con Visual Bsic, Visual C++ u otros programas similares.

Quitar copia local después de Eliminar

Esta opción hace que VSS elimine automáticamente la copia de un archivo de la carpeta de trabajo al eliminarlo en VSS. Esto ayuda a mantener la saturación del disco al mínimo. Y, mientras no hay destruido o purgado el archivo en la base de datos VSS, siempre podrá recuperar el archivo más adelante.

Utilizar indicador de sólo lectura para archivos no desprotegidos

Seleccione esta opción para marcar los archivos de su carpeta de trabajo como de sólo lectura.

VSS asumirá entonces que los archivos de su carpeta de trabajo que no están desprotegidos son de sólo lectura. Es altamente recomendable que deje esta opción activada.

Copiar los archivos de claves expandidas a la carpeta de trabajo

Seleccione esta opción para actualizar la información de palabras clave en su carpeta de trabajo al proteger un archivo. Cuando protege un archivo y tiene activada la expansión de palabras, VSS actualiza la información de palabras clave en su archivo. El archivo modificado se reemplaza directamente en VSS. Si no activa esta opción, no se colocará automáticamente una copia de este archivo en su carpeta de trabajo. Si no utiliza esta opción aumentará el rendimiento, pero la copia de su carpeta de trabajo podría no estar actualizada.

Agregar fin de línea a todos los archivos de texto

Utilice esta opción para agregar un carácter de fin de línea siempre que VSS recupere un archivo de texto que no lo incluya. Algunos compiladores requieren que todos los archivos que compilan terminen con un carácter de fin de línea. Si está trabajando en un entorno como éstos, puede que necesite establecer esta opción.

Comparar archivos por

Esta opción le permite configurar cómo determina VSS si su copia local está actualizada. Las siguientes opciones están en el orden apropiado para incrementar la velocidad:

  • Contenido: compara el contenido completo del archivo local con la copia de VSS. Es el método más lento, pero el más preciso.

  • Suma de comprobación: compara mediante una suma de comprobación almacenada por VSS. Utilice la comparación por suma de verificación en la mayoría de los posibles usos de VSS.

  • Hora: compara los indicadores de fecha y hora. El método exacto de comparación de fecha depende de la configuración de la opción Establecer fecha y hora en archivos locales: si está configurada como Protección, VSS reemplaza la copia local si la hora de la última protección (o adición) es más reciente que la fecha de modificación de la copia local. Si está configurada como Actual (predeterminado) o Modificación, VSS sustituye la copia local si la hora de modificación del archivo de VSS es distinta a la hora de modificación del archivo local.

Reemplazar archivos modificables

Cuando obtiene o desprotege un archivo, VSS copia el archivo a su carpeta de trabajo. Si ya hay una copia editable del archivo en la carpeta de trabajo, reemplazar el archivo puede borrar su trabajo. Esta opción le permite especificar cómo quiere que VSS se encargue de los archivos modificables.

  • Preguntar: Indica a un cuadro de diálogo que le pregunte qué desea hacer para cada operación que vaya a realizar.

  • Reemplazar: Reemplaza (sobrescribe) el archivo local.

  • Saltar: no sustituye el archivo local y genera un error en el panel Resultados si lo tiene en pantalla.

  • Combinar: combina los cambios entre el archivo desprotegido y el que se está obteniendo o desprotegiendo en ese momento. Si el archivo no se puede combinar (es decir, si se trata de un archivo binario), se muestra un error en el panel Resultados si lo tiene en pantalla. Para que esta opción funcione correctamente, su administrador de VSS debe habilitar las desprotecciones múltiples para los archivos implicados en la acción.

Establecer fecha y hora en archivos locales

Esta opción le permite especificar el módo en el que VSS establece la fecha y la hora de los archivos de su carpeta de trabajo. La opción que elija será la hora que verá cuando vea los archivos en el Explorador de Windows.

  • Actual: Cambia la fecha y la hora del archivo por la fecha y la hora actual, siempre que VSS obtiene un archivo. Esto indica al compilador que el archivo acaba de cambiar y hay que volver a compilarlo de nuevo. Es el predeterminado.

  • Modificación: establece la copia local a la fecha y la hora en que se modificó el archivo por última vez.

  • Protección: establece la copia local a la fecha y la hora en que se protegió el archivo por última vez.


Resolver conflictos de combinación con combinación visual

Vea también

Cuando hay un conflicto, VSS utiliza su formato de combinación visual, mostrándolo abajo de manera predeterminada. Así ocurre independientemente de si inicia usted la combinación o la inicia VSS.

El cuadro de diálogo Combinación visual

  • Los dos paneles superiores representan las dos versiones que se están combinando. En el cuadro de diálogo de ejemplo que se muestra más arriba, la combinación se está realizando automáticamente, como resultado de desprotecciones múltiples; por tanto, el archivo de la izquierda está en VSS, y el de la derecha está en su disco duro. En el caso de "Combinación de bifurcaciones", las dos versiones son de proyectos diferentes.

  • El panel inferior representa el resultado de la combinación. Comienza con todos los cambios sin conflicto ya hechos, y cambia dinámicamente conforme trabaja. Si está combinando bifurcaciones, el panel inferior contiene el archivo original desde el que se creó antes la bifurcación.

  • Los tres paneles se desplazan verticalmente juntos, para extenderse tanto como sea posible. (Bajo algunas circunstancias, VSS puede perder temporalmente la sincronización.) Los paneles superiores también se desplazan juntos horizontalmente; la posición horizontal del panel inferior es independiente.

  • Los colores y fuentes se controlan mediante las mismas opciones que se utilizan para la comprobación de diferencias. El estilo de fuente (negrita, cursiva, etc.) no se puede cambiar.

  • El panel inferior es modificable directamente, pero los paneles superiores no.

  • También puede copiar/copias desde los dos paneles superiores y pegar en el panel inferior.

  • Use el menú contextual para resolver conflictos.


Ver (Ficha, cuadro de diálogo Opciones)

Es esta ficha puede establecer las opciones de visualización del Explorador de VSS

Para mostrar la ficha de opciones Ver:

  1. En el menú Herramientas, haga clic en Opciones.

  2. Seleccione la ficha Ver

Opciones de la ficha

Ventana SourceSafe

  • Mostrar panel de resultados — Seleccione esta opción para mostrar el panel Resultados en el Explorador de VSS. El panel Resultados, situado en la parte inferior del Explorador de VSS, muestra los resultados de sus comandos VSS.

  • Mostrar barra de herramientas — Seleccione esta opción para mostrar la Barra de herramientas en VSS. La Barra de herramientas contiene un conjunto de botones que puede utilizar para ejecutar los comandos más habituales.

  • Mostrar barra de estado — Seleccione esta opción para mostrar la barra de estado en el Explorador de VSS. La barra de estado muestra información de estado acerca de VSS, como es la ordenación actual de los archivos en el panel de archivos, el nombre de usuario actual y el número de elementos de la lista de archivos.

Lista de archivos

  • Usar siempre los nombres de archivos en formato MS-DOS — Seleccione esta opción para truncar los nombres de archivo largos que se pueden utilizar en las plataformas de 32 bits. Esta opción permite que la columna correspondiente al nombre de archivo sea más pequeña y también es útil si la base de datos VSS es utilizada por ordenadores con varios sistemas operativos diferentes.

  • Convertir el proyecto seleccionado en el proyecto actual — Esta opción normalmente está seleccionada. Sin embargo, si su red tiene un rendimiento pobre, puede que desee poder desplazarse por la lista de proyectos sin que VSS actualice el proyecto actual. En este caso, desactive esta opción. Si está desactivada, puede presionar la tecla ENTRAR en un proyecto (o hacer doble clic en él con el mouse) para convertirlo en el proyecto actual.

  • Actualizar automáticamente la lista de archivos — Seleccione esta opción para hacer que VSS actualice automáticamente la lista de archivos. La actualización mantiene actualizado el Explorador de VSS, pero también provoca un retraso momentáneo (y una carga de la red). Si selecciona esta opción, especifique el intervalo de actualización en el cuadro de abajo. Si no selecciona esta opción, podrá refrescar la lista de archivos manualmente seleccionando la opción Actualizar lista de archivos del menú Ver.


Advertencias (Ficha, cuadro de diálogo Opciones)

En esta ficha puede especificar si se mostrarán advertencias antes de realizar acciones que puedan producir la pérdida o eliminación accidental de datos.

Para mostrar la ficha de opciones de Advertencias:

  1. En el menú Herramientas, haga clic en Opciones.

  2. Haga clic en la ficha Advertencias

Opciones de la ficha

Cuando elimina un archivo de la base de datos de VSS, VSS le pregunta "¿Realmente desea eliminar?". Algunos usuarios encontrarán útil la advertencia, puesto que impide la eliminación accidental de datos. Otros la encontrarán molesta, puesto que requiere presionar una tecla más. Ésta y otras advertencias de VSS son completamente configurables.

Puede elegir si desea recibir advertencias antes de que VSS ejecute lo siguiente:

  • Deshace la desprotección de un archivo modificado.

  • Eliminar un archivo o proyecto

  • Destruir un archivo o proyecto

  • Purgar un archivo o proyecto

  • Vuelve a la versión anterior de un archivo

  • Desproteger un archivo ya desprotegido — Si esta opción está deshabilitada, las desprotecciones múltiples están desactivadas — consulte con su Administrador de VSS.

  • Salir de VSS


Glosario

A

Administrador de VSS

Responsable de la base de datos de VSS. El administrador utiliza el programa Administrador de VSS para controlar la ubicación de la base de datos, la lista de usuarios y los derechos de acceso de cada usuario, y realiza la configuración y las tareas de copia de seguridad en la base de datos. El nombre de usuario del administrador siempre es Admin.

archivo bifurcado

Archivo cuyo vínculo compartido se rompió al utilizar el comando Bifurcar.

archivo compartido

Archivo utilizado simultáneamente, en su totalidad o en parte, por más de un proyecto.

archivo de palabras clave

Archivo que contiene información de las palabras claves de VSS.

archivo de sólo lectura

Archivo marcado como de sólo lectura en sus atributos de archivo. Un archivo de este tipo se puede ver en un editor de texto apropiado, pero no se puede modificar. VSS marca el archivo como de sólo lectura cuando utiliza los comandos Proteger y Obtener la última versión.

archivo desprotegido

Archivo reservado por un usuario para trabajar con él. Los usuarios desprotegen los archivos para realizar cambios con ellos. En la configuración predeterminada, VSS sólo permite desproteger un archivo a un usuario a la vez. Al desproteger un archivo se copia su última versión en la carpeta de trabajo del usuario.

archivo diario

Archivo de texto que el administrador configura para que registre cualquier acción de VSS que genere una entrada en el historial de un archivo o proyecto. Este archivo se utiliza frecuentemente con propósitos de auditoría.

archivo protegido

Archivos almacenados en la base de datos de VSS y que no están disponibles para su modificación.

arrastrar y colocar

Combinación de características que permite al usuario arrastrar un elemento y colocarlo sobre otro mediante el mouse (ratón). Un elemento puede ser el origen (el elemento que arrastra el usuario) o el destino (el elemento sobre el que el usuario coloca un origen).

Para arrastrar un objeto, haga clic en el objeto y después, manteniendo presionado el botón del mouse, llévelo a su nueva ubicación. Suelte el botón del mouse para colocar el objeto.

B

barra de estado

Barra que aparece en la parte inferior de la ventana del Explorador de VSS y se utiliza para mostrar información del estado de archivos y proyectos, así como información del comando actual.

base de datos de VSS

Base de datos central donde se almacenan todas la copias maestras, historiales, estructuras de proyecto e información del usuario. Un proyecto siempre está en una base de datos; es posible almacenar varios proyectos en una base de datos y puede haber varias base de datos de VSS para almacenar múltiples proyectos.

bifurcar

Proceso de compartir un archivo con otro proyecto y separarlo después en dos o más bifurcaciones. Tras haberse creado una bifurcación, dos archivos (el archivo del proyecto y su contrapartida en otros proyectos) tienen un historial compartido hasta un cierto punto e historiales divergentes después de ese momento.

bloqueo

Sistema de seguridad que sirve para que dos procesos no afecten al mismo registro de una base de datos a la vez. Para coordinar el acceso a registros, VSS aplica el bloqueo nativo, que utiliza funciones del sistema operativo nativo. También se puede configurar VSS para que utilice archivos de bloqueo que crean archivos temporales en la carpeta LOCKS.

C

caracteres comodín

El asterisco (*) y el signo de interrogación de cierre (?) son caracteres comodín. Puede utilizar estos caracteres para hacer coincidir modelos. También puede utilizar los caracteres comodín y los caracteres coincidentes para refinar una búsqueda.

Símbolo | Ejemplo | Utilización
* | qu* encuentra que, quién y queso; *al encuentra tal, cual y mal | Igual que el carácter comodín de MS-DOS asterisco (*), este asterisco coincide con cualquier número de caracteres.
? | s?n encuentra sin, san y son | Igual que el carácter comodín de MS-DOS (?), este símbolo coincide con cualquier carácter único.

Una barra inversa delante de un asterisco o un signo de interrogación de cierre indica un asterisco o interrogación de cierre literales: \* o \? (Esto es necesario si desea buscar asteriscos, signos de interrogación de cierre o barras inversas.) Una barra inversa doble (\\) indica una barra inversa. Se pasará por alto cualquier otra utilización de la barra inversa.

carpeta central

Carpeta central y opcional que contiene las versiones actuales de todos los archivos de un proyecto. La carpeta central no contiene la copia maestra ni la copia local de un archivo. En su lugar, proporciona una ubicación central desde la que se puede ver la estructura global del proyecto y sirve como lugar apropiado para generar o compilar el proyecto.

carpeta de desprotección

Carpeta en la que se desprotege un archivo en VSS. No es la carpeta de trabajo. Si desprotege un archivo, éste se desprotege en su carpeta de trabajo. Para otro usuario, el arhivo está en la carpeta de desprotección. La carpeta de desprotección se muestra en la columna Carpeta de desprotección del panel de archivos; la carpeta de trabajo se muestra bajo la barra de herramientas.

carpeta de trabajo

Carpeta específica del equipo local del usuario utilizada para almacenar archivos cuando se desprotegen de la base de datos de VSS. El usuario lleva a cabo los cambios en los archivos en la carpeta de trabajo y después protege los archivos modificados en la base de datos de VSS para el seguimiento de versiones.

comando Destruir

Quita de forma permanente los archivos y proyectos eliminados de la base de datos de VSS. Una vez destruidos, los elementos no se pueden recuperar.

comando Eliminar

Quita archivos y proyectos de un proyecto de VSS y los marca como eliminados; sin embargo, los elementos aún existen y se pueden recuperar mediante el comando Recuperar.

comando Purgar

Quita de forma permanente los archivos y proyectos previamente eliminados de la base de VSS. Los elementos no se pueden recuperar una vez purgados.

combinación automática

Cuando varios usuarios tienen el mismo archivo desprotegido, VSS combina sus cambios en el archivo al protegerlos.

combinación visual

Operación de combinación en la que se resuelven visualmente los conflictos en una interfaz gráfica fácil de usar.

combinar

Proceso de combinar diferencias en dos o más copias modificadas de un archivo a una nueva versión del mismo. Una combinación implica al menos dos archivos diferentes (que pueden ser versiones diferentes del mismo archivo o cambios realizados a la misma versión del archivo) y crea un archivo nuevo a partir de los resultados de la combinación. La combinación puede ocurrir cuando el usuario combina dos bifurcaciones o cuando se utiliza el comando Proteger u Obtener la última versión.

conflicto

Dos o más cambios diferentes en la misma línea de código en una situación de desprotección múltiple. VSS reconoce los conflictos durante una operación de combinación, y los marca de alguna manera.

contraseña

Cadena de texto utilizada como medio de seguridad para comprobar la identidad de un usuario. Para utilizar la base de datos de VSS se requiere a menudo la contraseña del usuario.

control de código fuente

Administración del historial de cambios de un archivo y relación del archivo con un grupo mayor de archivos relacionados conocido como proyecto. El control de código de origen es una parte vital del desarrollo eficiente de aplicaciones de software. VSS es un control de código fuente orientado a proyecto.

control de versiones

VSS mantiene varias versiones de un archivo, incluyendo un registro de los cambios en el archivo de versión a versión.

copia local

Copia de un archivo almacenado en la carpeta de trabajo del equipo local. La copia local puede ser diferente del la copia maestra de VSS si se modificó desde la última desprotección o si otro usuario modificó la copia maestra mientras trabajaba con la copia local.

copia maestra

Última versión protegida de un archivo almacenada en la base de datos de VSS, como contraposición a la copia local de un archivo en la carpeta de trabajo.

cuadro de diálogo Avanzadas

Cuadro de diálogo que contiene configuraciones opcionales o adicionales. Muchos cuadros de diálogo de VSS tienen un botón Avanzadas que muestra estas configuraciones adicionales.

D

delta inverso

Tecnología de almacenamiento de cambios utilizada por VSS en la que se almacenan los cambios incrementales con respecto a un archivo de referencia, en lugar de almacenar cada versión sucesiva del archivo en su totalidad. En VSS, la versión actual de un archivo se utiliza como referencia y se guardan los cambios con respecto a las versiones previas. Así se requiere menos requisitos de almacenamiento en disco y menor tiempo de acceso, ya que sólo se almacena en su totalidad en la base de datos la versión actual.

delta

En VSS, delta es la diferencia entre la versión X de un archivo y la versión X [image] 1 del mismo archivo. VSS utiliza la tecnología de delta inverso para almacenar los cambios.

derechos de acceso

Niveles de permisos de los usuarios que concede el administrador de VSS para usar la base de datos de VSS Los niveles de derechos de acceso son Leer, Desproteger, Agregar y Destruir.

desarrollo multiplataforma

VSS admite compatibilidad transparente de archivos entre varios procesadores y sistemas operativos.

desprotección múltiple

Desprotecciones simultáneas por parte de dos o más usuarios. El administrador de VSS debe habilitar la desprotección múltiple.

E

encabezado de archivo

Texto que aparece al principio de un archivo y que contiene información, como el número de revisión del archivo, el autor, la fecha y hora de la última modificación, etc. Esta información aparece normalmente como comentarios en los archivos de lenguaje de programación, por lo que no interfiere con la misma.

entorno de desarrollo

Conjunto de herramientas de desarrollo de software, que se presenta como un entorno unificado en el que puede trabajar más eficientemente el programador de software. Microsoft Visual Basic y Microsoft Visual C++ son ejemplos de esos entornos.

esconder

Impedir que un proyecto se vea afectado por determinados comandos, por ejemplo Obtener, Desproteger, Proteger, Deshacer desprotección y Mostrar diferencias de proyectos.

etiqueta

Nombre definido por el usuario que puede adjuntar a un número específico de versión de un archivo o proyecto.

expansión de palabras clave

Proceso que utiliza VSS para reemplazar palabras clave de VSS con información significativa de encabezado cuando utiliza los comandos Proteger y Agregar archivos. Por ejemplo, la cadena "$Revision:   $" indica a VSS que expanda automáticamente la palabra clave Revision con el número de versión del archivo actual.

Explorador de VSS

Interfaz gráfica de usuario de VSS. De manera predeterminada, contiene tres paneles: El panel izquierdo de proyecto y el panel derecho de archivo, así como la barra de herramientas, la barra de estado, los menús y así sucesivamente. El Explorador de VSS se muestra cuando se hace clic en el icono de VSS.

F

formato de columna

Opción de formato utilizada con expansión de palabras clave en un archivo. Esta opción (utilizando dos signos de dos puntos en vez de uno en las instrucciones de palabra clave) le dice a VSS que alinee las columnas de información de palabras clave para obtener una presentación más legible.

H

herencia

Efecto heredado de variables en los archivos de inicialización de VSS que reciben los subproyectos de sus proyectos primarios. Las variables de estos archivos se pueden agrupar bajo encabezados para especificar su comportamiento. Si se establece una variable en el archivo de inicialización antes de los encabezados de grupo, la variable afectará a todos los proyectos; las variables de los subproyectos heredan el efecto.

historial

Registra los cambios de un archivo desde que se agregó inicialmente a VSS. Con el historial del archivo, puede volver a cualquier punto de la historia del archivo y recuperarlo tal y como era en ese momento. El cuadro de diálogo Historial del proyecto muestra el registro de los eventos significativos del proyecto actual, como etiquetado y eliminación o agregación de archivos y subproyectos.

I

inicio de sesión

Proceso de introducción y comprobación del nombre y la contraseña de un usuario para tener acceso a la base de datos de VSS.

L

lista de archivos

Lista de archivos del proyecto actual, que se pueden encontrar en el panel de archivos de la ventana del Explorador de VSS.

lista de proyectos

Lista de todos los proyectos disponibles en la base de datos de VSS; la lista de proyectos se encuentra en el panel izquierdo de la ventana del Explorador de VSS.

lista de usuarios

Lista de usuarios que pueden usar la base de datos de VSS. La lista la mantiene el administrador de VSS y se muestra en la ventana principal del Administrador de VSS.

M

marcador de conflicto

Símbolo utilizado para designar cambios conflictivos en un archivo. Estos símbolos son:

Símbolo | Descripción
<<<<<< | versión de SourceSafe
====== | separador de conflicto
>>>>>> | versión local

VSS coloca esas marcas en el archivo tras un conflicto de protección o una operación de combinación, de forma que se pueda encontrar y resolver fácilmente.

N

nombre usuario

Cadena única que identifica a un usuario dado. Se utiliza para iniciar sesión.

número de versión

Número que indica el número de revisiones que ha sufrido un archivo desde que se agregó a VSS. Dicho nombre aparece en el cuadro de diálogo Historial. Los números de versión son siempre números enteros.

O

operación recursiva

Operación que se aplica a un proyecto y a todos los archivos y subproyectos de ese proyecto. Por ejemplo, puede utilizar el comando Desproteger de forma recursiva para desproteger simultáneamente todos los archivos de la lista de proyectos y evitar tener que seleccionar cada archivo individualmente.

P

palabra clave

Específico de VSS. Puede utilizar palabras clave en los archivos de texto para crear automáticamente un encabezado de archivo con información específica de la versión. Utilice palabras clave de VSS para colocar información desde VSS directamente en un archivo de texto.

panel de archivos

Lado derecho de la ventana del Explorador de VSS. Este panel contiene la lista de archivos, que es una lista de todos los archivos del proyecto actual.

panel de proyectos

Lado izquierdo de la ventana del Explorador de VSS. El panel de proyectos contiene la lista de proyectos, una lista de todos los proyectos disponibles en la base de datos de VSS.

panel de resultados

Porción de la ventana del Explorador de VSS donde se muestran los resultados de las operaciones de VSS. Por ejemplo, cuando protege un archivo, en este panel aparece el nombre del archivo que está protegiendo.

propagación de derechos

Asignación predeterminada de derechos a un usuario en subproyectos basada en los derechos asignados en el proyecto primario. Esta asignación predeterminada se puede modificar.

proyecto actual

Proyecto seleccionado en el panel de proyectos de la ventana del Explorador de VSS.

Proyecto de sitio Web.

Proyecto marcado como un proyecto de sitio Web en el Administrador de VSS Esta designación permite la utilización de comandos de sitio Web especiales tales como Despliegue, en este proyecto.

proyecto primario

Proyecto en el que existe un archivo o subproyecto. Por ejemplo, el primario del archivo $/Proyecto/Abc.txt es $/Proyecto y el primario del proyecto $/Proyecto es el raíz ($/).

proyecto raíz

Proyecto de máximo nivel con el nombre $/ en la lista de proyectos. Todos los proyectos de una base de datos de VSS son subproyectos del proyecto raíz.

proyecto

Grupo de archivos asociados, normalmente todos los archivos necesarios para desarrollar un componente software. Es posible agrupar los archivos en un proyecto para crear subproyectos. Proyectos que se pueden definir de cualquier forma que tenga sentido para el usuario. Por ejemplo, un proyecto por versión, o un proyecto por lenguaje. Los proyectos tienden a estar organizados de la misma manera que los directorios de archivos.

S

seguimiento de versiones

Proceso de mantenimiento de registros del seguimiento del historial de un archivo desde su versión inicial hasta la versión actual. Se siguen los cambios a un archivo como parte de este proceso.

seguridad

VSS tiene dos niveles de seguridad: seguridad predeterminada y seguridad de proyecto. La seguridad predeterminada proporciona dos derechos de acceso: lectura y escritura, y sólo lectura. Cuando está activada la seguridad de proyecto, hay cuatro derechos de acceso disponibles por usuario y proyecto: Leer, Desproteger, Agregar y Destruir. Cada derecho sucesivo incluye los derechos que le preceden. El derecho de acceso Destruir proporciona acceso ilimitado y es equivalente a los derechos de Leer y escribir bajo la seguridad predeterminada.

Sistema de seguridad del proyecto

El más restrictivo de los dos sistemas de seguridad que proporciona VSS. De manera predeterminada, está deshabilitado. Cuando lo habilite el administrador, esta características permite a un administrador establecer derechos de acceso por usuario y por proyecto. Vea derechos de acceso.

subproyecto

Proyecto dentro de un proyecto primario.

V

versión actual

Versión del archivo utilizado más recientemente en la base de datos de VSS. La versión actual tiene el mayor número de versión de un archivo en VSS.

vínculo compartido

Vínculo entre un archivo compartido entre uno o más proyectos. Este vínculo sirve para actualizar el archivo compartido con cualquier cambio protegido, sin importar desde qué proyecto se desprotegió.


Sintaxis de nombres de VSS, convenciones y limitaciones

VSS tiene la siguiente sintaxis, convenciones y limitaciones para los nombres:

  • Los nombres de usuario y los nombres de etiquetas pueden tener hasta 31 caracteres de longitud.

  • Las contraseñas de usuario pueden tener hasta 15 caracteres de longitud.

  • Las cadenas de búsqueda pueden tener hasta 255 caracteres. Los nombres de archivo incluyen espacios sobre sistemas operativos que los admitan.

  • Las rutas de proyecto pueden tener hasta 259 caracteres (incluyendo el nombre de archivo).

  • Las etiquetas de archivos o proyectos pueden tener hasta 31 caracteres.

  • Las cadenas de búsqueda pueden tener hasta 63 caracteres.

  • Los comentarios pueden tener hasta 63 caracteres para el comando Desproteger y 4 KB para los demás comentarios.

  • En los archivos de inicialización de VSS, las líneas pueden tener hasta 511 caracteres de longitud.

  • El resultado de la suma de los archivos y los proyectos (juntos) de la base de datos de VSS no puede ser superior a 4000 millones.

  • El resultado de la suma de los archivos y los proyectos (juntos) de cualquier proyecto de la base de datos de VSS no puede ser superior a 8191.

  • El tamaño máximo permitido para un archivo almacenado en la base de datos de VSS es de 2 gigabytes.

  • El máximo número de versiones de un único archivo que VSS puede almacenar es de 32.767.

La mayoría de los nombres de VSS no pueden empezar ni terminar con espacios en blanco ni tabuladores. Puede utilizarse cualquier carácter para los nombres o etiquetas, excepto los siguientes:

  • Signo de moneda ($)

  • Signo @

  • Corchetes angulares (< >), corchetes ([ ]), llaves ({ }) y paréntesis (( ))

  • Dos puntos (:) y punto y coma (;)

  • Signo igual (=)

  • Circunflejo (^)

  • Símbolo de canalización (|)

  • Asterisco (*)

  • Exclamación (!)

  • Barra oblicua (/) y barra inversa (\)

  • Signo de porcentaje (%)

  • Interrogación de cierre (?)

  • Coma (,)

  • Comillas (sencillas o dobles) (' ")

  • Tabulador

VSS acepta los nombres de archivo UNC (Convención de nomenclatura universal). Si su sistema operativo de red acepta nombres de ruta UNC, puede utilizarlos en cualquier lugar para especificar un nombre de ruta.

VSS no acepta la utilización del carácter @ en redes Banyan Vines. Los usuarios de Banyan pueden tener acceso a toda la funcionalidad de VSS si utilizan letras asignadas de unidades de red.